• 0
dravik

Slow transfer speed on single files

Question

Hi All,

 

I am kind of new to the Xpenology group, but I am a data communication professional.

 

I connect to the system from outside of my house using VPN.

 

I have a 50/50mbit connection.

 

Files download really slow from outside of my network (inside works fine). I am talking about 1000kb/s. However, if i download the same file at the same time I get another 1000kb/s. And a 3rd file at the sime time gives me another 1000kb/s. Even if I download the same file multiple times in parallel I get 1000kb/s for each connection.

 

So my connection is fast enough, my VPN works fast enough, but single-file transfer are really slow.

 

I have already tried:

  - local file transfer inside of my network. They work fine and get over 100mbit.

  - SMB file transfer over VPN, also 1000kb/s.

  - FTP over VPN, also 1000kb/s per connection.

  - Disabling encryption and VPN, also 1000kb/s.

  - Using teamviewer: speed goes up to 80mbit/s.

 

Any ideas to get those singe-file speed up?

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

What kind of VPN do you use? Router based or Synologys VPN? Did you set any limitations within DSM?

Share this post


Link to post
Share on other sites
  • 0
25 minutes ago, jensmander said:

What kind of VPN do you use? Router based or Synologys VPN? Did you set any limitations within DSM?

Thanks for helping. 

 

VPN enabled or direct connection after opening a port has the same result. I do use Openvpn server directly on xpenology. 

 

I have not set any limitation on the VPN server, user accounts and other synology configuration (I think at least) . 

Share this post


Link to post
Share on other sites
  • 0

Could be several reasons then. Is the firewall enabled in DSM? What’s about the hardware of your Xpenology, especially the CPU? Does DSM indicate high loads when you use it‘s VPN? And your router? Does it have any bandwidth limitations, packet inspection, QoS or anything like that enabled? From what you described anything that passes your router is limited. TeamViewer has it‘s own tunneled peer network, usually using port 80 or 443 which aren’t blocked for traversal traffic (in to out) on most routers (btw.: 80mbit transfer speed via TeamViewer seems technically not possible since your upstream is 50mbit, maybe you receive cached speed results). A last point is your ISP. In rare cases they limit traffic for common VPN services by packet inspection and analysis. 

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, jensmander said:

Could be several reasons then. Is the firewall enabled in DSM? What’s about the hardware of your Xpenology, especially the CPU? Does DSM indicate high loads when you use it‘s VPN? And your router? Does it have any bandwidth limitations, packet inspection, QoS or anything like that enabled? From what you described anything that passes your router is limited. TeamViewer has it‘s own tunneled peer network, usually using port 80 or 443 which aren’t blocked for traversal traffic (in to out) on most routers (btw.: 80mbit transfer speed via TeamViewer seems technically not possible since your upstream is 50mbit, maybe you receive cached speed results). A last point is your ISP. In rare cases they limit traffic for common VPN services by packet inspection and analysis. 

 

The firewall in DSM is disabled.

The hardware I am using is an old pc of the company I work for, which has an intel i7 940.

DSM seems ok with the loads in am using, i can not check the router. The device is also my modem and does not show a lot of data. However, as 3 files are 3 times faster, even over VPN i think the router will only pass trough 1 AES encrypted stream?

None bandwidth limitations enabled as far as I can find.

I know 80mbit is over 50mbit... but sometimes I get a little higher than I pay for or it is some kind of burst behavior.

 

So maybe it would be a good idea to see what happens if I disable VPN, forward port 80 to the nas. Just for testing only ofcourse, I don't want to use the standard ports.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.