cedrique30

Accéder à des dossiers partagés avec WebDav

Recommended Posts

Bonjour.

 

Je souhaiterais pouvoir accéder à des dossiers partagés de mon NAS en réseau interne mais également externe en passant par l’explorateur Windows.

 

Je ne souhaite pas utiliser QuickConnect et j'aimerais éviter d'installer d'autres logiciels si Windows permet vraiment de faire cela.

 

J'ai donc installé le module WebDav sur mon NAS, puis j'ai créé des utilisateurs sur mon NAS pour pouvoir faire des tests.

 

J'ai créé des dossiers que j'ai partagés et j'ai configuré les acces par rapport aux nomes des utilisateurs avec ADMIN comme utilisateur ayant accès a tout.

 

J'ai ouvert les ports 5000 / 5005 et 5006 dans ma BOX que j'ai redirigés vers l'adresse ip de mon NAS.

 

J'ai exporté de mon NAS les certificats que j'ai ajoutés a Windows.

 

Je suis allé dans "ORDINATEUR" pour Connecter un lecteur réseau.

Je met l'adresse ip externe de ma box https://xxx.xxx.xxx.xxx:5006/ ou https://xxx.xxx.xxx.xxx:5006/admin/

 

Quand j'essai de me connecté avec plusieurs noms d'utilisateurs différents cela me propose toujours d'écrire le nom d'utilisateur et le mot de passe, je valide, ça peux me le demander 3 fois d'affilé, puis ça me met un message d’erreur (parfois différents selon les essais).

 

Par exemple : Echec d'ouverture de session sur le réseau.

ou, Un périphérique attaché au système ne fonctionne pas correctement.

 

Je ne sais pas ce que j'ai pu oublié.

 

Si vous auriez des idées.

Merci :-)

 

 

 

Share this post


Link to post
Share on other sites

Hello,

 

Si tu es (encore^^)sous Windows 7, il faut installer un KB spécifique pour pouvoir avoir le client Webdav de Windows.

Avec les versions >= de Windows 8, c'est natif normalement. Avant de tenter une connexion HTTPS, essaie déjà en HTTP et sur ton réseau local, genre http://192.168.1.x:5005/[NomDuPartage]

Share this post


Link to post
Share on other sites

Je suis sous Windows 10 Famille, je suppose donc que c'est également natif comme pour Windows 8.

Quand vais directement sur \\192.168.1.91\test avec l'explorateur windows, ça me demande l'identifiant, le mot de passe et ça fonctionne.

 

Quand j'essai d'ajouter un lecteur réseau avec le lien suivant

http://192.168.1.91:5000/test/

j'ai les mêmes messages d’erreurs, peu importe le nom d'utilisateur que j'entre.

"Un périphérique attaché au système ne fonctionne pas correctement."

 

Dans le NAS il est possible d'ajouter une connexion a distance, de choisir WebDav et d'entrer les mêmes informations.

(donc en gros je connecte le NAS sur son propre dossier partagé si je comprend bien).

Quand j'essai de faire la connexion avec ce menu, j'ai le message "Connexion refusée par le serveur"

 

Je ne sais pas si ça peut aider..

Share this post


Link to post
Share on other sites

Faut le faire sur le port 5005 (celui qui correspond au service Webdav,  le port 5000 c'est pour DSM). Vérifie aussi si tu n'aurais pas un firewall d'activé

Share this post


Link to post
Share on other sites

J'ai désactivé le Firewall de ma box, j'ai également ajouté les ports dans le pare-feu de Windows.

Le résultat est toujours le même en écrivant l'adresse de la même manière.

 

Cependant! Si j'ajoute un lecteur réseau et que j'écris l'adresse ip externe de ma box comme cela \\xxx.xxx.xxx.xxx\test et bien ça fonctionne. (sans mettre http:// et sans mettre de port)

 

Du coup je ne sais pas si ça a un rapport avec le module WebDav et je ne sais pas quel port est utilisé. Mais ça me demande bien un identifiant et je n'ai accès qu'aux dossiers pour lesquels les autorisations sont configurées.

 

Est-ce que du coup je peux considérer que le problème est réglé, ou est-ce que c'est pas normal?

Share this post


Link to post
Share on other sites
Citation

\\xxx.xxx.xxx.xxx\test

Bonsoir,

ça c'est la syntaxe pour connecter un partage réseau sous Windows, avec le protocole CIFS, donc via Samba, pas WebDav.

 

Jacques

Share this post


Link to post
Share on other sites
Il y a 12 heures, cedrique30 a dit :

Est-ce que du coup je peux considérer que le problème est réglé, ou est-ce que c'est pas normal?

Ben ton topic concerne Webdav, pas le partage de dossiers Windows. Ce n'est pas du tout le même protocole comme le fait remarquer @JacquesF. Donc non ton pb n'est pas réglé selon moi.

 

Pour faire du Webdav avec DSM les ports par défaut c'est le 5005 sur HTTP et 5006 sur HTTPS. Lorsque tu fais du partage de dossier avec Windows, la syntaxe indique un autre protocole '\\' qui n'oblige pas de spécifier de n° de port (pour info ce sont les 445 et 139 de mémoire).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.