Sign in to follow this  
elvosparsley

Logitech Media Server WMA playback in DSM 5

Recommended Posts

I've got my system pretty much all setup and working great, apart from one thing.

 

A lot of my music is WMA encoded and I use Logitech Media Server for use with SqueezePlay.

 

On previous OS builds I've used the PlayWMA plugin to control MPlayer to transcode to MP3 for playback.

However much I've tried I can't get MPlayer to compile and I can't find an ipkg release for it either.

 

I've also tried using the ffmpeg work around shown here:

http://wiki.slimdevices.com/index.php/WMA

 

Unfortunately all I get is hiss, even though BBC IPlayer listen live works fine, which hints at the wrong version of ffmpeg (currently 2.02 installed via ipkg)

 

Really scratching my head here, anyone manage to compile MPlayer or have a package that I could use?

Share this post


Link to post
Share on other sites

Found the solution after having the same problem with Madsonic.

 

Install Audiostation first.

 

Then in /volume1/@appstore/SqueezeCenter/convert.conf

 

change wma mp3 * * to:

 

wma mp3 * *

/usr/syno/bin/ffmpeg -i $FILE$ -ab 160000 -v 0 -vn -f mp3 -

 

You can change the bitrate to suit.

 

The same can be done in Madsonic's transcode settings and then they'll both play sweet as a nut!

 

Hope this helps others.

Share this post


Link to post
Share on other sites
Sign in to follow this