Nvidia Runtime Library


Recommended Posts

This is really interesting work.  I have a Quadro P620 passed through to a Plex container on my Unraid box and works great - but I would much prefer to use Xpenology.

 

I followed this guide to get it working on Unraid where a lot of the hard work is done in one of their plugins.

 

Fingers crossed for us on the Xpenology side!

 

Edit:

..although looks like the plugin has been pulled as Unraid now supports Nvidia directly.. [ link ]

 

 

 

 

Edited by flannell
Link to post
Share on other sites
В 12.01.2021 в 02:13, RedwinX сказал:

Hey All, 

 

Very intresting topic. I have installed a GT 1030 in a microserver gen 8, with DSM 6.2.3. I have compiled a custom version of ffmpeg, and still have the same error, cuda initialization failed. 

Driver is ok (I think) :

image.png.aa8215bdd5ce636cc4ba4bfed6d158da.png

image.png.23f1d62003afe1c3b35ca2773e656aa9.png

 

Trying to install NVIDIA Driver : 

image.png.defbcb2b91a0f43848ab442d2d7cc205.png

GT1030 does not support NVENC.

https://developer.nvidia.com/video-encode-and-decode-gpu-support-matrix-new

image.thumb.png.bf5f6d88c78d29d6815956448f7c70b3.png

 

I have a Quadro P400 rev 1.0 (HP). Can test, if someone can say how. 

nvidia-smi shows P400. How to test ffmpeg?

Edited by Demitsuri
Link to post
Share on other sites
  • 4 weeks later...

if i change the spk info with an editor like Notepad++ i get errors with unkown fileformat 

has any one got a working spk file for the DS3617xs 

 

I see that the 3617xs has an broadwell arch and not the denverton

The 3617xs  has an Xeon D cpu and the dva3219 has an atom based cpu 

i geus this wont even happen 

Edited by sojab0on
found that ds3617xs and dva 3219 are differnt cpu types
Link to post
Share on other sites

i got teh package to install but now when i start nvidia-smi it states 
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
and i cant get it to do it 

installed the NVIDIARuntimeLibrary-dva3219-1.0.1-0014.spk with the INFO file edited to show no model 

Copied the .ko files from the nvidia_440.44_3615_623.zip that was given in a previous post to the /usr/lib/modules/ and ran the 
insmod on all the .ko files but it gave back errors 

 insmod /usr/lib/modules/nvidia.ko
insmod: ERROR: could not insert module /usr/lib/modules/nvidia.ko: Unknown symbol in module
ash-4.3# insmod /usr/lib/modules/nvidia*.ko
insmod: ERROR: could not insert module /usr/lib/modules/nvidia-drm.ko: Invalid parameters

After switching back to the 0011 spk smi started working and the insmod worked as well 
for some reason after a reboot the .ko files arent loaded and smi goes back to cant communicate with driver until i rerun insmod for the .ko files


but now its says 
 nvidia-smi
Unable to determine the device handle for GPU 0000:13:00.0: Unknown Error
Have and GTX690 to test with and in a newer amd build a RTX2070 in bouth i get this error 

quadro P2000 is underway 

 

any sugestions

after changeing a VM value hypervisor.cpuid.v0 = FALSE the nvdia-smi workend and showed 

 

ash-4.3# nvidia-smi
Sun Feb 14 12:55:15 2021
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 381.22                 Driver Version: 381.22                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 680     Off  | 0000:13:00.0     N/A |                  N/A |
| 30%   38C    P0    N/A /  N/A |      0MiB /  1999MiB |     N/A      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|=============================================================================|
|    0                  Not Supported                                         |
+-----------------------------------------------------------------------------+

on the xeon esxi system with teh gtx 680 

now its as most of us could not get to work the HW transcode to cuda 

 

Edited by sojab0on
Nvidia-smi started running after spk version cahnged
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.