• 0
el_tuner_fou

Besoin d'aide pour problème HDD non visible dans DSM

Question

Bonjour a tous, 

 

Après plusieurs recherche sur différents forums, tuto, etc . . .je n'arrive toujours pas a résoudre mon problème.

 

Pour commencer :
Hardware = Carte-mère ASUS h170m-Plus, Proc. Intel G4400, Ram G-Skill 8Go DDR4, carte LSI Megaraid 9260-8i et carte HP SAS Expander.
Software = "Jun's Loader v1.03b DS3615xs (Synoboot_3615.zip)", "DSM_DS3615xs_24922.pat" et "12.15.0-0239_MR_2108_SAS_FW_2.130.403-4660 (dernier firmware LSI 9260-8i)".

Je suis sur la version actuelle : DSM 6.2.2-24922 Update 3

 

L'installation s'est parfaitement déroulée, sans aucun soucis.

 

Mais voilà, je rencontre 2 soucis :
- le 1er est dérangeant mais pas ultra dramatique. En effet, si je lance un "Redémarrer" ou "Eteindre" depuis l'accueil, DSM s'arrête mais, le "PC matériel" continu de tourner. Obligé donc d'agir sur le bouton Power ou Reset. C'est pas vraiment tip top  

 

- le second soucis par contre est ultra important, et c'est surtout pour celui-ci que j'en viens vers vous. En effet, je possède 6 disques durs SSD branchés en sata sur la carte-mère? Ceux-ci apparaissent bien dans DSM, et j'ai créé mes volumes. Mais je possède aussi 20 disques durs branchés sur la carte LSI 9260-8i et SAS Expander, mais voilà, eux ne sont pas visible dans DSM. Je désespère vraiment. Le firmware de la carte LSi est dans sa dernière version, elle est accessible depuis le Bios, je peux accéder au Web-Bios Interface (pour créer mes disques virtuels), mais dans DSM, rien, nada.

 

Ce qui est assez curieux, c'est que je possédais une ancienne configuration a base de Supermicro X8DTL-3F, dual Xeon E5645 et 48Go de ram, DSM en version 5.1-5055, et tout fonctionnait très bien avec la carte LSI, je voyais bien mes disques durs dans DSM.

 

Avez-vous donc une idée de pourquoi mes disques durs n'apparaissent pas? Quelque chose que j'ai mal fait? Qui manque?

 

Je vous demande vraiment de l'aide, j'ai cherché partout mais je ne trouve pas  

Je vous remercie énormément par avance pour votre aide car là, je suis vraiment dépité, surtout qu'a part ce gros désagrément, le reste a l'air de super bien fonctionner (dernière version de Plex, idem de Logitech Media Server, etc....). Mas pourquoi je ne vois pas les disques durs relié a la carte LSI???

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Salut,

 

Je pense tout simplement que le loader ne contient pas les drivers de ta carte controleur. Ton ancienne config devait les supporter mais plus la version est récente moins les drivers sont inclus... dsl.

Le plus simple étant de passer sur VMWare ESXi dans ton cas.

 

Si tu souhaites rester en baremetal : pour ton pb d'extinction plusieurs raisons ont été abordées ici : soit un mauvais paramétre dans le BIOS, soit une incompatibilité avec le loader 3615XS et ton matos, essaie le 3617XS

Share this post


Link to post
Share on other sites
  • 0

Peut être un essai avec dsm 6.1.7 qui contenait plus de drivers pour vérifier qu'au niveau hardware tout fonctionne.

 

Share this post


Link to post
Share on other sites
  • 0

Merci beaucoup pour vos réponse.

En effet, j'ai pris la version DS3615XS car a priori la plus "compatible".

 

Sur un autre forum, j'ai trouvé ceci:

2023982305_xpenologyDS3617XS6.2.thumb.png.6da4e7b9bf9eaf0b2694127a40ca1a51.png

On vois qu'il utilise le loader v1.03b, mais avec la version DS3617XS, donc, ce n'est pas le même loader. Des drivers supplémentaires?

Le matos qu'il utilise est quasiment similaire au mien : G4400, DDR4 2133, LSI 9260-8i.

 

Quand pensez-vous? J’essaie la version loader v1.03b - DS3617XS?

Par contre, si je comprend bien, il utilise la version DSM 6.2 update 2. (c'est a dire? version 6.2-23739-2, c'est bien ça? Je commence a voir du mal a suivre avec toutes ces versions...)

Donc, si je récapitule, ce qui devrai fonctionner serait le loader v1.03b, version DS3617XS, avec DSM 6.2-23739-2.

 

Après, pour l'histoire de la VMWare ESXi, ouch, ça m'a l'air bien compliqué. Alors oui, je suis pas très fan et a l'aise avec la virtualisation, donc si je pouvais rester en version BAREMETAL, ça m'arrangerai énormément.

 

Je suis assez deg de pas pouvoir rester en 6.2.2 update 3 car tout à l'air de bien fonctionner sinon, grrrr, galère.

Après, si je ne dis pas de bêtise, en version 6.2-23739-2, je devrai tout de même bénéficier des dernières versions de Plex, Logitech Media Server, et autres applis . . .

J'attends vos réponses, mais je pense que je vais tester cette solution.

Share this post


Link to post
Share on other sites
  • 0

Pas de réponses? D'avis?

Bon, cet après-midi, après la débauche, je vais tenter une nouvelle installation avec :

- Jun's loader v1.03b

- version DS3617xs

- DSM 6.2-23739 (puis update 2).

 

Je reviendrai dire si tout est ok ou pas.

Share this post


Link to post
Share on other sites
  • 0
Le 22/10/2019 à 13:56, el_tuner_fou a dit :

Après, si je ne dis pas de bêtise, en version 6.2-23739-2, je devrai tout de même bénéficier des dernières versions de Plex, Logitech Media Server, et autres applis . . .

Oui totalement

 

il y a 16 minutes, el_tuner_fou a dit :

- Jun's loader v1.03b

- version DS3617xs

- DSM 6.2-23739 (puis update 2).

Ca me parait pas mal niveau compatibilité

Share this post


Link to post
Share on other sites
  • 0

Re-

 

Me revoila comme promis.

Donc hier soir, ré-install avec :

- jun's loader v1.03b

- version DS3617xs

- DSM 6.2-23789.

 

1ère chose, avec la version DS3617xs, les "reboot et shutdown" fonctionnent normalement.

2ème chose, avec DSM 6.2-23789, mes disques durs rattachés à la carte Lsi 9260-8i et HP Sas Extender sont vus dans DSM.

 

Me reste a créer les volumes sur les disques durs, et ce sera ok.

 

P.S: Plex, Logitech Media Server, Tautulli, etc... sont dans leurs dernières versions, nickel.

 

Au final, dommage pour la version DSM 6.2.2-24922, mais bon doit manquer des pilotes (version encore trop récente?)

Quand a la version DS3617xs, ça corrige mon problème de reboot et shutdown hardware.

 

 

Share this post


Link to post
Share on other sites
  • 0

Etant dans le domaine de la sécurité, avoir toujours la dernière version ne veut pas dire disposer de la meilleure solution sécurisée. Il faut toujours prendre en compte tes besoins au regard des versions disponibles. Si tu n'as pas besoin des nouvelles fonctionnalités offertes par la 6.2.2. ce n'est pas grave de rester en 6.2. Les nouvelles fonctionnalités offertes (s'il y en a) tirent potentiellement des dépendances vers des versions de librairies contenants des vulnérabilités là où une version plus ancienne peut ne pas être concernée.

 

Si tu veux toujours avoir la dernière version malgré tout avec ton matos tu devras nécessairement passer par ESXi ou alors recompiler toi même le loader pour y ajouter les drivers...

Share this post


Link to post
Share on other sites
  • 0

En effet, la version 6.2.2 ne m'apporte pas vraiment grand chose de plus que la version 6.2 pour l'utilisation que j'en fait.

 

Mon but était avant tout un changement de materiel (ancienne carte mere Supermicro dual Xeon, qui a force pesait énormément sur la facture EDF).

En même temps, je voulais profiter du changement pour avoir une version plus récente de DSM pour avoir les dernières versions de Plex et Logitech Media Server, qui elles, ont de gros changements.

 

Au final, j'ai un serveur qui consomme énormément moins, et les dernières versions de Plex et Lms. Je suis assez satisfait du coup.

 

Le seul truc que je n'ai pas réussi a faire, c'est faire la mise a jour pour passer en update 2 (j'ai du me planter dans le fichier peut-être, bizarre).

 

Encore merci poir l'aide, remarques et avis.

 

Share this post


Link to post
Share on other sites
  • 0

Re-

 

Bon passage a la version 6.2-23789 update 2 effectué avec succès.

 

Ceci dit, des idées dans la tête, mais besoin d'aide pour pas faire de conneries sans savoir ce que je fait.

 

Donc, pour l'histoire, actuellement j'ai une carte Lsi Megaraid 9260-8i, c'est une très bonne carte MAIS, car il y a un MAIS, je n'aime pas trop (pas du tout en fait, mdr) le système de config de la carte (WebBios).  En effet, il faut créer des Virtual Device, or moi, ben je n'utilise pas le Raid matériel.

Ce que j'aimerais dans l'absolu, c'est brancher mes disques durs et hop, ils sont disponibles dans xpenology et il y a plus qu'a (comme les sata de la carte-mère donc).

En effet, j'utilise chaque disque individuellement car j'utilise ce NAS seulement comme "stockage disponible h24" (mais pas pour sauvegarde, elles sont sur des disques durs externes).

Chaque disque comprend des fichiers, et quand le disque lâche, je supprime le volume, disque poubelle, installation nouveau disque, copie des fichiers et hop, c'est reparti. Donc gestion hyper simple, rapide, sans prise de tête.

Ce que je sais, c'est que ce n'est pas possible avec cette carte Lsi 9260-8i, car obligé de passer par des VD.

 

Du coup, en cherchant, je suis tombé sur la LSI 9211-8i (puce LSI SAS2008), et surtout, qui peux fonctionner en mode IT. 

Mais voilà, ai-je bien compris ce type de fonctionnement?

Si je comprend bien, le mode IT (pour "Initiator Target") supprime le micrologiciel RAID, et du coup, présente chaque disque individuellement à l'hôte.

Du coup, rien a faire dans le bios de la carte Raid, et encore mieux, cela accélère le temps de démarrage et redémarrage car plus nécessaire de charger le bios.

 

Donc, si c'est bien ce que je pense, ce serait le top pour moi, car en effet, chaque rajout de disque dur, il est disponible comme si il était branché sur la carte-mère.

Ai-je bien compris ou je me trompe totalement. Car en effet, je serais HYPER intéressé par ce système. De plus, la carte LSI ne coute pas grand chose, et sur eBay on en trouve même déjà flasher en mode IT, que demander de plus?!

 

 

Share this post


Link to post
Share on other sites
  • 0

Pour résumer c'est faire un RAID logiciel avec DSM^^

Chaque controleur propose ses propres mécanismes propriétaires pour présenter les disques à l'hôte. Je ne connais pas ce "IT", donc ce n'est pas moi qui te répondra et d'ailleurs ce n'est plus l'objet de ce topic. Donc là il faut que tu en ouvres un dans la rubrique : https://xpenology.com/forum/forum/116-compatibilité-hardware-installation/

Je ferme ce topic.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.