Razmote

Migration HP GEN 8 vers DS1815+

Recommended Posts

Bonjour à tous,

 

J'ai actuellement un HP GEN 8 sous DMS 5.2 avec 4 disques durs, qui ne sont pas montés en RAID mais en SHR.

 

Je compte acheter un DS1815+ d'occas pour y mettre plus de disque, je garderai peut être le GEN 8 pour une nouvelle installation.

 

Quelle est la meilleure manière de procéder pour faire la migration du GEN 8 vers le 1815 ?

Mettre un disque dur vierge dans le 1815, puis installer DSM 6.2, puis mettre mes 4 disques (si ils sont reconnus et garder ainsi mes données) ?

Ou mettre directement les 4 disques dedans ?

 

Il me semblait que chaque disque avait une copie du système et du boot, de telle sorte que si un disque lache, le système peut quand même démarrer sur un autre disque.

Mais j'ai eu des souci il y a quelques temps avec mon GEN 8 et je n'ai pas pu démarrer sur 2 des disques, on dirait que seul le disque Volume 4 démarre...

 

Merci d'avance 😎

 

Edited by Razmote

Share this post


Link to post
Share on other sites

on ne peut pas être sûr à 100% dans ces cas de figure. Mais par expérience, le fait de disposer d'une grappe RAID (ou SHR peu importe) à partir d'un type de Syno pour les déplacer sur un autre matos ne pose en général pas de pb, j'ai pu le vérifier en passant du loader 3615xs au 3617Xs et réciproquement. La seule diff est qu'il reste à chaque fois un temps de reconfiguration à posteriori automatique, mais les données elles sont bien dispo.

 

Mais on n'est jamais trop prudent avec une sauvegarde en amont....

Share this post


Link to post
Share on other sites

Merci nicoueron pour ta réponse rapide :)

 

Pour les sauvegardes, bien sur il vaut mieux les faire avant...

 

Du coup je pars d'un disque dur vierge ou je tente de mettre un des 4 disques ?

 

Et pour cette histoire :

Il me semblait que chaque disque avait une copie du système et du boot, de telle sorte que si un disque lache, le système peut quand même démarrer sur un autre disque.

Mais j'ai eu des souci il y a quelques temps avec mon GEN 8 et je n'ai pas pu démarrer sur 2 des disques, on dirait que seul le disque Volume 4 démarre...

 

Merci 😎

Share this post


Link to post
Share on other sites
il y a 7 minutes, Razmote a dit :

Du coup je pars d'un disque dur vierge ou je tente de mettre un des 4 disques ?

J'aurai tendance à dire de mettre les 4 dans un premier temps. si c'est KO, autant reinstaller DSM proprement sur un disque vierge puis ajouter les disques pour que DSM se remette correctement sur les 4 autres disques

Share this post


Link to post
Share on other sites

Salut Nico,

 

Bon j'ai installé un DSM tout neuf sur un disque de 1 To que j'ai mis dans mon DS1515+.

J'ai tout configuré grace à la restauration des paramètres ça a été assez rapide et facile.

 

Du coup j'ai démonté un des disques de mon Gen 8 et le disque n'est pas reconnu...

Comme j'en ai encore 3 je sais pas trop quoi faire, voila la capture écran jointe.

 

Je pensais que DSM reconnaitrait un disque provenant d'une version 5.2 et qu'il l'ajouterait automatiquement, mais non...

Du coup quand je crée un volume il me demande de confirmer l'effacement du disque.

 

Merci d'avance.

 

syno.jpg

Edited by Razmote

Share this post


Link to post
Share on other sites

Un raid (ou shr) est construit dur plusieurs disques, en n'en installant qu'un tu n'importes qu'un tiers de tes donnés, c'est donc normal qu'il ne voye rien.

A ta place j'aurais juste mis mes 4 disques et démarré, le nas devrait proposer une migration sur synology assistant.

 

Share this post


Link to post
Share on other sites

Salut keido, 

 

Je demarre donc mon ds1515+  avec le 1ier disque qui contient un dsm 6.2 tout neuf et les 4 disques shr non raid de mon Gen 8 dsm 5.2 ? 

j y avais pensé mais j ai eu peur que le dsm 5. 2 de ces disques soit écrasé et que si j avais un problème je ne puisse les remettre dans le gen 8.

 

merci.

Share this post


Link to post
Share on other sites
Le 27/10/2019 à 00:40, Keido a dit :

Un raid (ou shr) est construit dur plusieurs disques, en n'en installant qu'un tu n'importes qu'un tiers de tes donnés, c'est donc normal qu'il ne voye rien.

A ta place j'aurais juste mis mes 4 disques et démarré, le nas devrait proposer une migration sur synology assistant.

 

Salut,

à mon sens, j'aurai cru que DSM aurait vu que le disque contenait une partition SHR et qu'il aurait monté un volume certes en erreur mais au moins il aurait pu le reconstruire après. Comme ce n'est pas le cas ben oui j'aurai tendance à proposer de mettre les 3 ou 4 disques en mm temps du coup

Share this post


Link to post
Share on other sites

Bonjour Nico et Keido.

 

Je vous mets une capture du gestionnaire de disque :

 

Les 4 disques ont été ajouté de la même manière SHR sans Raid.

 

Bizarrement seul le disque No 3 permet de démarrer DSM 5.2.

Je m'étais amusé à essayer de démarrer sans ce disque et c'était impossible.

 

Je viens d'acheter un disque de 4 TO, je vais essayer de m'en servir comme disque de transfert pour migrer mes disques...

Je sais pas encore comment, je vais faire des essais.

 

Actuellement, j'ai un disque de 1TO avec DSM 6.2 et tous mes paramètres ok dans le DS1515+

Si je dois mettre les 4 disque de mon GEN 8, je suppose que je dois les mettre dans le même ordre, sachant que le 1er disque sera monté dans le 2ième emplacement du DS1515+.

J'ai bon ?

 

Merci à vous.

syno.jpg

Edited by Razmote

Share this post


Link to post
Share on other sites

Bonjour,

 

SHR sans RAID... ???  SHR signifie Synology Hybrid Raid

Le RAID est logiciel avec une couche de volumes logiques (LVM) en plus.

Donc, il y a une déclaration du RAID dans les derniers blocs du disque.

Ensuite, si les 4 disques étaient dans 4 volumes indépendants, cela ne prête pas à conséquence mais s'il s'agit d'un même volume, il faut au moins 3 disques sur les 4 comme indiqué plus haut.

 

Jacques

Share this post


Link to post
Share on other sites

Bonjour Jacques,

 

Malgré le fait que j'ai 4 disques SHR, il ne me semble pas que ces disques soient montés en RAID.

Lors de l'ajout de ces disques et en suivant l'assistant, j'ai pris l'option sans RAID. et donc sans aucune sécurité

Donc mes disques sont bien des disques indépendants, d'ailleurs dans le gestionnaire de disque il y a bien marqué :

Disque 1 1,8 TO

Disque 2 1,8 TO

Disque 3 1,8 TO

Disque 4 3,58 TO

 

Je suppose que lorsque ces disques sont montés en RAID 0, 1 ou 5 la taille affiché de ceux ci n'inclus pas les données du RAID.

 

Mais peut être me trompais je...

 

Je confirme aussi que les volumes crées le sont uniquement sur les disques concernés, soit 4 volumes, 1 par disque.

 

Merci pour ta réponse.

Syno 3.jpg

Edited by Razmote

Share this post


Link to post
Share on other sites

D'après l'image, c'est assez difficile à lire, mais en bout de ligne on distingue les volumes sont différents pour chacun des disques.

Ceci dit, cela n'exclue pas que le SHR soit utilisé même si on ne crée qu'un volume par disque. Je ne me souviens plus dans mon cas, j'ai 6 disques répartis en 3 volumes, et les 2 derniers sont bien avec 1 disque unique. Mais j'ai pourtant du SHR dessus, seulement je ne sais plus si c'est parce que je l'ai demandé ou si ça a été fait automatiquement.

Les informations sont visibles dans les menus "Groupes RAID" et "Volumes" du gestionnaire de stockage.

Si tu as effectivement du SHR, même sur un seul disque, on est en RAID. Maintenant, comme la configuration du nombre de disques est stockée dans le super-bloc en fin de disque, tu ne devrais pas avoir de soucis pour que le disque soit reconnu individuellement.

Toutefois, tu as du passer en version 6 et le SHR n'est plus activé par défaut dans la configuration du NAS. Il faut le forcer dans un fichier de configuration (donc activer l'accès SSH entre autre pour le faire. Ensuite on peut éditer le fichier avec vi ou grace à WinSCP par exemple.

Voir cet article : https://xpenology.club/enable-shr-in-dsm-6/

Je souhaite que ça règle ton problème

 

Jacques

Share this post


Link to post
Share on other sites

Super, merci Jacques je vais essayer pour voir et je te dirais ;)

 

Ca me semble une piste intéressante et surtout une bonne explication si ça marche...

 

PS : tu peux cliquez sur l'image pour l'agrandir.

Edited by Razmote

Share this post


Link to post
Share on other sites

Pour info, avec DSM on est en faite TOUJOURS en RAID. Le DSM étant installé sur tout les disques.

Si un disque est HS ou même plusieurs, l’accès a DSM est toujours ok. ( seul les paquets sont impactés ) 

 

 

 

Share this post


Link to post
Share on other sites

Salut Evotk, 

 

Pas chez moi, seul 1 disque sur 4 permet de démarrer sous DSM 5.2.

 

J ai testé et j en ai déjà parlé dans un autre post. 

 

Merci. 

Share this post


Link to post
Share on other sites

Désolé, je prend le post en marche ;) 

DSM n'est donc pas installé correctement, l'idéal serait donc de faire un reset avec pertes de la config mais conservations des données et réinstallation de DSM pour repartir sur des bonnes bases.

Share this post


Link to post
Share on other sites

alors sur mon nouveau DS1515+ avec un disque de 1 TO, tout est prêt, paquets, utilisateurs, partages, etc... 

manque plus que les 4 disques à rapatrier.. 

par contre ta manip me fait un peu peur lol

Edited by Razmote

Share this post


Link to post
Share on other sites

Tu ne les as pas intégré dedans ? Quesqu'il te dit ?

J'avais fait une fois dans un groupe de 6 DD DSM 6.2 l'ajout d'un DSM 6.0, il m'avais sans soucis proposé de l’intégrer dans le NAS et avait tout gerer tout seul.

Apres entre DSM 6.2 et DSM 5.2 il y a une belle différence de version, mais c'est pas impossible qu'il te propose comme il la fait pour moi.

Share this post


Link to post
Share on other sites

quand je mets 1 des disques dedans j ai le message cité plus haut, de créer un volume et de confirmer l effacement... 

 

je vais voir cette histoire de non prise en compte de SHR par dsm 6.2.

 

merci 

Share this post


Link to post
Share on other sites

Effectivement, je te conseil d'activer le SHR et d'essayer a nouveau.

Si non concluant, je pense qu'il va falloir récuppérer tes données avec un linux live par exemple, puis formater tes disques pour les intégrer !

Share this post


Link to post
Share on other sites

Re,

 

Bon on ne peut plus se connecter en root simplement avec WinSCP.

 

J'essaie de me connecter sur DSM 6.2 avec le compte admin ou root et le mot de passe de ma session (je fais parti du groupe admin) et cela ne marche pas...

 

Décidément...

Share this post


Link to post
Share on other sites

Bonjour à tous,

 

Bon j'ai pu me connecter à mon DS1515+ et vérifié ceci :

Citation

Toutefois, tu as du passer en version 6 et le SHR n'est plus activé par défaut dans la configuration du NAS. Il faut le forcer dans un fichier de configuration (donc activer l'accès SSH entre autre pour le faire. Ensuite on peut éditer le fichier avec vi ou grace à WinSCP par exemple.

Voir cet article : https://xpenology.club/enable-shr-in-dsm-6/

Tout est ok, SHR était déjà activé, donc cela ne vient pas de la...

 

Il me reste donc 2 solutions :

Soit j'enlève mon disque qui contient DSM 6.2 dans mon DS1515+, je mets les 4 disques de mon Gen 8 dans le même ordre et je tente une migration.

Soit je reste avec mon disque DSM 6.2, j'achète un disque dur et je m'en sers de transfert pour basculer toutes mes données d'un NAS à l'autre et d'un disque à l'autre...

 

A suivre...

Edited by Razmote

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.