Driver extension jun 1.03b/1.04b for DSM6.2.2 for 3615xs / 3617xs / 918+


Recommended Posts

В 19.10.2020 в 17:44, ramzes508 сказал:

Good day to all! I ask you to help add a driver for the Adaptec 6405h controller, unfortunately my experience was not enough to figure out how to add a driver myself.

 


04:00.0 Serial Attached SCSI controller [0107]: Adaptec PMC-Sierra PM8001 SAS HBA [Series 6H] [9005:8081] (rev 05)
04:00.0 Serial Attached SCSI controller: Adaptec PMC-Sierra PM8001 SAS HBA [Series 6H] (rev 05)
	Subsystem: Adaptec PMC-Sierra PM8001 SAS HBA [Series 6H]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at d0760000 (64-bit, non-prefetchable) [size=64K]
	Region 2: Memory at d0750000 (64-bit, non-prefetchable) [size=64K]
	Region 4: Memory at d0740000 (32-bit, non-prefetchable) [size=64K]
	Region 5: Memory at d0700000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at d0600000 [disabled] [size=1M]
	Capabilities: [40] Power Management version 3
		Flags: PMEClk- DSI- D1+ D2- AuxCurrent=375mA PME(D0+,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [50] MSI: Enable- Count=1/32 Maskable- 64bit+
		Address: 0000000000000000  Data: 0000
	Capabilities: [70] Express (v2) Endpoint, MSI 00
		DevCap:	MaxPayload 256 bytes, PhantFunc 0, Latency L0s <1us, L1 <8us
			ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset- SlotPowerLimit 253.000W
		DevCtl:	CorrErr- NonFatalErr- FatalErr- UnsupReq-
			RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 128 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr- NonFatalErr- FatalErr- UnsupReq- AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 5GT/s, Width x8, ASPM L0s L1, Exit Latency L0s <512ns, L1 <64us
			ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
		LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 5GT/s (ok), Width x1 (downgraded)
			TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
		DevCap2: Completion Timeout: Not Supported, TimeoutDis+, NROPrPrP-, LTR-
			 10BitTagComp-, 10BitTagReq-, OBFF Not Supported, ExtFmt-, EETLPPrefix-
			 EmergencyPowerReduction Not Supported, EmergencyPowerReductionInit-
			 FRS-, TPHComp-, ExtTPHComp-
			 AtomicOpsCap: 32bit- 64bit- 128bitCAS-
		DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
			 AtomicOpsCtl: ReqEn-
		LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-
			 Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
			 Compliance De-emphasis: -6dB
		LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
			 EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
	Capabilities: [ac] MSI-X: Enable+ Count=16 Masked-
		Vector table: BAR=0 offset=00002000
		PBA: BAR=0 offset=00004000
	Capabilities: [100 v1] Advanced Error Reporting
		UESta:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
		UEMsk:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
		UESvrt:	DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
		CESta:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr-
		CEMsk:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
		AERCap:	First Error Pointer: 00, ECRCGenCap+ ECRCGenEn- ECRCChkCap+ ECRCChkEn-
			MultHdrRecCap- MultHdrRecEn- TLPPfxPres- HdrLogCap-
		HeaderLog: 00000000 00000000 00000000 00000000
	Kernel driver in use: pm80xx
	Kernel modules: pm80xx

 

Driver: https://storage.microsemi.com/en-us/support/sas/sas/asa-6405h/

 

Thanks in advance for any help!

 

Hello! Of all versions, my Adaptec 6405h controller worked and displayed correctly in DSM 5.2
XPEnoboot 5.2-5967.1 DS3615xs
XPEnoboot_DS3615xs_5.2-5967.1.img

Can I somehow take the driver from 5.2 and transfer to the newer DSM Xpenology?

 

Link to post
Share on other sites
3 hours ago, emailme0909 said:

Jun's loader version 1.04b for 918+

extra.lzma & extra2.lzma for loader 1.04b ds918+ DSM 6.2.3 v0.12.1.   (file name: extra918plus_v0.12.1.zip)

rd.gz & zimage files from DSM_DS918+_25426.pat (download from synology website -open & extract these 2 files using 7zip)

 

using the matching kernel from 6.2.3 would be best but i also tested the 6.2.3 extra/extra2 with the original kernel files on loader 1.04b (6.2.0 files) and it worked too for the nic's i had for testing and the storage controller (like lsi sas 9211-8i), its just a match for the 1st boot of the loader, when installing 6.2.3 the kernel on the usb flash drive will be replaced/updated with the 6.2.3 kernel

 

6 minutes ago, ramzes508 said:

Can I somehow take the driver from 5.2 and transfer to the newer DSM Xpenology?

there is no "transfer" as copying a file, you need to compile the right driver for the kernel that is used for the dsm version in question

if you can't wait for the new driver package you can still use the tutorial for compiling and "injecting" drivers in the loader

https://xpenology.com/forum/topic/7187-how-to-build-and-inject-missing-drivers-in-jun-loader-102a/

https://xpenology.com/forum/topic/7341-tutorial-compile-xpenology-drivers-in-windows-10/

and build the new driver yourself

atm it depends on the weather, as long as its kind of late summer like i will do other things then drivers and extra's (tomorrow has a rainy forecast ..., weekend looks sunny)

Link to post
Share on other sites
On 10/21/2020 at 6:27 AM, emailme0909 said:

I have Intel NUC (NUC7JYH).  (j4005 processor + Realtek 8111H-CG ethernet).

I tried all three extra.lzma/extra2.lzma for loader 1.04b ds918+ DSM 6.2.2.

But cannot get IP address.

I also tried 3615 & 3617 loaders + pat files.

 

I am out of ideas now, Is there any other way to make DSM work on Intel NUC (NUC7JYH)?  

 

Hello,

I have the same problem with NUC 5i5RYK with Intel I218-V and loader 1.04b ds918+ (or loader 1.02a2).

NAS not found also with loader DS3617XS and Loader 1.03b

 

NIC is a Intel I218-V with F4:4D:.... MAC Address

Link to post
Share on other sites
12 hours ago, mmjc23 said:

I have the same problem with NUC 5i5RYK with Intel I218-V and loader 1.04b ds918+ (or loader 1.02a2).

that nic might need a newer driver, so try the latest, extra/extra2 from the 6.2.3 driver thread and 6.2.3

 

12 hours ago, mmjc23 said:

NAS not found also with loader DS3617XS and Loader 1.03b

1.03b for 3615/17 does not support uefi

does that system even has csm mode? if yes it needs to be on and you also need to boot from the non uefi boot device (might only show up after 1st reboot with csm on)

 

12 hours ago, mmjc23 said:

NIC is a Intel I218-V with F4:4D:.... MAC Address

to say anything about the driver version and supporting this hardware it needs the pcie vendor- and product-id and its sub id (if present), usually you get this with lspci when booting a live/rescue linux

Link to post
Share on other sites
В 22.10.2020 в 14:17, IG-88 сказал:

there is no "transfer" as copying a file, you need to compile the right driver for the kernel that is used for the dsm version in question

if you can't wait for the new driver package you can still use the tutorial for compiling and "injecting" drivers in the loader

https://xpenology.com/forum/topic/7187-how-to-build-and-inject-missing-drivers-in-jun-loader-102a/

https://xpenology.com/forum/topic/7341-tutorial-compile-xpenology-drivers-in-windows-10/

and build the new driver yourself

atm it depends on the weather, as long as its kind of late summer like i will do other things then drivers and extra's (tomorrow has a rainy forecast ..., weekend looks sunny)

 

Dear IG-88, I'm ready to wait for the new driver package and extra's. I am very grateful to you for your contribution to the development of xpenology.
Please add another LAN driver for MSI j1800 motherboard - LAN from Realtek® RTL8111G for Jun's Loader v1.03b DS3615xs or Jun's Loader v1.03b DS3617xs. Jun's Loader v1.03b does not see my network card.
https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software
Jun's Loader v1.04b DS918 sees my network card, but it makes no sense for my hardware, since transcoding requires a powerful processor.
Thanks in advance.

Link to post
Share on other sites
17 hours ago, ramzes508 said:

Please add another LAN driver for MSI j1800 motherboard - LAN from Realtek® RTL8111G for Jun's Loader v1.03b DS3615xs or Jun's Loader v1.03b DS3617xs. Jun's Loader v1.03b does not see my network card.

what make you think its a driver problem? did you connect a serial 0-modem cable to see the local console?

from my experience here its not, for >>90% of the cases when it comes to network its something else, the r8168 driver in the extra.lzma's available is recent enough for rtl8111g (same as 8168 or 8118), many people with that chip already using it

 

as we are in 6.2.2 area here its to mention IF using 6.2.2 dsm *.pat file you will need to use exactly the extra.lzma made for 6.2.2 and also follow exactly the instructions about copying the kernel from 6.2.2 to the loaderm, if not doing that correctly the driver may crash when booting because kernel on the loader and the driver are not compiled with the same settings - 6.2.2 and 6.2.3 are incompatible, 6.2.2 is a thing for its own (and not supported anymore as it was replaced with 6.2.3)

 

beside the 6.2.2/6.2.3 the problem with 1.03b 3615/17 is the fact that it only works in csm/legacy mode and then only when booting with the usb legacy (non uefi) usb boot device (that might only show up when rebooted once with csm acive in bios)

1.04b or 1.02b are more easy going it that es they boot in uefi and csm mode

https://ark.intel.com/content/www/us/en/ark/products/78866/intel-celeron-processor-j1800-1m-cache-up-to-2-58-ghz.html

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

17 hours ago, ramzes508 said:

Jun's Loader v1.04b DS918 sees my network card, but it makes no sense for my hardware, since transcoding requires a powerful processor.

 

no, it will offer the option to use hardware trancoding when present, and i would not count apollolake and geminilake cpu's as powerful, they just support intel quick sync video

the only plus in 3617 is raid F1 (special ssd raid) and 16 cpu cores instead of 8 (3615 and 918+)

 

and beside this the J1800 has intel qsv support, but it will only be on level with ivy bridge /  haswell, mpeg2/h.264 de-/encoding but no h.265/hevc support (4k contens us usually hevc)

https://en.wikipedia.org/wiki/Intel_Quick_Sync_Video#Hardware_decoding_and_encoding

 

so 918+ might be exactly what you want

Edited by IG-88
Link to post
Share on other sites
6 часов назад, IG-88 сказал:

what make you think its a driver problem? did you connect a serial 0-modem cable to see the local console?

from my experience here its not, for >>90% of the cases when it comes to network its something else, the r8168 driver in the extra.lzma's available is recent enough for rtl8111g (same as 8168 or 8118), many people with that chip already using it

 

as we are in 6.2.2 area here its to mention IF using 6.2.2 dsm *.pat file you will need to use exactly the extra.lzma made for 6.2.2 and also follow exactly the instructions about copying the kernel from 6.2.2 to the loaderm, if not doing that correctly the driver may crash when booting because kernel on the loader and the driver are not compiled with the same settings - 6.2.2 and 6.2.3 are incompatible, 6.2.2 is a thing for its own (and not supported anymore as it was replaced with 6.2.3)

 

beside the 6.2.2/6.2.3 the problem with 1.03b 3615/17 is the fact that it only works in csm/legacy mode and then only when booting with the usb legacy (non uefi) usb boot device (that might only show up when rebooted once with csm acive in bios)

1.04b or 1.02b are more easy going it that es they boot in uefi and csm mode

https://ark.intel.com/content/www/us/en/ark/products/78866/intel-celeron-processor-j1800-1m-cache-up-to-2-58-ghz.html

https://xpenology.com/forum/topic/13333-tutorialreference-6x-loaders-and-platforms/

 

 

no, it will offer the option to use hardware trancoding when present, and i would not count apollolake and geminilake cpu's as powerful, they just support intel quick sync video

the only plus in 3617 is raid F1 (special ssd raid) and 16 cpu cores instead of 8 (3615 and 918+)

 

and beside this the J1800 has intel qsv support, but it will only be on level with ivy bridge /  haswell, mpeg2/h.264 de-/encoding but no h.265/hevc support (4k contens us usually hevc)

https://en.wikipedia.org/wiki/Intel_Quick_Sync_Video#Hardware_decoding_and_encoding

 

so 918+ might be exactly what you want

Dear IG-88, thanks for the detailed answer. For a long time I could not decide on the version of the loader, initially I tried version 1.04, but then on the forum I saw a recommendation for my processor to use 1.03 3615/17.
I will install 1.04 DSM 918. The issue with the LAN driver for Realtek® RTL8111G is no longer relevant for me.
If it is not difficult for you, please add the Adaptec 6405h driver to the next build extra.lzma for loader 1.04. I will be very happy.
Thanks in advance :)

 

P.S. As I understand it, for 6.2.2 you no longer make new versions of the extra.lzma builds, then we are talking about 1.04b ds918 + DSM 6.2.3?

Edited by ramzes508
Link to post
Share on other sites
1 hour ago, ramzes508 said:

I will install 1.04 DSM 918. The issue with the LAN driver for Realtek® RTL8111G is no longer relevant for me.
If it is not difficult for you, please add the Adaptec 6405h driver to the next build extra.lzma for loader 1.04. I will be very happy.

the new extra will have the latest version of the r8168 driver and a driver for the adaptec too

the downloadable pm80xx drivers are 2014/2015 so i guess all later development was done in the kernel driver,the kernels synology used for dsm 6.2 are fro ~2017 so the old source from microsemi/adaptec might not even match to compile properly, from my older driver listings in 6.1 extra and 918+ extra thread the 6405 i listed a external aacraid driver with newer date like from 2018, if anything than its aacraid as driver, if i can find a newer driver i might try this one

 

the realtek 8111g chip dates back at least to 2015 so i dont think a driver that about 1 year old that is now in the extra you downloaded will be different from the latest driver (5/2020) in that regard

 

1 hour ago, ramzes508 said:

P.S. As I understand it, for 6.2.2 you no longer make new versions of the extra.lzma builds, then we are talking about 1.04b ds918 + DSM 6.2.3?

 

any new extra.lzma is compiled with the kernel settings for 6.2.3 and is unlikely to work with 6.2.2

and the new extra.lzma will be posted in the 6.2.3 thread (for a good reason)

 

Edited by IG-88
Link to post
Share on other sites
On 10/23/2020 at 12:09 PM, IG-88 said:

that nic might need a newer driver, so try the latest, extra/extra2 from the 6.2.3 driver thread and 6.2.3

 

1.03b for 3615/17 does not support uefi

does that system even has csm mode? if yes it needs to be on and you also need to boot from the non uefi boot device (might only show up after 1st reboot with csm on)

 

to say anything about the driver version and supporting this hardware it needs the pcie vendor- and product-id and its sub id (if present), usually you get this with lspci when booting a live/rescue linux

Thanks a lot IG-88 for the reply

 

I downloaded the file extra918plus_v0.13.3.zip and I copied the files inside, replacing those present in the partition of the USBKEY.

 

I tried both UEFI and Legacy boot and have also tried disabling other peripherals in BIOS, but the card does not get any IP from DHCP.

The LAN card is: VEN_8086 & DEV_15a3; if I run Windows 10 on the same NUC, it immediately gets an IP.

 

I wanted to try Xpenology on the NUC before buying the hardware for a new NAS (i5-10xxx or i3-10xxx) but I'm afraid it's too complicated for me.

I'll try with OMV.

 

Thank you very much and excude me for english

Have a good evening.

Link to post
Share on other sites
On 10/8/2020 at 12:18 PM, IG-88 said:

 

6.2.2 is dead, it does not get updates from synology and i will not do anything about these drivers, beside uploading them, most people dont even need them

i did new uploads to the recent 6.2.3 extra.lzma's anything else is when i have time, extra's for 6.1 might be more important then these 6.2.2's files

 

First, thank you for reply, and thank you for your contributions to this forum.

 

They are appreciated!

 

However...

 

I always find it curious and a bit sad when someone assumes their needs and their requirements are the needs and requirements of others - or worse, of the needs and requirements of everyone.  I may be misreading things a bit, but the statement "6.2.2 is dead" as a response to a request for re-upload or adding a mirror seems to follow that premise.

 

It's also curious that - in the amount of time it took to draft and submit your reply - the task of a re-upload or a mirror could have accomplished.  I fully understand and appreciate the timetable for accomplishing such a task or replying at all should be solely at the discretion of the person replying and their available time and resources.  But ...if you had to time to reply, why not just fulfill the request? By you own admission, "i will not do anything about these drivers, beside uploading them"..  re-uploading them is something you do deem within the scope of what you're willing to do, yes? 

 

I do not understand that mentality, certainly.  I think this forum exists for us to help each other when and where we can.  Not to dangle help above a user's reach - especially a new user.  If I'm honest, it makes me yearn for the early, fledgling days of the intertubez, having belonged to NWG as ARPANET was taking its first steps.  We may have had different viewpoints and opinions back then, but there was a definite altruistic nature which everyone was infected with.

 

As such, I will take the time to offer a contribution, even if it is rather small.

 

The filedropper link seems viable for now, but it was out of commission for quite a while.  For anyone else seeking the following file in the OP, here are some mirror links which hopefully will be around and working should filedropper be unreliable again:

 

DS3615: extra.lzma for loader 1.03b_mod ds3615 DSM 6.2.2 v0.5_test
SHA256: BAA019C55B0D4366864DE67E29D45A2F624877726552DA2AD64E4057143DBAF0

Hope that helps!

Link to post
Share on other sites
1 hour ago, rcached said:

I always find it curious and a bit sad when someone assumes their needs and their requirements are the needs and requirements of others - or worse, of the needs and requirements of everyone.  I may be misreading things a bit, but the statement "6.2.2 is dead" as a response to a request for re-upload or adding a mirror seems to follow that premise.

 

It's also curious that - in the amount of time it took to draft and submit your reply - the task of a re-upload or a mirror could have accomplished.  I fully understand and appreciate the timetable for accomplishing such a task or replying at all should be solely at the discretion of the person replying and their available time and resources.  But ...if you had to time to reply, why not just fulfill the request? By you own admission, "i will not do anything about these drivers, beside uploading them"..  re-uploading them is something you do deem within the scope of what you're willing to do, yes? 

 

I do not understand that mentality, certainly.  I think this forum exists for us to help each other when and where we can.  Not to dangle help above a user's reach - especially a new user.  If I'm honest, it makes me yearn for the early, fledgling days of the intertubez, having belonged to NWG as ARPANET was taking its first steps.  We may have had different viewpoints and opinions back then, but there was a definite altruistic nature which everyone was infected with.

 

Yes, this is quite "curious."  @IG-88 is THE heavy lifter with regard to driver support on this hack of a hack and is the #1 contributor as recognized by the forum population.  I won't speak for him, but from my view 6.2.1 and 6.2.2 were real problems for driver support as Synology essentially broke their own driver model, let it get out into the public, and then fixed it with 6.2.3.  And contrary to uninformed opinion, the drivers available don't always just compile without errors into the Syno DSM environment, they take some work to address incompatibility and weird dependencies.  I say this because I tried to duplicate his work when he was offline for awhile, and found a lot of problems in doing so.

 

So if he doesn't want to update his own contributions to 6.2.2 because it's fundamentally broken, drivers don't work even when they compile clean, and generally a real pain in the butt, so be it.  If the recommendation to a new user is NOT to use 6.2.2 because of this, that's still help. To accuse him of insufficient or faulty altruism is the height of arrogance.  Nobody gets paid for this, we do it because we like the platform and want others to enjoy it.

Edited by flyride
Link to post
Share on other sites
1 hour ago, flyride said:

 

Yes, this is quite "curious."  @IG-88 is THE heavy lifter with regard to driver support on this hack of a hack and

 

Thanks for your reply!

 

I don't mind criticism, but you seem to be arguing against a point I did not make, nor condone.

 

If you read the replies:

 

On 8/12/2020 at 5:00 AM, CIURI said:

Hello ,

 

can anyone please re-upload version 0.8_syno ds918+ , the file was deleted.

 

Thank you.

 

On 9/30/2020 at 8:46 AM, Masyanich said:

DS3615: extra.lzma for loader 1.03b_mod ds3615 DSM 6.2.2 v0.5_test
http://s000.tinyupload.com/?file_id=87576629927396429210

SHA256: BAA019C55B0D4366864DE67E29D45A2F624877726552DA2AD64E4057143DBAF0

 

link is dead

any mirror plz :(

 

On 10/2/2020 at 9:34 PM, izgovnaipalok said:

 

+1 

A similar problem

 

On 10/6/2020 at 5:30 AM, mike861033 said:

 

On 10/8/2020 at 4:23 AM, rcached said:

 

As others have mentioned, this URL is down.  From reading the thread, it appears it has been for some time now.

 

I searched this thread and checked online elsewhere (by the hash) for a mirror but could not find one.

 

None of these, including my post, were asking for an update to the drivers.

 

They were merely asking for a re-upload of the work already done.  Some of the filedropper links were down for... months?

 

Others may be requesting an update, but I wasn't

 

If there was some confusion there on your part or anyone else, I apologize.

 

Edited by rcached
In case my third grade teacher is reading this, and catches my poor verb conjugations
Link to post
Share on other sites
3 hours ago, rcached said:

If there was some confusion there on your part or anyone else, I apologize.

 

Sorry, no confusion here.  I am not referring to any of those posts.  I quoted you specifically from your fifth contribution to this forum, where you decided to admonish a highly respected contributor, bracketed with two paragraphs of tripe about how you wish folks would behave, and the wistful recollection of idealism from the early days of ARPANET. It was all perfectly communicative, thank you.  At best, you make it hard to want to help you.  I certainly won't forget who you are.

 

At worst, you (and now I) have damaged a valuable information thread and made it less useful. Thus I have no interest in arguing or responding further. This is a multi-national forum and bluntly, spouting on to impress one's self and wasting whitespace arguing semantics is really counterproductive here due to the number of folks who have to translate. 

 

In short, this is noise we don't need.  Mods, please delete this series of posts if you can possibly see fit.

Link to post
Share on other sites
50 minutes ago, flyride said:

Sorry, no confusion here.  I am not referring to any of those posts.  I quoted you specifically from your fifth contribution to this forum

 

Thank you for your feedback.

 

Regrettably, I think a lot of the specific conversation of this thread I am posting about has gotten lost.   Because "any of those posts" are EXACTLY what the conversation I am having is about.  So, if you're not seeing that by default, allow me to clarify.

 

Here is the conversation as it should be read:

 

On 10/8/2020 at 4:23 AM, rcached said:

As others have mentioned, this URL is down.  From reading the thread, it appears it has been for some time now.

 

I searched this thread and checked online elsewhere (by the hash) for a mirror but could not find one.

 

If someone could provide this file, I know I would greatly appreciate it.  I'm sure others would, too!

 

Many thanks!

 

On 10/8/2020 at 12:18 PM, IG-88 said:

6.2.2 is dead, it does not get updates from synology and i will not do anything about these drivers, beside uploading them, most people dont even need them

i did new uploads to the recent 6.2.3 extra.lzma's anything else is when i have time, extra's for 6.1 might be more important then these 6.2.2's files

 

7 hours ago, rcached said:

I always find it curious and a bit sad when someone assumes their needs and their requirements are the needs and requirements of others - or worse, of the needs and requirements of everyone.  I may be misreading things a bit, but the statement "6.2.2 is dead" as a response to a request for re-upload or adding a mirror seems to follow that premise.

 

It's also curious that - in the amount of time it took to draft and submit your reply - the task of a re-upload or a mirror could have accomplished.  I fully understand and appreciate the timetable for accomplishing such a task or replying at all should be solely at the discretion of the person replying and their available time and resources.  But ...if you had to time to reply, why not just fulfill the request? By you own admission, "i will not do anything about these drivers, beside uploading them"..  re-uploading them is something you do deem within the scope of what you're willing to do, yes? 

 

If only spend time enough to read the bold parts, that's the conversation in a nutshell.  

 

The conversation you're arguing isn't contained in any of my posts.  Sorry about that.

 

50 minutes ago, flyride said:

At worst, you (and now I) have damaged a valuable information thread and made it less useful. Thus I have no interest in arguing or responding further. This is a multi-national forum and bluntly, spouting on to impress one's self and wasting whitespace arguing semantics is really counterproductive here due to the number of folks who have to translate. 


On the contrary, I think this post is useful:

 

7 hours ago, rcached said:

As such, I will take the time to offer a contribution, even if it is rather small.

 

The filedropper link seems viable for now, but it was out of commission for quite a while.  For anyone else seeking the following file in the OP, here are some mirror links which hopefully will be around and working should filedropper be unreliable again:

 

DS3615: extra.lzma for loader 1.03b_mod ds3615 DSM 6.2.2 v0.5_test
SHA256: BAA019C55B0D4366864DE67E29D45A2F624877726552DA2AD64E4057143DBAF0

Hope that helps!

 

If there had been a similar post as the one I made, I wouldn't have had to make the request for the re-upload.

 

I could have just thanked the person who provided it.

 

I'm not sure why you seem to want to create some kind of vendetta?

 

50 minutes ago, flyride said:

At best, you make it hard to want to help you.  I certainly won't forget who you are.

 

At this point, I am no longer requesting help. 

 

Instead, I am offering it to anyone else who might encounter the issue myself and number of other users encountered during the downtime when the link in the OP was not viable. 

 

I'm certainly not doing much, of course.  But it didn't require much effort to upload the file to multiple mirrors and post those links.  So, why not?

Edited by rcached
Link to post
Share on other sites
1 hour ago, Polanskiman said:

Ok everyone. Let's stick to the subject of this thread. No more bickering please. Thank you.

 

Great advice.  Thank you!

 

And also another huge thank you to IG-88.  It's worth repeating often! 

 

On 10/8/2020 at 4:23 AM, rcached said:

Many thanks!

 

13 hours ago, rcached said:

First, thank you for reply, and thank you for your contributions to this forum.

 

Link to post
Share on other sites
On 10/26/2020 at 10:31 PM, mmjc23 said:

I downloaded the file extra918plus_v0.13.3.zip and I copied the files inside, replacing those present in the partition of the USBKEY.

 

I tried both UEFI and Legacy boot and have also tried disabling other peripherals in BIOS, but the card does not get any IP from DHCP.

The LAN card is: VEN_8086 & DEV_15a3; if I run Windows 10 on the same NUC, it immediately gets an IP.

the e1000e driver version in the extra 3.6.0 is ~1 year old, you device id is in that driver as supported device

the latest driver is from 3/2020, 3.8.4

with the driver also comes a file pci.updates and both contain the same entry for this device and no sub devices

from that it seems the 3.6.0 should be enough

 

On 10/26/2020 at 10:31 PM, mmjc23 said:

I wanted to try Xpenology on the NUC before buying the hardware for a new NAS (i5-10xxx or i3-10xxx) but I'm afraid it's too complicated for me.

 

you can try again at any time, just make a usb flash drive and boot it up, there should be no harm to a disk in the system by just booting the loader and trying to find it in network

 

Quote

I'll try with OMV.

 

would also be my next try if i ditched DSM

 

Edited by IG-88
  • Like 1
Link to post
Share on other sites
23 hours ago, rcached said:

The filedropper link seems viable for now, but it was out of commission for quite a while

 

i only remember one or two comments about the filedropper links and when i checked the link worked

anyway one of the problems was to find a new free file hoster where i dont have to register, where files stay up long enough and where you preferably not get scammed to much, i found this pretty frustrating, you get zillions of candidates but you need to invest some time on each only to find out they do not really provide the service i'm looking for - i will try the hosters you used next (i have 6 now, will hopefully enough - and tinyupload.com is back online and it seems they still have the old files)

 

i don't mind if you start a new thread to mirror files as long as its clear what version number it is and what they are for (dsm type and version)

now that i have a few hoster a can add a mirror or two

 

from my point of view its pretty normal that there might be 3-4 weeks of complete inactivity, there are things like vacation and i might have a look here in that time but i will not do anything about drivers or files, that can wait and if its that important there would have been mirrors by other people already

“Only wimps use tape backup. REAL men just upload their important stuff on ftp and let the rest of the world mirror it.”

Linus Torvalds

 

23 hours ago, rcached said:

I do not understand that mentality

don't worry, thasts normal, people are very different - i'm at least normal enough to have a job i'm getting paid for and i don't need to visit a psychologist - good enough

 

Edited by IG-88
Link to post
Share on other sites
2 hours ago, IG-88 said:

the e100e driver version in the extra 3.6.0 an ~1 year old, you device id is int that driver as supported device

the latest driver is from 3/2020, 3.8.4

with the driver also comes a file pci.updates and both contain the same entry for this device and no sub devices

from that it seems the 3.6.0 should be enough

 

 

you can try again at any time, just make a usb flash drive and boot it up, there should be no harm to a disk in the system by just booting the loader and trying to find it in network

 

 

would also be my next try if i ditched DSM

 

 

Hi IG-88 and thanks for your reply ... you are very kind.

 

I tried and tried again synoboot-ds918.zip + extra918plus_v0.13.3.zip following the Howto in XPENOLOGY Tool.

 

I have tried on two different NUC models (5i5RYK with Intel I218-V and 10i5FN with Intel I219-V) and on a Dell Optiplex 780 (with Intel 82567L) but I never get an IP from the DHCP Server (I checked router log).

 

I think I am doing something wrong.
I also tried two different USBKEYs.

 

To load the updated drivers, I load partition 1 with osfmount and replace the extra.lzma and extra2.lzma files, is that correct?

 

I am sure I have set VID and PID of the USBKEY and the MAC of the network card correctly in the grub file and I have tried both with the serial number for 916+ (generated with "serial generator") and keeping the original one in the file.
But I think these parameters are used only after obtaining the IP or am I wrong? I can't even get the IP and I noticed that the cursor on the monitor is not blinking.

 

What do you mean with "extra 3.6.0"? Are you referring to the "extra918plus_v0.13.3.zip" file?

 

In preparation of installing XPenology on a new NAS with Intel i5 10th in the future, is it correct to test with synoboot-ds918 and DSM_DS918 + _23739.pat or is it better DS3615 or DS3617?

 

Thank you so much for your help and forgive my English and my little knowledge of the subjects.

 

Link to post
Share on other sites
15 minutes ago, mmjc23 said:

I think I am doing something wrong.

i thought that but had no good point where that could be, 918+ can do uefi and csm and the cpu is ok for 918+ (4th gen cpu minimum)

 

15 minutes ago, mmjc23 said:

I also tried two different USBKEYs.

when you see the grub menu and after this jun's message then its at least booting from usb (there can be problems with cpu gen in 918+ or cam mode not used with 3615/17 after this point  resulting in a not found in network)

 

15 minutes ago, mmjc23 said:

To load the updated drivers, I load partition 1 with osfmount and replace the extra.lzma and extra2.lzma files, is that correct?

its the 2nd partiton, on the 1st it the grub.cfg but when you replaced the two files it must have been the right partition

 

23 minutes ago, mmjc23 said:

I am sure I have set VID and PID of the USBKEY and the MAC of the network card correctly in the grub file and I have tried both with the serial number for 916+ (generated with "serial generator") and keeping the original one in the file.

just to find it in network you dont need any of that, the usb vid/pid is important but only later when installing the *.pat file with DSM

so for testing you might skip grub.cfg modification and only replace the extra/extra2.lzma

 

26 minutes ago, mmjc23 said:

I noticed that the cursor on the monitor is not blinking.

you usually see the message about "screen will stop updating shortly ..." and a blinking cursor but i'm not sure if its bad if the cursor does not blink

the interesting part can be seen on the serial console and kind of never look at the monitor (because there is nothing to be seen)

 

30 minutes ago, mmjc23 said:

What do you mean with "extra 3.6.0"? Are you referring to the "extra918plus_v0.13.3.zip" file?

 

badly phrased, it refers to the e1000e driver, its its version in the extra/extra2

 

32 minutes ago, mmjc23 said:

In preparation of installing XPenology on a new NAS with Intel i5 10th in the future, is it correct to test with synoboot-ds918 and DSM_DS918 + _23739.pat or is it better DS3615 or DS3617?

when you intent to use the hardware transcoding of the cpu or m.2 nvme ssd (as cache, only with two as write cache, in most cased not worth the effort especially with 1GBit nic) then it needs to be 918+

3615/17 with loader 1.03b can be tricky as it needs CSM mode in bios and you need to boot from the non uefi usb device (might only show up after rebooting with csm active and then going into bios to select the boot device)

 

maybe try loader 1.02b for 3615/17 that one can uefi and csm (as 918+ does) and with the last extra.lzma (4.8)  the nic (8086:15a3) should work too, the driver in that version is only 3.3.4 but it has the id of the i218v in it so it should work

 

another test might be to use the 918+ and beside the extra/extra2 you also replace the zImage and rd.gz (on the same partition as extra/extra2) with the files from inside the dsm 6.2.3 918+ *.pat file (DSM_DS918+_25426.pat), you can open the *.pat file with 7zip or any other decent zip extractor

the kernel files on the loader are from dsm 6.2.0 and the drivers are made for 6.2.3, they are mostly compatible and i did not find any problems when testing it but maybe there are cases? it cant do anything worth

 

 

  • Like 1
Link to post
Share on other sites
On 10/27/2020 at 11:47 PM, IG-88 said:

i thought that but had no good point where that could be, 918+ can do uefi and csm and the cpu is ok for 918+ (4th gen cpu minimum)

 

when you see the grub menu and after this jun's message then its at least booting from usb (there can be problems with cpu gen in 918+ or cam mode not used with 3615/17 after this point  resulting in a not found in network)

 

its the 2nd partiton, on the 1st it the grub.cfg but when you replaced the two files it must have been the right partition

 

just to find it in network you dont need any of that, the usb vid/pid is important but only later when installing the *.pat file with DSM

so for testing you might skip grub.cfg modification and only replace the extra/extra2.lzma

 

you usually see the message about "screen will stop updating shortly ..." and a blinking cursor but i'm not sure if its bad if the cursor does not blink

the interesting part can be seen on the serial console and kind of never look at the monitor (because there is nothing to be seen)

 

 

badly phrased, it refers to the e1000e driver, its its version in the extra/extra2

 

when you intent to use the hardware transcoding of the cpu or m.2 nvme ssd (as cache, only with two as write cache, in most cased not worth the effort especially with 1GBit nic) then it needs to be 918+

3615/17 with loader 1.03b can be tricky as it needs CSM mode in bios and you need to boot from the non uefi usb device (might only show up after rebooting with csm active and then going into bios to select the boot device)

 

maybe try loader 1.02b for 3615/17 that one can uefi and csm (as 918+ does) and with the last extra.lzma (4.8)  the nic (8086:15a3) should work too, the driver in that version is only 3.3.4 but it has the id of the i218v in it so it should work

 

another test might be to use the 918+ and beside the extra/extra2 you also replace the zImage and rd.gz (on the same partition as extra/extra2) with the files from inside the dsm 6.2.3 918+ *.pat file (DSM_DS918+_25426.pat), you can open the *.pat file with 7zip or any other decent zip extractor

the kernel files on the loader are from dsm 6.2.0 and the drivers are made for 6.2.3, they are mostly compatible and i did not find any problems when testing it but maybe there are cases? it cant do anything worth

 

 

Hi IG-88, and sorry for the delay in answering you but I wanted to do some tests before bothering you again.

 

As you advised me, I tried loader 1.02b for 3615/17...

 

At first it didn't work so I tried to update the NUC BIOS and completely disable UEFI BOOT and leave only the legacy boot (in the NUC BIOS you can completely disable a type of boot).

 

In this way (with loader 1.02b) the DHCP assigned me an IP and the search for the NAS was successful.

I continued the installation but it was giving me the error "Failed to Format Disk (35)"

 

So, I deleted all the partitions on the disk and tried again ... but it gave me the error "The file is probably corrupt. (13)"

 

I read that it could be a USBKEY problem (my USBKEY had VID: abcd and PID: 1234).

So:
-I have changed USB KEY
-I loaded the new DS918 loader (without updated drivers extra918plus_v0.13.3)
-I changed the NUC's USB port
-I kept UEFI boot disabled

 

In this way, I was able to successfully install the latest version "DSM_DS918+_25426.pat"

 

I later found out that xpenology requires that the USBKEY must always be kept connected, is that correct?

 

So can I use the NUC harddisk for data?

Isn't it possible to install xpenology directly on the NUC Harddisk and remove the USBKEY?

 

Now I would like to try to connect a Hauppauge dongle for recording TV channels.

 

Soon, in Italy, we will switch to the new digital terrestrial and in the NAS that I would like to build, I would like to insert a PCIe Hauppauge multi tuner card, both to record TV channels and see TV channels on my old TV.

 

Do you think this is possible?

 

Don't worry...I'll do some tests...
I just wanted to thank you...if I managed to install it, it is only your credit...

 

Thank you so much and have a good evening

Link to post
Share on other sites
57 minutes ago, mmjc23 said:

I later found out that xpenology requires that the USBKEY must always be kept connected, is that correct?

its not mounted when dsm is started but if you reboot the system its needed as boot media

its like in earlier linux days where you had a boot partition and a root file system (separate)

also when installing a dsm update the usb is mounted to copy a new kernel to the usb before rebooting

but you can remove it when dsm is running, like for copying a new extra.lzma to it or making a backup, you just have to reconnect it before the next boot (or the system will simply not boot until you insert it again (or replace it with a equivalent)

 

57 minutes ago, mmjc23 said:

So can I use the NUC harddisk for data?

yes, dsm creates a 2.4GB and a 2GB partition on every disk (raid1) as system and swap partitions, whts left can be used for creating (data) volumes

 

 

57 minutes ago, mmjc23 said:

Isn't it possible to install xpenology directly on the NUC Harddisk and remove the USBKEY?

no, but there are small micro usb's and some systems have sd/micro sd card readers (as usb device) that can be used for booting too (you would need to find out vid/pid with lsusb when dsm  or a other linux running

 

57 minutes ago, mmjc23 said:

Now I would like to try to connect a Hauppauge dongle for recording TV channels.

if that dongle is supported by dsm (driver, check synology's compatibility list online) and you use a software package from the package center (or docker with a software you need)

 

https://www.synology.com/en-global/knowledgebase/DSM/help/VideoStation/tvrecording

https://www.synology.com/compatibility?search_by=category&category=usb_tv_dongles&p=1¬_recommend_mode=false

 

57 minutes ago, mmjc23 said:

I would like to insert a PCIe Hauppauge multi tuner card, both to record TV channels and see TV channels on my old TV.

Do you think this is possible?

 

depends if you find a hardware that works, my driver package does not support dvb hardware, there where a view attempts to make drivers but it needs maintaining over dsm versions and thats to much work as it looks even synology is not continuing that and dsm 6.2 will be the last version that supports new devices

even having a look at open media vault might be a option if it gets more in the direction where you drivers are more important and nas is just simple storage with a webgui

 

but there is a solution, SAT>IP can be used as network device (its not just for sat, its also supporting dvb-c and dvb-t)

https://en.wikipedia.org/wiki/Sat-IP

and the recording can be done on the nas (timers,epg even live streaming), there are some dvb packages for synology

its also possible to have a dedicated dvb server that uses the nas as nfs based storage, there are different approaches depending on the way its supposed to be used

one of the problems can be the wakeup of the system handling the timers, you usually dont want to run the nas to be active all the time and then it starts to get messy

should it be a raspi, a micro pc a mini-itx with pcie, whats about local storage or will it be wol for the nas with automount , when having independent local storage how will the recordings get to the nas, what about distributed recordings and usage from all tv's, tablets, computers int the household, ...

it needs a clear concept on what should be working in what way before doing it

 

i have given up on that stuff a few years ago and stopped recording completely, i dont even use a tv anymore, the internet has all of it and what really is THAT  "important" can be downloaded or copied to nas storage - saves so much time and storage space not to record everything you might need

 

 

 

 

 

Edited by IG-88
Link to post
Share on other sites

Hi all!

 

This driver extension (for DS3617XS) contains driver for HP 331T NIC? It's a Broadcom BCM5719 based ethernet card.

Im using jun 1.03b loader with the lastest DSM version. (Running on ESXI 7.0)

 

It working good with Intel E1000E virtual ethernet card, but i would like to change the virtual card to a dedicated one (with hardware passthrough).

 

Any ideas? Do i need this driver extension, or no? Maybe it cant be done with this extension? (BTW its not clear for me how should i use this driver pack. I have replaced the extra.lzma file on my bootloader img, but after that the VM started, but a cant ping/use/login to my dsm. The DS finder did not find any Disk Station - so i reverted back to my bootloader.)

 

Thanks for the help.

Edited by havast
Link to post
Share on other sites
1 hour ago, havast said:

This driver extension (for DS3617XS) contains driver for HP 331T NIC? It's a Broadcom BCM5719 based ethernet card.

Im using jun 1.03b loader with the lastest DSM version. (Running on ESXI 7.0)

 

the driver list from former versions 1.03a2 is still valid and can be checked in this thread

https://xpenology.com/forum/topic/12859-driver-extension-jun-103a2dsm62x-for-ds918/

beside this the tg3 driver is already in jun's drivers set, if you already tried that i guess there is something else (is the system vt-d capable?)

in esxi i'd suggest the vmware virtual nic and use vmwares capabilities, that way you also get higher network rates between vm's as the virtual nic supports 10G

 

1 hour ago, havast said:

Any ideas?

yes

 

1 hour ago, havast said:

Do i need this driver extension, or no? Maybe it cant be done with this extension? (BTW its not clear for me how should i use this driver pack. I have replaced the extra.lzma file on my bootloader img, but after that the VM started, but a cant ping/use/login to my dsm. The DS finder did not find any Disk Station - so i reverted back to my bootloader.)

you are in the wrong thread and might have used the wrong driver pack that was made for 6.2.2 and you a most likely use dsm 6.2.3, so try the 6..2.3 driver pack from the other thread (6.2.2. was a oddity and not continued by synology)

Edited by IG-88
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.