IG-88

Driver extension jun 1.03b/1.04b for DSM6.2.2 for 3615xs / 3617xs / 918+

Recommended Posts

Posted (edited)

Hi all, anyone is using sata controller Jmicron JMB585?

is it working with loader loader 1.04b_mod ds918+ DSM 6.2.2 v0.8_syno ? 

im plan to buy one for expansion since im using GA-J4105N-H which only have 2 sata port.

Edited by htvsm

Share this post


Link to post
Share on other sites

I was trying to install 6.2.2 using Loader 1.04b with the extra drivers on my NUC 5CPYH but keep getting errors as screen shot.

https://imgur.com/Q7iOkvy

 

Steps for creating loader USB:

  • Update VID, PID, MAC, Serial
  • Creating loader USB using Rufus/Win32
  • Replacing extra.lzma & extra2.lzma from 'std'/'syno'
  • Replacing/not replacing rd.gz/zImage from 24922.pat file

I tried all combination but error keep coming back.

Any idea would be helpful.

Thanks

 

Share this post


Link to post
Share on other sites
17 hours ago, mysy said:

Nice. any plan to add LSI 9400 driver to DS3617 bootloader?

yes, synology published recent source so we can try newer drivers, i guess in e few days you can try

i cant test lsi 9400, has it IT firmware?

Share this post


Link to post
Share on other sites
14 hours ago, htvsm said:

Hi all, anyone is using sata controller Jmicron JMB585?

is it working with loader loader 1.04b_mod ds918+ DSM 6.2.2 v0.8_syno ?

the uneven number is usually a warning, dsm/xpenology does not support port multiplier only "real" sata ports

but from the specs it does look like a real 5 port controller AND it has PCIe 3.0, even with its 2 lanes it should be more capable than one of the usual 4port marvell chips 88SE92xx (1.000 GB/s vs 1.969 GB/s per lane)

https://www.jmicron.com/file/download/996/JMB585.pdf

 

its ahci so it will work ootb

Share this post


Link to post
Share on other sites
1 hour ago, Rukia2005 said:

I was trying to install 6.2.2 using Loader 1.04b with the extra drivers on my NUC 5CPYH but keep getting errors as screen shot.

you loose network support while iinstalling

my assumption would be you used the loader in its original state with its "old" extra/extra2.lzma and the old zImage and rd.gz (6.2.0)

when installing 6.2.2 your zImage and rd.gz is from kernel 6.2.2 and you drivers fail because of the changes in 6.2.2

make sure to copy new extra/extra2 and new zImage/rd.gz before you start to install (as in the description in the 1st post)

Share this post


Link to post
Share on other sites
Just now, IG-88 said:

you loose network support while iinstalling

my assumption would be you used the loader in its original state with its "old" extra/extra2.lzma and the old zImage and rd.gz (6.2.0)

when installing 6.2.2 your zImage and rd.gz is from kernel 6.2.2 and you drivers fail because of the changes in 6.2.2

make sure to copy new extra/extra2 and new zImage/rd.gz before you start to install (as in the description in the 1st post)

Hi. I tried old extra(s) file and device does not recognize NIC at all. Synology Assistant couldn't see it on network.

I also found another weird problem is that if I boot from SD Card (of the intergrated card reader) then I also couldn't see it on network at all. Only boot from USB (using the same SD card) can make it work.

After I changed the VID and PID in loader to the USB Card Reader and boot from that I can install 6.2.2 just find (with new extra files and rd.gz + zImage files replaced).

Share this post


Link to post
Share on other sites
3 hours ago, Rukia2005 said:

I was trying to install 6.2.2 using Loader 1.04b with the extra drivers on my NUC 5CPYH but keep getting errors as screen shot.

https://imgur.com/Q7iOkvy

 

Steps for creating loader USB:

  • Update VID, PID, MAC, Serial
  • Creating loader USB using Rufus/Win32
  • Replacing extra.lzma & extra2.lzma from 'std'/'syno'
  • Replacing/not replacing rd.gz/zImage from 24922.pat file

I tried all combination but error keep coming back.

Any idea would be helpful.

Thanks

 

I'm having the same issue when I  try to install on a Dell PowerEdge R630. any recommendation?

Share this post


Link to post
Share on other sites
18 hours ago, htvsm said:

Hi all, anyone is using sata controller Jmicron JMB585?

is it working with loader loader 1.04b_mod ds918+ DSM 6.2.2 v0.8_syno ? 

im plan to buy one for expansion since im using GA-J4105N-H which only have 2 sata port.

 

I suggest to use Marvel 88SE9215 (4 port SATA 6Gbps PCIe x1) for best compatibility, because it's used in DS918+. This card is easily available at ebay (and other China shops) in the various form factors (PCIe / miniPCIe)

Share this post


Link to post
Share on other sites
6 minutes ago, smartire said:

I'm having the same issue when I  try to install on a Dell PowerEdge R630. any recommendation?

 

4 hours ago, Rukia2005 said:

I was trying to install 6.2.2 using Loader 1.04b with the extra drivers on my NUC 5CPYH but keep getting errors as screen shot.

https://imgur.com/Q7iOkvy

 

Steps for creating loader USB:

  • Update VID, PID, MAC, Serial
  • Creating loader USB using Rufus/Win32
  • Replacing extra.lzma & extra2.lzma from 'std'/'syno'
  • Replacing/not replacing rd.gz/zImage from 24922.pat file

I tried all combination but error keep coming back.

Any idea would be helpful.

Thanks

 

 

I posted a step by step tutorial not too long ago. Can you follow it and see if you missed something and try again? 

Share this post


Link to post
Share on other sites
16 minutes ago, mosaati said:

 

 

I posted a step by step tutorial not too long ago. Can you follow it and see if you missed something and try again? 

Thank you for the quick response, Sure I will be happy to try it. can you please kindly provide me the link?

Share this post


Link to post
Share on other sites
2 hours ago, Rukia2005 said:

Hi. I tried old extra(s) file and device does not recognize NIC at all. Synology Assistant couldn't see it on network.

I also found another weird problem is that if I boot from SD Card (of the intergrated card reader) then I also couldn't see it on network at all. Only boot from USB (using the same SD card) can make it work.

After I changed the VID and PID in loader to the USB Card Reader and boot from that I can install 6.2.2 just find (with new extra files and rd.gz + zImage files replaced)

 

thats boot problems, you initial description was about a error when already installing dsm (and it was not the typical error 13 when vid/pid is wrong)

maybe there could be other problems like having 2 dhcp servers in network and nic getting a new address from the 2nd?

also possible if there are more then one dsm system in network and two having the same mac will also result into problems

in situations like this its helpful to have the serial console, you might see if drivers fail or you can see what ip address the system uses and you can also login to have a closer look

 

2 minutes ago, smartire said:

can you please kindly provide me the link?

 

https://xpenology.com/forum/topic/21663-driver-extension-jun-103b104b-for-dsm622-for-3615xs-3617xs-918/?do=findComment&comment=140359

 

Share this post


Link to post
Share on other sites
12 minutes ago, IG-88 said:

 

thats boot problems, you initial description was about a error when already installing dsm (and it was not the typical error 13 when vid/pid is wrong)

maybe there could be other problems like having 2 dhcp servers in network and nic getting a new address from the 2nd?

also possible if there are more then one dsm system in network and two having the same mac will also result into problems

in situations like this its helpful to have the serial console, you might see if drivers fail or you can see what ip address the system uses and you can also login to have a closer look

 

 

https://xpenology.com/forum/topic/21663-driver-extension-jun-103b104b-for-dsm622-for-3615xs-3617xs-918/?do=findComment&comment=140359

 

Thank you very much I will try it right now and let you know the results....

Share this post


Link to post
Share on other sites
4 minutes ago, smartire said:

Thank you very much I will try it right now and let you know the results....

I'm sorry for the stupid question but am I missing something? it's asking for a decryption key to download 

2020-04-14_18-36-12.png

Share this post


Link to post
Share on other sites
5 hours ago, IG-88 said:

 

thats boot problems, you initial description was about a error when already installing dsm (and it was not the typical error 13 when vid/pid is wrong)

maybe there could be other problems like having 2 dhcp servers in network and nic getting a new address from the 2nd?

also possible if there are more then one dsm system in network and two having the same mac will also result into problems

in situations like this its helpful to have the serial console, you might see if drivers fail or you can see what ip address the system uses and you can also login to have a closer look

 

 

https://xpenology.com/forum/topic/21663-driver-extension-jun-103b104b-for-dsm622-for-3615xs-3617xs-918/?do=findComment&comment=140359

 

Hi. I got the problem resolved for the Intel NUC. It was the problem of integrated card reader VID & UID. I used a small SD card as Boot Loader before with DSM 5.2 so I though it would also work with 6.2.2 but I was wrong. I re-created the boot loader SD Card by my laptop using the integrated SD Card reader then push the card into the integrated Card Reader of the Intel NUC. It does boot up but causing problem while installing. Changed to using a USB Card Reader then update new VID & UID fixed the issue.

Now I'm trying to install 6.2 with 1.03B loader on a Foxconn NT3500. 

Share this post


Link to post
Share on other sites
6 hours ago, smartire said:

Unfortunately the same results :-(

2020-04-14_19-29-39.png

I noticed you are using DSM for DS918 while the steps and loader are for DS3617. Have made the necessary changes in the steps for DS918? 

Share this post


Link to post
Share on other sites
11 hours ago, IG-88 said:

the uneven number is usually a warning, dsm/xpenology does not support port multiplier only "real" sata ports

but from the specs it does look like a real 5 port controller AND it has PCIe 3.0, even with its 2 lanes it should be more capable than one of the usual 4port marvell chips 88SE92xx (1.000 GB/s vs 1.969 GB/s per lane)

https://www.jmicron.com/file/download/996/JMB585.pdf

 

its ahci so it will work ootb

 

Hi IG-88, thanks for your info and technical spec. From technical spec, it should support it because use ahci as you mention.Beside that, is it backward compatibility to pcie 2.0 for this chipset do you think? 

Nothing mention about backward compatibility from the tech spec. I was thinking to get this sata chipset for my experiment.

 

Here is pic of the card and link for the card:

 

https://www.aliexpress.com/item/33014907444.html?spm=a2g0s.8937460.0.0.3b512e0eW2hRQR

 

 iocrest.jpg%22%20alt=%22iocrest%22%20bor

 

8 hours ago, Arcao said:

 

I suggest to use Marvel 88SE9215 (4 port SATA 6Gbps PCIe x1) for best compatibility, because it's used in DS918+. This card is easily available at ebay (and other China shops) in the various form factors (PCIe / miniPCIe)

 

Hi Arcao, thanks for your suggestion. I have this card laying around, exactly same chipset using pcie x1. I already tested and work great.

However i  need to use the pcie x1 slot for my dual port ethernet card upgrade which is intel 82575 E1G42ET since my board is GA-J4105N-H only have single slot x1 pcie. 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, htvsm said:

Hi Arcao, thanks for your suggestion. I have this card laying around, exactly same chipset using pcie x1. I already tested and work great.

However i  need to use the pcie x1 slot for my dual port ethernet card upgrade which is intel 82575 E1G42ET since my board is GA-J4105N-H only have single slot x1 pcie. 

 

Note: Marvel 88SE9215 also exists in M.2 M Key 2260 version:

https://www.aliexpress.com/item/32814284199.html?spm=a2g0o.productlist.0.0.25b53c0ds9S1kJ&algo_pvid=e52cd22c-0354-472f-9c68-076f7c750c23&algo_expid=e52cd22c-0354-472f-9c68-076f7c750c23-6&btsid=0be3743615869391392268670eb250&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_

 

Or you can buy M.2 M key to PCIe 1x riser card similar to this:

https://www.aliexpress.com/item/4000825543839.html?spm=a2g0o.productlist.0.0.377d17088YtFCl&algo_pvid=89c570e2-7219-41e7-8dcf-4ba32f7fdaa0&algo_expid=89c570e2-7219-41e7-8dcf-4ba32f7fdaa0-24&btsid=0ab6fa7b15869398135633409e5814&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_

 

 

Share this post


Link to post
Share on other sites

Hi IG,

Yes, I get a Lenovo 430-8i HBA card, it was SAS3408 chipset, aka LSI 9400-8i , IT mode firmware.  spec: 12Gb SAS HBA card. I use it with Esxi 6.7 and Win 2016 with broadcom driver is working fine connect 8 HDD to 2 disk cage. Just remind, SAS3408 use driver name: ItSas35  , SAS 3108/9300 call themself as lsi_sas3 .  I try the9300 card driver doesn't work with 9400 card in windows server 2016.

14 hours ago, IG-88 said:

yes, synology published recent source so we can try newer drivers, i guess in e few days you can try

i cant test lsi 9400, has it IT firmware?

 

Share this post


Link to post
Share on other sites
8 hours ago, mosaati said:

I noticed you are using DSM for DS918 while the steps and loader are for DS3617. Have made the necessary changes in the steps for DS918? 

I have done my best Mosaat, but I'm not sue if it is enough lol. I'm opened for any suggestion.

I was never able to install DS918 on the Dell R630, however I was able to install DS3617xs Legacy BIOS couple times of more than 100 tries, but it would not detect all the 8 SAS drives, since it was not detecting to install I added a256 SSD on the CD-ROM to be able to install it, but it was freezing and resetting the BIOS time.

Share this post


Link to post
Share on other sites
3 minutes ago, smartire said:

I have done my best Mosaat, but I'm not sue if it is enough lol. I'm opened for any suggestion.

I was never able to install DS918 on the Dell R630, however I was able to install DS3617xs Legacy BIOS couple times of more than 100 tries, but it would not detect all the 8 SAS drives, since it was not detecting to install I added a256 SSD on the CD-ROM to be able to install it, but it was freezing and resetting the BIOS time.

 

You won't be able to install DS918 because it is incompatible with the processors of R630. DS3617 is compatible and this is why it's installing. Not detecting the drives is weird and I'm sure there is a problem somewhere with the way you are implementing it.

BTW, you have to increase the amount of drives by editing a config file post installing DSM, If that is what you are referring to not detecting your drives. I had 16 drives and it was limited I think to 8 and had to edit the file for DSM to see and pick up the remaining. 

Share this post


Link to post
Share on other sites
39 minutes ago, mosaati said:

 

You won't be able to install DS918 because it is incompatible with the processors of R630. DS3617 is compatible and this is why it's installing. Not detecting the drives is weird and I'm sure there is a problem somewhere with the way you are implementing it.

BTW, you have to increase the amount of drives by editing a config file post installing DSM, If that is what you are referring to not detecting your drives. I had 16 drives and it was limited I think to 8 and had to edit the file for DSM to see and pick up the remaining. 

Thank you again, I'm cleaning up the drives right now with live linux, and will do try number 1000 lol, how would you recommend to try install DS3617 on the R630?

I'm following this tutorial with the DS3617: extra.lzma for loader 1.03b_mod ds3617 DSM 6.2.2 v0.5_test and replacing the  zImage and rd.gz with the ones from the DSM_DS3617xs_24922.pat.

 

btw I'm nott planing use this server as NAS, I just got a R420 with 8 bay yesterday of the eBay that will be my NAS. FYI i have succefuly install DS3617xs on my friends R620.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.