Driver extension jun 1.03b/1.04b for DSM6.2.2 for 3615xs / 3617xs / 918+


Recommended Posts

I have put the extra and extra2 in the "recovery" file but I don't think it comes from there.
the problem really comes up when I try to do anything with Docker.
I am attaching to you what I could find in the logs.

I uninstalled it and restarted several times but it doesn't work.

Docker

Edited by vlotho
Link to post
Share on other sites
On 2/12/2020 at 8:38 PM, vlotho said:

the only access i have is ssh.

it would be useful to have the root password.

Login ssh as DSM user with administrator priviliges, then type

sudo - i

and as a password use the same password as for admin user.

  • Like 1
Link to post
Share on other sites

Hi. Could you upload the following link again? 

"DS3617: extra.lzma for loader 1.03b_mod ds3617 DSM 6.2.2 v0.5_test"
Thank you!!!

 

Unfortunately, "0.8_syno ds918+" it doesn't work on my board, Asrock j3455-ITX.

Edited by Dyno
Link to post
Share on other sites
On 2/14/2020 at 9:46 AM, whatever000 said:

I am interested to try the extra.lzma for ds3617xs 1.03b loader on my Supermicro X10SDV-4C-TLN2F. However, the tiny upload link said the file no longer exists. Where can I find the file? Thanks

uploaded and changed the link

Link to post
Share on other sites
3 hours ago, Dyno said:

Unfortunately, "0.8_syno ds918+" it doesn't work on my board, Asrock j3455-ITX.

 

update or fresh install?

what "does not work"? does not boot, no /dev/dri, ...

you should at least be able to boot with recovery and after being able to log into your system by ssh you can delete the the i915 firmware and drivers in "update" folder as in the description, shut down, copy the extra/extra2  "syno" type to the usb and boot again

Link to post
Share on other sites
1 hour ago, IG-88 said:

 

update or fresh install?

what "does not work"? does not boot, no /dev/dri, ...

you should at least be able to boot with recovery and after being able to log into your system by ssh you can delete the the i915 firmware and drivers in "update" folder as in the description, shut down, copy the extra/extra2  "syno" type to the usb and boot again

Fresh install.

Not boot. Can't find network.
I tried this "extra" 

and if it starts but they don't works fine. They start very slowly and sometimes they don't even start.

I'll try tomorrow a 0.8_recovery ds918+ extra.

 

DSM 6.2.2 update 4 for ds3615xs with DS3615 v0.5_test extra, everything works fine, but i want to try ds3617.

 

Thank you very much!

Edited by Dyno
Link to post
Share on other sites

Asrock J5005 ITX.

extra918plus_v0.8_syno

Baremetal fresh install: Success

Update from 6.2 (DSM_DS918+_23739.pat): Success

Comments: Shutdown and reboot works good. No errors at dmesg. No dev/dri. Next updated to DSM 6.2.2-24922 Update 5 - still works good.

 

extra918plus_v0.8_std

Baremetal fresh install: Failed

Update from 6.2 (DSM_DS918+_23739.pat): Failed

Comments: Lot of errors at dmesg. I was able to finish install with extra918plus_v0.8_recovery, but still lot of errors, no dev/dri, shutdown and reboot not working.

Link to post
Share on other sites
7 minutes ago, apriliars3 said:

Any drivers sata for dell DL320 g5p

HPE uses smart array raid controllers, thats not AHCI

it might work if you confugure the controller for IT mode (hpsa 410 and newer might support this - never tried this as i dont have this hardware) or maybe for testing you can configure one or more drives as hpe raid set, this raid sets might show up when the (hpsa.ko) driver is working (try this before putting to much work into findung out if IT mode work) - my advice is to forget about the HPE SA controllers, use a AHCI 4 or 8 port controller or a lsi mpt fusion SAS 2.0 controller in IT mode (8 sata ports with the propper cable)

Link to post
Share on other sites

I apologize up front if this has been clarified/mentioned by someone else, however, I can confirm that it is possible to upgrade from 6.1.7 directly to 6.2.2 using IG-88's extra.lzma without losing the data, by choosing "Reinstall DSM" option and selecting 6.2.2 pat file mentioned by IG-88 in his first post. It goes w/o saying that you will have to reinstall all packages, users, configuration but you are saving a ton of time by not having to restore the data.

 

As I stated previously in one of my replies in this post, I was not able to go through a migration process successfully from 6.1.7 to 6.2.2 but choosing the option to reinstall the DSM worked flawlessly.

 

I have used that approach successfully on my last 2 NAS' that had 6.1.7 (one of them is so old that it has a Q9500 CPU) and are now running happy on 6.2.2.

 

Hope that helps.

Link to post
Share on other sites
12 hours ago, Dyno said:

The 0.8_recovery ds918+ extra also not boot on my j3455-ITX

 

if that refers to a asrock board, there are others with it and it does work for them

 

12 hours ago, ex3me said:

The same on my Gigabyte J3455N-D3H. Syno, std, recovery won't work.

had one tester with this board, he was able to boot and install dsm 6.2.2 but had stability problems, but as he also had this problems with jun's original loader and dsm 6.2.0 so it must have been something else that produced stability problems

 

in general "not booting" in most cases is not the correct term, that would be the case if you dont see jun's message or no menu (3 options from grub boot manager) and that would have nothing to do with the drivers, maybe "it does not finish booting" comes near

please describe your steps, and that means not cut and paste my description, describe what you really have done, when unsure redo the steps you about to write down, in some cases people might see by themselves that they missed a step just by writing it down and rereading the guide

don't make assumptions when there are no data, the only thing you can usually say, if you see jun's message and don't have a serial console connected, is that you can't find it in network after booting, that can have a lot of reasons, starting with a loose or "wrong" network cable (uups wrong switch), general network config problems (vlan's, more then one dhcp server, ...) to crashing driver on loading kernel that halt's the system

 

Link to post
Share on other sites
3 hours ago, pcVirus said:

please make a driver for the intel i219v network

that would be e1000e.ko and that driver is recent, version 3.6.0

as you can see here, its the latest version

https://sourceforge.net/projects/e1000/files/e1000e stable/

 

but there are more options to consider

maybe read what i wrote one post above your's about boot problems

 

20 hours ago, IG-88 said:

please describe your steps, and that means not cut and paste my description, describe what you really have done, when unsure redo the steps you about to write down, in some cases people might see by themselves that they missed a step just by writing it down and rereading the guide

don't make assumptions when there are no data, the only thing you can usually say, if you see jun's message and don't have a serial console connected, is that you can't find it in network after booting, that can have a lot of reasons, starting with a loose or "wrong" network cable (uups wrong switch), general network config problems (vlan's, more then one dhcp server, ...) to crashing driver on loading kernel that halt's the system

 

Link to post
Share on other sites
В 17.02.2020 в 18:53, Huberer сказал:

@pcVirus
Вы пробовали с нетронутым загрузчиком?
У меня есть i219-LM (Fujitsu d3417-b2), и он отлично работает с нетронутым


Gesendet von iPhone mit Tapatalk

Yes, I tried! she can't see the network

Link to post
Share on other sites
В 17.02.2020 в 21:39, IG-88 сказал:

это был бы e1000e.ko и этот драйвер недавно, версия 3.6.0

как вы можете видеть здесь, его последняя версия

https://sourceforge.net/projects/e1000/files/e1000e stable /

 

но есть еще варианты для рассмотрения

возможно прочитайте то, что я написал одним постом выше Вашего о проблемах загрузки

 

 

The Board has 2 network devices. The second Realtek device sees the network, but Intel doesn't! (standard loader). With mod 0. 8_std ds918+ - extra.lzma/extra2.lzma for loader 1. 04b_mod ds918+ DSM 6.2.2 v0.8_std and 0.8_syno ds918+ - extra.lzma/extra2.lzma for loader 1. 04b_mod ds918+ DSM 6.2.2 v0.8_syno does not see the network neither Intel nor Realtek/

Link to post
Share on other sites
12 minutes ago, pcVirus said:

does not see the network neither Intel nor Realtek/

 

and the logic dictates that its not the drivers(s) as other people are using them

maybe try a older loader and dsm 6.1 for 3615 to make sure hardware is working

Link to post
Share on other sites
20 минут назад, IG-88 сказал:

 

и логика диктует, что это не драйверы (ы), как их используют другие люди

возможно, попробуйте старый загрузчик и dsm 6.1 для 3615, чтобы убедиться, что оборудование работает

In dsm 6.1, everything is the same for 3615. Realtek works, Intel doesn't. But in this motherboard, Wi-Fi and Bluetooth are integrated into the Intel chip, and I disabled all this in the BIOS. The result is a FAILURE.

Link to post
Share on other sites
13 hours ago, pcVirus said:

n dsm 6.1, everything is the same for 3615. Realtek works, Intel doesn't. But in this motherboard, Wi-Fi and Bluetooth are integrated into the Intel chip, and I disabled all this in the BIOS. The result is a FAILURE.

i did not write it that way but meant you should also use the extra.lzma for loader 1.02b/DSM 6.1 from here to get better/newer intel driver for dsm 6.1

https://xpenology.com/forum/topic/9508-driver-extension-jun-102bdsm61x-for-3615xs-3617xs-916/

Link to post
Share on other sites

Hi

 

When I disconnect the HDMI cable from the iGPU HDMI port on the main board or from the HDMI port on the monitor, the Ethernet port disappears.
When I reconnect the HDMI cable, the Ethernet port will work again.
Not only HDMI cables, but also DVI and RGB.

 

The bootloader version is 1.04b.

Bootloader 1.04b was modified with (0.8_syno ds918+ - extra.lzma/extra2.lzma for loader 1.04b_mod ds918+ DSM 6.2.2 v0.8_syno).
Use the DS918+ DSM 24922 version.
The main board and the CPU are
GIGABYTE GA-B85N Phoenix-WIFI, i5-4690.
Ethernet is Intel.

 

Is there any solution?

Link to post
Share on other sites
47 minutes ago, Peter Suh said:

Is there any solution?

 

don't connect a monitor, as long as there are no boot problems there is no need for a monitor

dsm is designed as a headless system

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.