Driver extension jun 1.03b/1.04b for DSM6.2.2 for 3615xs / 3617xs / 918+


Recommended Posts

I have an Asrock z390 pro4 with Intel core i3 9100. Can't get either 918+, ds3615xs or The ds3617 with changes as per iG88(extra.lzma and two files from the pat file) to be detected with my onboard nic. Please help

Edited by Siva
Link to post
Share on other sites

Upgrade n54l (with internal NIC) 3615xs from 6.1.7 to 6.2.2 + extra.lzma (with adding 2 kernel files to image as described) as "migration" seems not completely successfull. After the procedure system is accessible on the previously assigned IP, but any action through web-interface leads to freezes and unavailability within a couple of minutes. With no login - files and folders accessible through LAN, but I cannot even get access to Control Panel or update packages. Repeats after reboot. Any advice how to fix it without clean install / downgrade? What to check first?

Link to post
Share on other sites
7 hours ago, deaduser said:

Upgrade n54l (with internal NIC) 3615xs from 6.1.7 to 6.2.2 + extra.lzma (with adding 2 kernel files to image as described) as "migration" seems not completely successfull. After the procedure system is accessible on the previously assigned IP, but any action through web-interface leads to freezes and unavailability within a couple of minutes. With no login - files and folders accessible through LAN, but I cannot even get access to Control Panel or update packages. Repeats after reboot. Any advice how to fix it without clean install / downgrade? What to check first?


See my posts earlier in this thread regarding updating from 6.1.7 to 6.2.2. I had the same issues and I ended up performing a fresh install. 

Edited by Decebalus
  • Thanks 1
Link to post
Share on other sites

Hi all,

 

I was so stupid to assume 6.2.2 was a minor upgrade. Did the upgrade from 6.1 to 6.2 using 1.04b just fine on my Asrock N3150-B. Then I updated to 6.2.2 and off course I lost network to the machine. In what seems to be a futile attempt I tried to load the lzma 0.6 test (copy onto the partition) but no change.

 

What are my best options to proceed? I don't mind to reinstall the DSM bits and bytes but would like to keep my volume1 and volume2 intact?

Link to post
Share on other sites
On 1/25/2020 at 5:48 PM, Siva said:

I have an Asrock z390 pro4 with Intel core i3 9100. Can't get either 918+, ds3615xs or The ds3617 with changes as per iG88(extra.lzma and two files from the pat file) to be detected with my onboard nic. Please help

 

the nic is jus a normal newer intel, older driver (like in jun's original extra.lzma or from synology) might not work

 

the 3615/17 need CSM (BIOS) mode and you also need to set the boot device to bios mode (there might be 3 after enabling bios mode, two uefi one other for the same usb device)

the nic should work with the new extra.lzma

 

918+ might not work as the intel drivers in the "old" 918+ release are to old, the new 0.8 will have the same new drivers as the latest extra.lzma for 3615/17 have

 

I'd suggest try 3615/17  and look for the bios settings and if you want to get 918+ working without the not released 0.8 driver pack then you can try with a older nic in a pcie slot

 

 

46 minutes ago, lcars8467 said:

I was so stupid to assume 6.2.2 was a minor upgrade. Did the upgrade from 6.1 to 6.2 using 1.04b just fine on my Asrock N3150-B. Then I updated to 6.2.2 and off course I lost network to the machine. In what seems to be a futile attempt I tried to load the lzma 0.6 test (copy onto the partition) but no change.

 

What are my best options to proceed? I don't mind to reinstall the DSM bits and bytes but would like to keep my volume1 and volume2 intact?

 

if you still have the usb in the state as it was after the 6.2.2 update (dont mind the different 0.6 extra.lzma) the you could just copy a new "recovery" extra.lzma version to the usb and all problems solved - i will send you a link to that new beta version, i had one tester with a N3150 and he solved the problems with it

 

  • Like 1
Link to post
Share on other sites
3 hours ago, Decebalus said:


See my posts earlier in this thread regarding updating from 6.1.7 to 6.2.2. I had the same issues and I ended up performing a fresh install. 

 

Pity I haven't found your report earlier, that would make me a bit more discreet with the upgrade. Seems like I was too optimistic, as some users reported about no problem with migration at all. So, any problem with the clean install over this half-migrated half-bricked system with the same USB stick? Disks are on their places with all the data untouched, only packages and shares should be installed?  Any precautions / advices?

Link to post
Share on other sites
37 minutes ago, IG-88 said:

 

if you still have the usb in the state as it was after the 6.2.2 update (dont mind the different 0.6 extra.lzma) the you could just copy a new "recovery" extra.lzma version to the usb and all problems solved - i will send you a link to that new beta version, i had one tester with a N3150 and he solved the problems with it

 

 

That was the solution, thank you very much my machine is back up and running!!

Link to post
Share on other sites

I am using bhyve hypervisor. FreeBSD's bhyve only support virito_net and e1000. (not e1000e)

unfortunately, e1000 is not so stable, and virito-net is not automatic loading with extra.lzma.

 

Currently I passthough a dual port e1000e to vm. and DSM 6.2.2 works flawlessly.

(with jun's 1.03b, 3617xs)

 

I have a Chelsio T520-CR on FreeBSD host. and SR-IOV works.

I'd like to passthough a VF of T520-CR to DSM.

Here is the pci info after I pass the VF (command output from DSM 6.2.2)

0000:00:08.0 Class 0200: Device 1425:5801
	Subsystem: Device 1425:0000
	Flags: bus master, fast devsel, latency 0
	Memory at c0204000 (32-bit, non-prefetchable) [disabled] [size=4K]
	Memory at c0208000 (32-bit, non-prefetchable) [disabled] [size=32K]
	Memory at c0210000 (32-bit, non-prefetchable) [disabled] [size=8K]
	Capabilities: [70] Express Endpoint, MSI 00
	Capabilities: [b0] MSI-X: Enable- Count=8 Masked-
	Capabilities: [50] MSI: Enable- Count=1/32 Maskable+ 64bit+

cxgb4.ko and cxgb4vf.ko already exists in exra.

But I can't find cxgb5vf source from linux kernel.

Any way to build the kernel module from driver that come from chelsio website?

Link to post
Share on other sites

@IG-88 I'm currently running the latest 6.2.2 upadate on a J4105-ITX with ds918+ on the 1.04b loader. Unfortunately no matter what I do I can't seem to get hw transcoding to work (serial and mac from real 918+). Will your extensions make that possible?

Link to post
Share on other sites
3 hours ago, The_Dave said:

Will your extensions make that possible?

 

the driver are about having /dev/dri that is used for transcoding, in most cases people seem to choke on the serial and mac address protection in synologys video station package and the driver won't help with this

there might be something in in that field but its pretty new and might be work in progress

https://xpenology.com/forum/topic/24864-transcoding-without-a-valid-serial-number/

 

the feedback i got so far for the 0.8 beta test for 918+ is not as good as i was hoping no luck with J3455 an 6.2.2 so far and J4105 does not look any better

mainly about /dev/dri, other drivers are ok, so people just wanting to use 6.2.2 with 918+ and not using /dev/dri would be 100% ok i think

 

if there are people with serial console and J33xx/J34xx, J4205 or J40xx/J41xx, J50xx and willing to test with a fresh usb and a empty disk - i need feedback about errors on booting after installing (console output if it stops booting or dmesg if its booting and does not produce /dev/dri

 

Link to post
Share on other sites
On 1/27/2020 at 11:39 AM, deaduser said:

 

Pity I haven't found your report earlier, that would make me a bit more discreet with the upgrade. Seems like I was too optimistic, as some users reported about no problem with migration at all. So, any problem with the clean install over this half-migrated half-bricked system with the same USB stick? Disks are on their places with all the data untouched, only packages and shares should be installed?  Any precautions / advices?


I would suggest to contact IG-88 first based on the below. I would see if that works first. I was not able to complete the upgrade and ended up with a fresh install after which I copied back the data (had backups). 

 

On 1/27/2020 at 11:38 AM,  IG-88 said: 

 

if you still have the usb in the state as it was after the 6.2.2 update (dont mind the different 0.6 extra.lzma) the you could just copy a new "recovery" extra.lzma version to the usb and all problems solved - i will send you a link to that new beta version, i had one tester with a N3150 and he solved the problems with it

Link to post
Share on other sites
On 1/27/2020 at 9:14 AM, deaduser said:

Upgrade n54l (with internal NIC) 3615xs from 6.1.7 to 6.2.2 + extra.lzma (with adding 2 kernel files to image as described) as "migration"

 

3 hours ago, Decebalus said:

f you still have the usb in the state as it was after the 6.2.2 update (dont mind the different 0.6 extra.lzma) the you could just copy a new "recovery" extra.lzma version to the usb and all problems solved - i will send you a link to that new beta version, i had one tester with a N3150 and he solved the problems with it

 

that does not match, the (not released) recovery version of the extra.lzma is just a special need for 918+ as there are problems with the i915 driver that is used for transcoding, has nothing to do with 3615/17 as there are no gpu drivers

n54l is far to old to be used with loader 1.04b and 918+

Link to post
Share on other sites
11 hours ago, IG-88 said:

 

 

that does not match, the (not released) recovery version of the extra.lzma is just a special need for 918+ as there are problems with the i915 driver that is used for transcoding, has nothing to do with 3615/17 as there are no gpu drivers

n54l is far to old to be used with loader 1.04b and 918+

Yes, I know, looks like reputable Decebalus mixed up our two cases. I plan to continue with the clean install with the same 1.03b loader on the same USB stick, so wondering is there something I should care of or this process simple and straight forward (in part of discovery of existing disk pools, first of all). I cannot recall if I did it previously. 

Link to post
Share on other sites

Hello Gurus,

 

I need your urgent help to do my own NAS, but i want to select the best motherboard that can handle file/folder shares as well as backups (Hyper Backups and Active Backup for business) and one Virtual MAchine (Win 10 or 7). That said, which MB would give me the best performance from the below ones.

 

1) ASROCK J3355
2) ASROCK J4005

3) ASROCK J4105 

4) ASROCK J4205 (has two different SATA controllers, one of them is ASMedia ASM1061, support NCQ, AHCI and Hot Plug)

5) ASROCK J5005

 

forgot to mention that i intend to use DS3615xs with 4x 6TB drives in SHR volume or is it better to use DS918 for the sake of the above scope.

 

For sure i would like to use the updated DSM 6.2.x, but if not, then i can use 6.1.x - has any one tested any of those MB with either loaders?

 

which mother board will give best speed (read/write) with no processing bottle nicks for 15 users?

 

@IG-88 can you help me choose plz?

Edited by TheMonk
Link to post
Share on other sites
6 hours ago, TheMonk said:

For sure i would like to use the updated DSM 6.2.x, but if not, then i can use 6.1.x - has any one tested any of those MB with either loaders?

 

as you seem not to be interested in hardware transcoding i'd also go with the latest tech J5005

imho mini-itx is not a good choice as you have not much options to extend like having a 4/8 port ahci controller or 10G nic, micro-atx offers more in that direction (have a look at the gigabyte B365M-HD3/B360M-HD3)

also when using it in a multi-user scenario the ssd cache (2xssd for read/write cache) might be worth to consider (usually not needed with 1-2 users in home environment)

 

Link to post
Share on other sites

@IG-88 Many thanks for your feedback. I will take a look on the options you have given me here. The reason i choose mini-itx because of tight budget. But for sure i will re-review in the light of your example of GigaByte B365M-HD3

Link to post
Share on other sites
3 minutes ago, TheMonk said:

have you tested J5005 with any XPE loader? Apprciate if you have any feedback on your judgement.

 

i have positive feedback from testers of the new 0.8 driver pack for 918+ about booting and network drivers working and as long as you are not interested in hardware transcoding it will be ok

Link to post
Share on other sites
1 minute ago, IG-88 said:

 

i have positive feedback from testers of the new 0.8 driver pack for 918+ about booting and network drivers working and as long as you are not interested in hardware transcoding it will be ok

 

@IG-88 not interested on hardware transcoding, but for sure i will need speed and performance for file/folder sharing and different kinds of backups as mentioned.

 

Much obliged for helping me find my way here!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.