Sign in to follow this  
goldmind

XPENOLOGY on ESXI 5.1 with spindown / hibernation setting

Recommended Posts

Hello community,

I have the following problem.

I have successfully installed DMS 5.0-4493U2 on my ESXI / Hypervisor 5.1.

I configured it with a PCIe SATA controller "Digitus DS-30104-1" (with MARVELL 88SE9230 chipset) wich is passed through to the VM XPenology via vT-d passthrough. Everything works first very good and all hard drives are recognized.

My problem is that I would like the disks to use spin-down function. I've also read that just needs to get out at a native installation the USB stick.

But what do i have to do in my Case? The "USB Stick" is in my case a VM HDD.

I hope you can help me.

Share this post


Link to post
Share on other sites

What I Tried:

XPenology natively -> Spin Down Works with internal controller and Marvel SATA controller

Different versions of ESXI 5.1 and 5.0 -> SATA controller passed through to VM -> same problem

under a Windows operating system -> SATA controller passed through to VM -> spindown works

 

It must be a driver problem in XPEnology in conjunction with the ESXI...

 

Please help!

Share this post


Link to post
Share on other sites

What disks do you have?

 

I'm on ESXi 5.5 and spin down doesn't work for me, nor does SMART data.

 

However I read on WD's site the firmware on WD RED's does spin down itself, doesn't need an OS to perform said task.

So if you're using WD RED it's not important, it's already in hand.

Share this post


Link to post
Share on other sites

I use Seagate ST3000DM001, but i tried it also on wd RE500GB and WD1TB Black.

Everytime the same thing.

But i have already 4 x 3TB and to buy again new Drives... This will be a little bit expensive.

I heard that the build in Spindown in a disk ist not so good if you want to run a raid...

My Idea is that i pass the hole controller that the xpe can manage the disk´s by himself...

 

Maybe this is a Nanoboot Problem?

Linke i siad: xpe native installation can spindown all harddrives. On the Marvel controller an on the internal Mainboard controller...

Share this post


Link to post
Share on other sites

resolved:

To all who want to build a similar project ...

 

The key is that you are installing on the ESXI not with virtual hard disks based (nanoboot + data memory).

But packs a Native installation in a VM.

With the tool Plop Boot Manager 5.0, you can create a Live CD with which you can start Nanoboot from a real USB stick.

 

So you created the VM as in an installation as normal hardware.

Create a Image with Live Plop Boot Manager, to launche automatically from a USB stick

 

1 Create Nano boat on USB Stick

2 Connect USB Stick with Nanoboot to VM

3 Passtrugh disks to the VM

4 Set up boot sequences in VM Bios on CD Image

5 remove USB stick either manually or by script from the DS

 

and behold, the spin down of HDD's Now works in a VM fine.

Share this post


Link to post
Share on other sites

Bravo Goldmind, I have the similar setup as yours (NB + 4528 on ESXi 5.0U3, LSI9211-8i pass through to DSM), spin down and SMART didn't work, I will try your solution, can you give me the detail step by step guide? Thanks!

Share this post


Link to post
Share on other sites

I'm currently trying to get things working on my esxi 5.5 but strange things are happening..

I installed a HighPoint Rocket 640L on my Gigabyte GA Z87-D3HP motherboard. Esxi recognizes this card and I can check it to be available for passthrough. The Highpoint uses the Marvell 88SE9230 chipset)

I can then add the card to my VM as a PCI device, but ONLY in vSphere Client, managing the host directly. When I try to add the card in Web client, I get an error that passthrough device ID is invalid. When I boot the VM, I can see my disks that are connected to the Highpoint SATA Controller BUT I have to connect them to port 2 and port 4. When I try to connect them to port 1 and 2, only the disk connected to port 2 is visible.. I can install DSM (4528) but when I create a volume RAID 1 or SHR, the VM crashes..

I'm now doing a wipe on my disks so that they are clean and will try again to install 4493 and create Volume.

But even if that works, I can only use 2 of 4 ports on the Highpoint card..

 

Any ideas what I can try? I'm afraid the Nanoboot or Gnuboot latest editions do not have the right drivers for this card..

Share this post


Link to post
Share on other sites

For those interested..

I currently have my DS up and running. I reinstalled esxi 5.5 (added all new patches and added sata ahci driver from http://www.v-front.de/2013/11/how-to-ma ... -ahci.html)

This way I was able to attach my disk with the datastore on to the Highpoint (port 2!). This made my datastore visible again.

Next I followed the steps described in last post of : https://communities.vmware.com/thread/458324.

This made my onboard SATA AHCI Lynx Point available for passthrough.

Passed it through to my VM and all disks visible (also in the right order!)

Then I could finally make my volume and start copying my backup to it..

Hope this will help some other esxi users..

The Highpoint card costed around € 65 so in my opinion a rather cheap solution to work with esxi and still be able to monitor disks!

Untill now, performance seems good!

Share this post


Link to post
Share on other sites
Sign in to follow this