goldmind

XPENOLOGY auf ESXI 5.1 inkl. Spindown/Hibernation Einrichten

Recommended Posts

Hallo liebe Gemeinde, ich habe folgende Problem.

Ich habe mir Erfolgreich das DMS 5.0-4493U2 auf meinem ESXI/Hypervisor 5.1 Installiert.

Zusätzlich habe einen PCIe SATA Kontroller "Digitus DS-30104-1" (mit MARVELL 88SE9230 Chipsatz) per Passthrough an die VM-XPenology durchgereicht. Funktioniert auch alles erstmal soweit sehr gut und alle Festplatten werden erkannt.

Mein Problem ist das ich gern die Festplatten Spindown Funktion nutzen wollen würde. Ich habe auch schon gelesen das bei einer nativen Installation der USB Stick einfach nur raus muss und dann Funktioniert die Einstellung die man im "Hardware und Energie" eingestellt hat . Wie mache ich es aber bei meinem Scenario? Den der "USB Stick" ist ja in meinem Fall eine VM-HDD.

Ich hoffe ihr könnt mir helfen.

Falls noch weitere relevante Daten notwendig sind sagt einfach bescheid...

Share this post


Link to post
Share on other sites

Ok was ich nun noch selbst Probiert habe:

XPenology nativ -> Spindown Funktioniert mit internem Kontroller und Marvel SATA Kontroller

Unterschiedliche ESXI Versionen 5.1 und 5.0 -> SATA Kontroller durchgereicht an VM -> gleiches Problem

unter einem Windows Betriebssystem -> SATA Kontroller durchgereicht an VM -> Spindown Funktioniert

 

Es muss anscheinend ein Treiberproblem sein im XPEnology in Verbindung mit dem ESXI...

 

Bitte dringend um Hilfe!

Share this post


Link to post
Share on other sites

Gelöst:

An alle die ein ähnliches Projekt aufbauen möchten...

 

Das entscheidende ist das man die Installation unter dem ESXI nicht mit Virtuellen Festplatten aufbaut (Nanoboot + Datenspeicher).

Sondern quasi eine Native Installation in eine VM packt.

Mit dem Tool Plop Boot Manager 5.0 kann man eine Live CD erstellen mit welcher man Nanoboot von einem USB Stick starten kann.

 

Man erstellt also die VM wie in einer Installation wie bei normaler Hardware.

1. Image mit Live Plop Boot Manager erstellen mit dem automatisch von einem USB Stick gestartet werden kann

2. Nanoboot auf USB Stick erstellen

3. USB Stick mit Nanoboot an VM anbinden

3. Festplatten per Passthrue an die VM durchreichen

4. Bootreihenfolgen in VM Bios auf CD Image einrichten

5. USB Stick entweder manuel oder per Script aus der DS entfernen

 

und siehe da, der Spindown der HDD´s Funktioniert nun auch in einer VM.

Share this post


Link to post
Share on other sites

Ansich sollte die Installation unter VMWare Workstation Funktionieren (ich habe aber leider keine Workstation...)

Soweit ich es aber nachlesen konnte, kann die Workstation wohl nur SSD´s durchreichen und keine HDD´s oder PCI Kontroller...

MfG

Share this post


Link to post
Share on other sites

HDD's kan mann in Workstation 10 durchreichen indem mann die HD als SCSI anbietet. Jedoch Spindown funktioniert nicht. Weiss jedoch nicht ob dies auch innerhalb Mikkiesoft geht (Momentan Linux installiert mit VMWare Workstation. Vielleicht HDparm verwenden?)

Share this post


Link to post
Share on other sites

Danke @goldmind für diese Lösung.

Ich selbst suche gerade nach einem Weg, Hibernation unter ESXI hinzubekommen.

 

Wenn ich Deinen Weg richtig verstanden habe:

1.) Live CD mit Plop Boot Manager erstellen und diese in ein virtuelles Laufwerk per iso legen

2.) Nanobootstick in einen realen USB Port und diesen mit der VM verbinden

...

richtig?

(beschäftige mich erst seit ca. 3 Tagen mit ESXI)

 

 

Kannst Du mir sagen, ob durch Deine Lösung ebenfalls die Smartdaten über Synology DSM einsehen kannst?

 

beste Grüße

Christian

Share this post


Link to post
Share on other sites

Hallo Christian,

Schön einen Gleichgesinnten zu treffen .

Ja das hast du richtig verstanden.

Zu 1.)

Es gibt die Möglichkeit mit Plop ein Custom iso zu erstellen in dem dann automatisch von USB gebootet wird.

 

Dadurch das man den Controller inkl. Der Festplatten durchreicht werden die Smartwerte auch komplett angezeigt.

 

Nachteil dieser Methode, was ich zumindest bis jetzt herausgefunden habe...

 

Open vm Tools erkennen das NAS nicht als vm.

Man muss dieses beim herunterfahren oder Neustarten des esxi davor entweder manuell oder per Script von einer anderen vm (wenn diese herunterfährt) herunterfahren lassen. Mit dem shutdownscript von einer anderen VM habe ich zwar angefangen mich ein zu lesen, habe es aber auch noch nicht umgesetzt.

Wenn hier jemand eine Idee oder Lösung hat

Hör ich sie mir gern an

 

Ich habe 4x 3TB Seagate 3000DM001 drin. Bei mir hat sich mein SHR RAID verabschiedet. Hat mir defekte Sektoren gemeldet. Nach Prüfung aller Platten konnte ich dies aber nicht feststellen...

Mit RAID 5 (direkt) läuft es erstmal fehlerfrei...

Ich tippe eher auf Kompabilitätsprobleme vom SHR mit dem Controller oder den Festplatten.

 

Kannst dich ja nochmal melden wie es bei dir voran geht.

Grüße

 

 

 

Gesendet von iPhone mit Tapatalk

Share this post


Link to post
Share on other sites

Ps man muß noch den USB stick genauso wie bei der nativen Installation unmounten damit die hibernation funktioniert.

 

 

Gesendet von iPhone mit Tapatalk

Share this post


Link to post
Share on other sites

Ich häng mich dann auch mal rein. Würde gerne auch auf meinem HP ProLiant Microserver (Gen8) gerne Hibernation und SMART nutzen. Sobald ich Zeit habe, versuche ich mich mal daran. Es hat nicht zufällig jemand auch den Gen8 und das schon hinbekommen?

Share this post


Link to post
Share on other sites

Also USB und Kartenleser laufen auch über den Controller?

Zur Not müsste ich mir mal einen zweiten kaufen. Hätte ja einen Steckplatz frei...

Share this post


Link to post
Share on other sites

Nein natürlich nicht. Aber soweit ich weiß kannst du kein datastore über USB einbinden. Kartenleser hab ich glaub ich was gehört, bzw Soweit ich mich entsinne waren diese über IDE und compactflash... Glaub aber nicht das diese so Performant sind da vielleicht ein größeres so darauf laufen zu lassen außer vielleicht ein kleines Linux...

Alternativ, weiß aber nicht ob dann die hibernation funktioniert, xpenology auf die von mir beschriebene Weise einbinden, iscsi und dieses als datastore einbinden...

 

 

 

 

Gesendet von iPhone mit Tapatalk

Share this post


Link to post
Share on other sites

Ok, dank dir schon mal. Damit muss ich mich dann mal auseinander setzen, wenn ich wieder etwas mehr Zeit habe. Ich würde natürlich gerne noch versuchen etwas Strom zu sparen und SMART wäre auch sehr gut.

Vielleicht teste ich auch nochmal Xpenology im AHCI Mode ohne ESXi. Da hieß es allerdings, dass der Lüfter lauter dreht.

Share this post


Link to post
Share on other sites

@goldmind:

Danke für Deine Hilfe.

Unglücklicherweise habe ich in Deinem Anfangsposting übersehen, dass Du die HD mit PCIe SATA Controller druchreichst.

Mein Setup sieht keinen separaten SATA Controller vor, deshalb kann ich Deine Lösung doch nicht nutzen.

 

beste Grüße

Christian

Share this post


Link to post
Share on other sites

Hi zusammen,

 

ich möchte DSM auch in Verbindung mit ESXi 5.5 nutzen.

Habe mir jetzt auch den Digitus Sata Controller bestellt, damit der Disk Spindown funktioniert.

Auf http://www.xpenology.nl/boot-images/ gibt es ja auch ISOs.

Hat schon mal jemand getestet, ob der Spindown funktioniert, wenn man NanoBoot als virtuelle CD einbindet, oder muss diese dann auch nach dem Booten ausgeworfen werden?

Das mit Plop ist mir schon irgendwie ein bisschen zu umständlich.

 

Die VMware Tools funktionieren so übrigens auch. Zumindest, wenn sie vorher installiert waren und man dann die Nanoboot-VMDK entfernt und durch die Nanoboot-ISO ersetzt.

Ich werde es mal testen, sobald mein Controller da ist.

 

 

Viele Grüße

 

Lynchme

Share this post


Link to post
Share on other sites

Halt mich doch mal auf dem laufenden, ob du es mit dem Image auch hin bekommst.

 

Habe auch nach dieser Anleitung installiert. Setze ebenfalls den Digitus Controller ein. Durchgereichter Kontroller mit den vier Platten geht schön in den SpinDown. Habe jedoch wie beschrieben per Plop und USB gebootet. Mit Image kann ich nichts sagen.

 

Hatte auch Probleme mit ESXI 5.5. Setze nun 5.1 ein. Habe jedoch noch einen Treiber vbr im ESXI Image installiert. Welche für den Marvell Chip ist.

 

Wollte jetzt auch nicht mehr viel Basteln, da es funktioniert und der Satz gilt "Never touch a running system".

 

Grüße aus Augsburg

Share this post


Link to post
Share on other sites

Hi Cheesy,

 

mein Controller ist heute gekommen und es funktioniert perfekt!

Im DSM hängen jetzt die NanoBoot-ISO als virtuelle CD und der durchgeschleifte Digitus mit einer 4TB-Festplatte.

Die Platte fährt wie gewünscht nach 10 mins runter :smile:

Open-VM-Tools laufen ebenfalls und das mit ESXi 5.5 UP3.

 

Woran hakte es denn bei dir mit ESXi 5.5?

Was ich mir vorstellen könnte wäre:

 

- Du hattest ESXi 5.5 UP2 laufen ( die ISO von MyVMware ist nur UP2, UP3 muss manuell nachinstalliert werden; bringt auch übrigens USB3.0-Support :smile: )

- Mein Digitus hat eine neuere Firmware

 

Falls du Lust hast auch auf die ISO umzusteigen, einfach folgenden Eintrag in die .vmx packen: bios.bootOrder = "cdrom,floppy"

Das legt die Bootreihenfolge für die CD fest. Über das Bios hatte es bei mir nicht richtig geklappt.

 

Viele Grüße

 

Lynchme

Share this post


Link to post
Share on other sites

Hatte das Problem,

 

das wenn Nanoboot gestartet ist, nur die Grubbefehle kamen, dann oben die Überschrift mit NanoBoot. Dann war schluß. DSM mit den Laden der Module ist nicht gestartet. Habe dann festgestellt, dass das Problem daran lag, sobald als ich den SATA Controller durchgereicht hatte, ist DSM nicht gebootet. Controller aus Config raus und die Kiste ist gelaufen.

Probiere gerade erneut ESXI 5.5 UP2. Ist UP3 beta, finde es nirgends.

Habe auch noch vib in ESXI hinzugefügt, welche für mehrere Kontroller ist. Diese hatte ich bei ESXI 5.1 auch hinzugefügt. Vielleicht war es ja das. Ich werde berichten.

 

Danke mal fürs testen

 

Grüße aus Augsburg

 

Nachtrag: ESXI 5.5 UP2 mit DSM funktioniert nun. Habe per Update von 5.1 installiert. Auch habe ich deinen Ratschlag verfolgt und die Nanoboot ISO per DVD gemountet. Jedoch ohne Config Änderung, sondern nur den Hacken bei Einbinden beim Einschalten gesetzt. Nanoboot und DSM bootet und die Platten legen sich schön schlafen. Warum es beim ersten mal nicht funktioniert hat, kann ich nicht sagen. Vielleicht lag es wirklich nur an der hinzugefügten treiber.vib datei.

 

So, jetzt muss ich aufhören und weiter weinen. Augsburg hat gerade gegen Bayern 0:4 verloren :wink:

Share this post


Link to post
Share on other sites

Hi,

 

schön, dass es bei dir klappt :wink:

 

Sorry, es ist ein Patch vom Oktober und kein Update Package.

Hier der Link: http://kb.vmware.com/selfservice/micros ... Id=2087358

Und hier noch eine Anleitung, wie du dann USB 3.0 aktivierst, falls es dich interessiert: http://www.v-front.de/2014/11/vmware-si ... sb-30.html

 

Eine VIB habe ich nicht installiert. Ist für einen Passthrough auch eigentlich nicht nötig.

 

Ich hatte zwischendurch wieder Probleme mit dem Spindown, habe aber das Problem gefunden....

Sobald ich DSM zur Domain hinzugefügt hatte fuhren die Platten nur noch unregelmäßig herunter.

Naja dann eben ohne Active Directory :grin:

 

 

Viele Grüße

 

Lynchme

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now