Virtualbox and phpVirtualbox on XPEnology


Recommended Posts

Just noticed something strange tonight. If I start a VM (in this case a Win XP machine), it slowly fills up /dev/md0. Note, the VM itself is stored on /volume1/Virtualmachines, but something must be generating log or temp files at an alarming rate. I couldn't login to the DSM GUI because the volume was full. The space does not get cleared down when I stop theVM, only when I restart the NAS itself.

 

This only started happening since I upgraded to DSM5.1, The VMs worked fine before the upgrade, and the md0 didn't get filled up. Since the DSM Update the VMs are a lot slower than they were before.

 

Anyone else seen this?

 

Andrew

Link to post
Share on other sites

today and ' happened to me .. but I had imported a virtual machine and thought it was it ..

rather than what you say to be like you.

to me with windows 7

 

sorry for my bad english

 

nb..

sorry .. a few posts above ... find how to change administrator password ... have under eyes

Link to post
Share on other sites

Further to my earlier post about md0 filling up:

 

After I upgraded to DSM51 virtualbox wasn't working anymore, so I uninstalled it, then reinstalled it and updated the modules.

 

Since then:

 

The md0 fills up to 100% in about 30-45 minutes if I use a bridged network, it does NOT happen with NAT (this did not happen before DSM51)

The VM cannot reach the internet with bridged connection (it could before the upgrade to DSM5.1)

The VM CAN reach the internet if I use NAT.

VBoxManage command is not in the PATH (it was before the DSM upgrade)

 

Has anyone else had the same issues? I'm wondering if something went wrong with the installation of virtualbox, although there were no error messages).

 

Seba?

 

Andrew

Link to post
Share on other sites
Mittel,

Did you change the storage location to somewhere other than the default? The default stores the vms in /root/Virtualbox (or similar), the point being that it is on /dev/mdo which is the "system" disk, and doesn't have much space.

 

Andrew

Actually I did but still not working.

Link to post
Share on other sites
Mittel,

Where did you install the package from, and did you upgrade the modules after installing?

Can you create a new VM, as opposed to importing?

 

Andrew

 

I downloaded the package on page 11 made by dodo-dk.

Actually I don't see where I can update it, I guess this is already the latest version for dsm 5.1

 

I have just noted that I cannot create 64bits virtual machine! only 32bits! I guess it is the reason.

Now why I cannot do it, I have no idea.

Link to post
Share on other sites

Mittel,

Does your xpenology box show as a DS3615xs in Synology Assistant? (i.e. are you using the 64 bit xpeno?)

What does "cat /var/log/vbox.log" show?

I'm not sure if you still need to scp the modules or not with the latest download from dodo, did you?

 

Andrew

Link to post
Share on other sites
Mittel,

Does your xpenology box show as a DS3615xs in Synology Assistant? (i.e. are you using the 64 bit xpeno?)

What does "cat /var/log/vbox.log" show?

I'm not sure if you still need to scp the modules or not with the latest download from dodo, did you?

 

Andrew

 

There is no 32bits version, so I guess I have the 64bits

When I type cat /var/log/vbox.log i get a bunch of those lines:

 

02:22:43.964194 SQW03    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)
02:22:46.966576 SQPmp    Request 3252 on socket 10 queued for processing (1 items on Q)
02:22:46.966617 SQW03    Processing connection from IP=127.0.0.1 socket=10 (2 out of 3 threads idle)
02:22:48.326794 SQPmp    Request 3253 on socket 11 queued for processing (1 items on Q)
02:22:48.327042 SQW02    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)
02:22:49.973308 SQPmp    Request 3254 on socket 10 queued for processing (1 items on Q)
02:22:49.973348 SQW03    Processing connection from IP=127.0.0.1 socket=10 (2 out of 3 threads idle)
02:22:52.984255 SQPmp    Request 3255 on socket 11 queued for processing (1 items on Q)
02:22:52.984295 SQW02    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)
02:22:53.328508 SQPmp    Request 3256 on socket 10 queued for processing (1 items on Q)
02:22:53.328545 SQW01    Processing connection from IP=127.0.0.1 socket=10 (1 out of 3 threads idle)
02:22:56.123417 SQW03    Processing connection from IP=127.0.0.1 socket=13 (2 out of 3 threads idle)

Link to post
Share on other sites

So, after removing virtualbox, a reboot, and reinstalling from the latest download (file name: virtualbox-x64-4.3.12_DSM-5.1_fixed.spk) everything seems to be working fine again. After the reinstall all my VMs and settings were still there in the web interface, bridged mode now works, and the md0 filling up issue is gone.

 

The .spk that I had installed from was an earlier version, named:virtualbox-DSM5.1-4.3.12-93733.spk - I am not sure where I downloaded it from, but it was apparently not "fixed", as the latest download _is_ :smile:

 

Mittel, what was the name of the .spk file you had installed?

 

Andrew

Link to post
Share on other sites
So, after removing virtualbox, a reboot, and reinstalling from the latest download (file name: virtualbox-x64-4.3.12_DSM-5.1_fixed.spk) everything seems to be working fine again. After the reinstall all my VMs and settings were still there in the web interface, bridged mode now works, and the md0 filling up issue is gone.

 

The .spk that I had installed from was an earlier version, named:virtualbox-DSM5.1-4.3.12-93733.spk - I am not sure where I downloaded it from, but it was apparently not "fixed", as the latest download _is_ :smile:

 

Mittel, what was the name of the .spk file you had installed?

 

Andrew

 

Hi

 

I think I installed this one virtualbox-x64-4.3.12_DSM-5.1_fixed.spk

Link to post
Share on other sites
So, after removing virtualbox, a reboot, and reinstalling from the latest download (file name: virtualbox-x64-4.3.12_DSM-5.1_fixed.spk) everything seems to be working fine again. After the reinstall all my VMs and settings were still there in the web interface, bridged mode now works, and the md0 filling up issue is gone.

 

The .spk that I had installed from was an earlier version, named:virtualbox-DSM5.1-4.3.12-93733.spk - I am not sure where I downloaded it from, but it was apparently not "fixed", as the latest download _is_ :smile:

 

Mittel, what was the name of the .spk file you had installed?

 

Andrew

 

Hi

 

I think I installed this one virtualbox-x64-4.3.12_DSM-5.1_fixed.spk

Link to post
Share on other sites

DKeppi,

I presume you edited the INFO file in the .spk, changing the arch= from "bromolow" to "avoton", otherwise I don't think the install will contine, but it is worth asking.

 

Is the reboot immediate, or does it take a while?

 

What happens if you remove the "fixed" spk and install the package via packagemanager? (Add http://spk.synologyitalia.com/ to your Synology NAS Package Center sources)

 

If the "fixed" package is specific to xpenology then it may be making calls to modules that are not present on a real synology.

 

Andrew

Link to post
Share on other sites

DKeppi,

 

Am I correct, on a real ds415+, with the real synology DSM5.1, and the fixed spk, the machine spontaneously reboots when you start a VM?

 

What do /var/log/vbox.log and vboxscripts.log show?

 

Are these imported VMs? Any chance you are importing a 64bit VM, but your VB host is 32bit - this would cause a reboot in VB 4.0.18, perhaps the error is back.

 

Try creating a VM from scratch, single disk, booting from a simple install .iso like DSL or such, can you complete the install? Will the VM run?

 

Andrew

Link to post
Share on other sites

Hi, i have compiled the VirtualBox and Kernels with newer Version.

The newest phpvirtualbox i have added too.

 

Virtual Box 4.3.22 (98236)

phpVirtualBox 4.3-2

 

Here you can Download it: https://mega.co.nz/#!4F5gRRrI!EaCkp_7ct ... ByJQMlUP6Q

 

Please Stop all Virtual Machines and the VirtualBox before you deinstall the old VirtualBox.

 

Testet on XPEnology (XPEnoboot 5.1-5022.2 / DSM 5.1-5022 Update 2 / X64 DS3615xs)

 

Use it of your own risk.

 

Dodo

 

Edit: I have add arch="x86 cedarview avoton bromolow" in the SPK and updated the Download link.

Edited by Guest
Link to post
Share on other sites
Hi, i have compiled the VirtualBox and Kernels with newer Version.

The newest phpvirtualbox i have added too.

 

Virtual Box 4.3.22 (98236)

phpVirtualBox 4.3-2

 

Here you can Download it: https://mega.co.nz/#!pV4HCKBJ!DF29ArX2b ... jugqKcrzpw

 

Please Stop all Virtual Machines and the VirtualBox before you deinstall the old VirtualBox.

 

Testet on XPEnology (XPEnoboot 5.1-5022.2 / DSM 5.1-5022 Update 2 / X64 DS3615xs)

 

Use it of your own risk.

 

Dodo

 

 

Ok thanks a lot!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.