Virtualbox and phpVirtualbox on XPEnology


Recommended Posts

  • 2 weeks later...

vbox 5.1.30 on HP N54L is working for me with DSM 6.1.5-15254 -> following same edit process: replace the 3 values 15217 by 15254 in previous spk (5.0.40 or 5.1.30)

 

after upgrade: uninstall old vbox / reinstall updated spk

 

in the setup for the admin user put the admin password (admin must be enabled in dsm, and you need to set a strong password)

keep "run after setup" selected

reboot synology

 

in case you have port 18083 error after login on webpage (after rebooting with vbox started before reboot)

 

connect ssh & check:

sh-4.3# lsmod | grep vbox
vboxpci                15225  0
vboxnetadp             18580  0
vboxnetflt             17736  0
vboxdrv               373485  3 vboxnetadp,vboxnetflt,vboxpci

 

sh-4.3# netstat -an | grep 18083
tcp        0      0 127.0.0.1:18083         0.0.0.0:*               LISTEN

if phpvirtualbox does not connect after login/password (admin/admin and show error with port 18083) :

start the service manualy:
sh-4.3# cd /volume1/@appstore/
sh-4.3# ./opt/VirtualBox/vboxwebsrv &

 

retry:

sh-4.3# netstat -an | grep 18083, it should display a result, if not try version 5.0.40
sh-4.3# uname -a
Linux N54L 3.10.102 #15254 SMP Fri Jan 26 06:40:50 CST 2018 x86_64 GNU/Linux synology_bromolow_3615xs


VirtualBox_x64_5.1.30-118389-1.spk.dsm6.1.5

Link to post
Share on other sites

Since i try synology virtual manager i found sometimes i had a unreachable box, and forced to restart with power button (no ssh or gui accessible)

 

found this line in kernel log file:

 

Quote

2018-02-06T12:50:12+01:00 N54L kernel: [89540.479393] RIP: 0010:[<ffffffffa0bda8b7>]  [<ffffffffa0bda8b7>] ovs_vport_get_stats+0x7/0xc0 [openvswitch]

 

 

this seems to be caused by openvswitch activated (when you installed dsm virtual manager this option become enabled )  

 

go to config panel / network interface / manage and uncheck openvswitch (if you don't use dsm virtual manager)

 

your box should be more stable, if you have installed and removed the virtual manager. (once installed i can't proprely uninstall it, and had to go cli for manual uninstall)

 

 

 

did someone got it to work on xpenology with jun's bootloader (intel  or amd ?)

 

 

 

 

Link to post
Share on other sites
  • 4 weeks later...
  • 4 weeks later...
  • 2 weeks later...

Hi, I try to install Virtualbox ,

Getting one error when starting Virtualbox.

 

PHP does not have the SOAP extension enabled.

Could someone please point me how to archive this?

 

Sorry solved change browser :)

Edited by Joe1
Link to post
Share on other sites
  • 1 month later...
Il y a 2 heures, stefauresi a dit :

 

Hello
unable to install the package on my NAS (i7-7700) DSM 6.1.7.15284

 

Thx for your help.

DSM.PNG

 

Finally,

it's good on my 3617Xs

simply create VirtualBoxVMs folder manually before run installation

 

Thank you

Link to post
Share on other sites
  • 2 weeks later...

Hello,

 

I was no more able to install the version 5.1.30 since 6.1.5, so I decided to go back to VirtualBox 5.0.40 package updated for the 6.1.7 version (thank to Jarugut for VirtualBox_x64_5.0.40-115130-1_6.1.7.spk package).

 

The package installed perfectly on both of my systems: Pentium G4500 and AMD Ryzen 5 2400G.

The Pentium system had 16Go of RAM and all the 16Go are available in VBOX, but the Ryzen system is equiped with 8Go of RAM, but only 3460MB are available in VBOX. Does anyone would have a clue on how to solve this as in the end I like to use my Ryzen system in priority for my VM's.

 

Thanks & Regards

Link to post
Share on other sites
3 hours ago, GangaS said:

Hello,

 

I was no more able to install the version 5.1.30 since 6.1.5, so I decided to go back to VirtualBox 5.0.40 package updated for the 6.1.7 version (thank to Jarugut for VirtualBox_x64_5.0.40-115130-1_6.1.7.spk package).

 

The package installed perfectly on both of my systems: Pentium G4500 and AMD Ryzen 5 2400G.

The Pentium system had 16Go of RAM and all the 16Go are available in VBOX, but the Ryzen system is equiped with 8Go of RAM, but only 3460MB are available in VBOX. Does anyone would have a clue on how to solve this as in the end I like to use my Ryzen system in priority for my VM's.

 

Thanks & Regards

 

Add in the grub.cfg file the  disable_mtrr_trim option.

 

Link to post
Share on other sites
  • 5 weeks later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.