seba

Virtualbox and phpVirtualbox on XPEnology

Recommended Posts

I've successfully installed Virtualbox using VirtualBox_x64_5.0.40-115130-1_(for 6.1.4).spk with DSM 6.1.4 but I got error in PHP.

 Anyone expericed this error as well?

Capture.PNG

Share this post


Link to post
Share on other sites

VirtualBox_x86_64_5.0.22-108108-2_fixed dsm5967u4.spk

2 hours ago, dyter said:

Hello, 

 

I have DSM 5.2 and all virtualbox packages don't work, I need it !

 

mini_204131Capture.png

 

All Oracle links are changed to http://download.virtualbox.org/virtualbox/5.0.22/Oracle_VM_VirtualBox_Extension_Pack-5.0.22-108108a.vbox-extpack

(108108a not 108108)

On 7.12.2017 at 11:13 AM, nemesis122 said:

 

Hi enjoy fixed by me :D use this one with dsm 5967

regards

Nemesis

 

VirtualBox_x86_64_5.0.22-108108-2_fixed dsm5967u4.spk

Edited by nemesis122

Share this post


Link to post
Share on other sites

I'm getting a plain message saying:

"Could not install "VirtualBox""while installing the packages for 6.1.4 downloaded on from the links on this thread.

I'm running 6.1.4-15217 on 1.02b 3617xs.

Edited by MBchristoff

Share this post


Link to post
Share on other sites

Hi all 

I have trouble install php virtualbox for dsm 5967 since they have changed some thing on there website.

Could anyone help me edit the spk file for dsm 5967.1 ?

the file is attached also the log file was going wrong.

 

the Problem is the script is not downloading PHP virtualbox!! 

 

thank you very much 

Michael

 

 

--2018-01-10 09:18:40-- https://sourceforge.net/projects/phpvirtualbox/files/latest/download
Resolving sourceforge.net... 216.34.181.60
Connecting to sourceforge.net|216.34.181.60|:443... connected.
ERROR: cannot verify sourceforge.net's certificate, issued by '/C=GB/ST=Greater Manchester/L=Salford/O=COMODO CA Limited/CN=COMODO RSA Domain Validation Secure Server CA':
  Unable to locally verify the issuer's authority.
To connect to sourceforge.net insecurely, use `--no-check-certificate'.
unzip:  cannot find or open /volume1/@tmp/pkginstall/package/virtualbox_install_files/, /volume1/@tmp/pkginstall/package/virtualbox_install_files/.zip or /volume1/@tmp/pkginstall/package/virtualbox_install_files/.ZIP.
2018/01/10 09:18:54    install    virtualbox 5.0.22-108108-2:
            End:    preinst    ret=[1]
2018/01/10 09:18:54    install    virtualbox 5.0.22-108108-2:
            Begin:    /bin/rm -rf /volume1/@tmp/pkginstall
2018/01/10 09:18:54    install    virtualbox 5.0.22-108108-2:
            End:    /bin/rm -rf /volume1/@tmp/pkginstall    ret=[0]
2018/01/10 09:18:54    install virtualbox 5.0.22-108108-2 failed

 

 

 

synopkg.log

VirtualBox_x86_64_5.0.22-108108-2_fixed dsm5967u4.spk

 

 

but the certificate is up to date !:-(

this issue is happen on different servers so the problem is not the server 

Edited by nemesis122

Share this post


Link to post
Share on other sites

for this one who can solve thissue im ready to spend some money 

i have tried so mayn things and it is not working and i realy dont know why.

the main issue is it is not download php virtualbox

thanks

:-(

any tips or hint why this is happen i will try thanks

 

 

Edited by nemesis122

Share this post


Link to post
Share on other sites

Hi All, Great Project! I come from XPEnology HP Homeserver. Now i've DS918+ with SSD Cache. Cannot install VirtualBox. Installing VirtualBox_x64_5.1.30-118389-1_(for 6.1.4).spk because others not even starting to install. This one is stuck at: Your Kernal 4.4.15+ is not supported by this package!. Someone has solution for this? running 6.1.4 with update 5.

Thnx!

Share this post


Link to post
Share on other sites

VirtualBox is failing during installation.

Anyone found a solution? 

 

install Php 5.6 (OK)

install Web Station (OK)

DSM 6.1.4-15217 Update 5

DS3615xs

virtualbox.jpg

Edited by synologyturkey
Text

Share this post


Link to post
Share on other sites
 

hello try with 

VirtualBox_x64_5.0.40-115130-1_6.1.4.spk

http://spk.synologyitalia.com/packages/VirtualBox_x64_5.0.40-115130-1_(for 6.1.4).spk

this one is ok for me

 

 

and not with

VirtualBox_x64_5.1.30-118389-1_(for 6.1.4).spk

thanks for the reply. VirtualBox_x64_5.0.40-115130-1_(for 6.1.4).spk is not even starting to install. Incompatible package for current DSM Version.

Share this post


Link to post
Share on other sites
On 16-11-2017 at 9:49 PM, jarugut said:

 

Sorry mandolin but my kernel version is the following:

Linux NAS 3.10.102 #15217 SMP Fri Nov 10 20:08:59 CST 2017 x86_64 GNU/Linux synology_bromolow_3615xs

 

 

Maybe it's possible to change the REQUIRED_KERNEL_VERSION="3.10.102" to your kernel, but it's your responsability, I don't know what can happens.

How do i change REQUIRED_KERNEL_VERSION. If i use notepad++ the file is invalid after upload in DSM.

Thank you.

Share this post


Link to post
Share on other sites
1 hour ago, polcomp said:

How do i change REQUIRED_KERNEL_VERSION. If i use notepad++ the file is invalid after upload in DSM.

Thank you.

Try using something like Textpad

Share this post


Link to post
Share on other sites
2 hours ago, polcomp said:

How do i change REQUIRED_KERNEL_VERSION. If i use notepad++ the file is invalid after upload in DSM.

Thank you.

 

I used the 7zip software to open the spk file and I used the notepad++ to modify directly the file inside the 7zip.

 

In the options of the 7zip on the Editor tab you can  select what software do you want to use to modify the files.

imagen.png.28c2b54713dd22092233a229e1d120cf.pngimagen.png.075dae2ee7386cb2268548bcc206466e.png

Share this post


Link to post
Share on other sites
17 minutes ago, jarugut said:

 

I used the 7zip software to open the spk file and I used the notepad++ to modify directly the file inside the 7zip.

 

In the options of the 7zip on the Editor tab you can  select what software do you want to use to modify the files.

imagen.png.28c2b54713dd22092233a229e1d120cf.pngimagen.png.075dae2ee7386cb2268548bcc206466e.png

NICE!!! thank you!! that did the trick. Modified installer.sh from 4.4.15 to 4.4.15+. Install successful. 

But now i got Could not connect to host (http://127.0.0.1:18083/)...

Share this post


Link to post
Share on other sites
6 minutes ago, polcomp said:

NICE!!! thank you!! that did the trick. Modified installer.sh from 4.4.15 to 4.4.15+. Install successful. 

But now i got Could not connect to host (http://127.0.0.1:18083/)...

That is the problem that some people we have with VirtualBox_x64_5.1.30-118389-1 version. 

Share this post


Link to post
Share on other sites

T

21 minutes ago, jarugut said:

That is the problem that some people we have with VirtualBox_x64_5.1.30-118389-1 version. 

`Thanks! So we have to wait until someone fixes this problem? Can i try VirtualBox_x64_5.0.40-115130-1_(for 6.1.4).spk? because when i try to instal this one, it says incompatible DSM version. Is this also something to edit with Notepad? thanks!

Share this post


Link to post
Share on other sites
34 minutes ago, polcomp said:

T

`Thanks! So we have to wait until someone fixes this problem? Can i try VirtualBox_x64_5.0.40-115130-1_(for 6.1.4).spk? because when i try to instal this one, it says incompatible DSM version. Is this also something to edit with Notepad? thanks!

The problem is that this package version is only for kernel 3.10. It not have the  compiled libraries for other kernels.

Share this post


Link to post
Share on other sites

Ok, eddited some files in VirtualBox_x64_5.0.40-115130-1_(for 6.1.4).spk and could install it. But after installation still could not connect to localhost... Hope someone will make this package working for DS918+ :) 

Share this post


Link to post
Share on other sites

it is realy strange with this plugin i had a server here from a friend 8GB RAM setup complete done VirtualBox_x64_5.1.30-118389-1 was not working in my homelab try it over 2 hours restart and a lot of other things.

at home my friend started the server in his enviroment and BAM virtualbox is working!:-(

 

in my homelab i have a server with 16 gb ram VirtualBox_x64_5.1.30-118389-1 is not working and a server with the same config with 8gb RAM VirtualBox_x64_5.1.30-118389-1 is working.

 

it is realy strange

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.