seba

Virtualbox and phpVirtualbox on XPEnology

Recommended Posts

probably not, if the kernel source is not released from synology , the kernel is newer in dsm 6.2 (from 3.10.102 in dsm 6.1 to 4.4) so the vbox drivers wont work without compilation.

Share this post


Link to post
Share on other sites
On 2017. 11. 09. at 11:19 PM, ygor said:

Working :

 

DSM 6.1.4-15217 and the package from google cache : 5.1.30

 

download the package

edit 2 files in scripts folder:

installer.sh

vboxdrv.sh

replace: REQUIRED_KERNEL_BUILD="15152" with REQUIRED_KERNEL_BUILD="15217"

 

open path : VirtualBox_x64_5.1.30-118389-1.spk\package.tgz\package.tar\kernel_module\

rename folder: 15152 with 15217

 

all done with 7zip to open spk and edit the files & save, windows 10 guest and linux guests up and running in vbox in DSM 6.1.4 

 

much better performance for windows10 guest in my case on HP N54L

 

Hi Ygor, just tried your method, but didn't work for me.

The only thing what I could find is theat the owner and group is modified from root to nothing if I work in 7zip.

Do you have any idea, or could you share your working/modified package?

Share this post


Link to post
Share on other sites

Hi,

 

when you modify the 2 scripts and rename the folder, you have to uninstall previous release before installing the spk.

 

It doenst work with an upgrade.

 

You have to use 1.02b loader (i don't know for other loader)

 

i'll share in a few using wetransfert the package i saved.

Edited by ygor

Share this post


Link to post
Share on other sites
15 minutes ago, Rabby said:

Hi Ygor, just tried your method, but didn't work for me.

The only thing what I could find is theat the owner and group is modified from root to nothing if I work in 7zip.

Do you have any idea, or could you share your working/modified package?

 

done

Share this post


Link to post
Share on other sites

Thanks, but

  • vbox was never installed, so I cannot remove
  • I use the good loader
  • your package install failed too

virtual machine manager was installed so I've removed it and now trying to install after reboot, fingers crossed.

Share this post


Link to post
Share on other sites

Hi 

thank you for your package but it is not working.

install is done all is correct nginx / soap activated/share is avilable mine is : Virtualbox

see the error message could you help me in this case?

Exception Object
(
    [message:protected] => Could not connect to host (http://127.0.0.1:18083/)
    [string:Exception:private] => 
    [code:protected] => 64
    [file:protected] => /volume1/web/phpvirtualbox/endpoints/lib/vboxconnector.php
    [line:protected] => 220
    [trace:Exception:private] => Array
        (
            [0] => Array
                (
                    [file] => /volume1/web/phpvirtualbox/endpoints/lib/vboxconnector.php
                    [line] => 3147
                    [function] => connect
                    [class] => vboxconnector
                    [type] => ->
                    [args] => Array
                        (
                        )

                )

            [1] => Array
                (
                    [file] => /volume1/web/phpvirtualbox/endpoints/lib/vboxconnector.php
                    [line] => 951
                    [function] => remote_vboxGetGuestOSTypes
                    [class] => vboxconnector
                    [type] => ->
                    [args] => Array
                        (
                            [0] => 
                        )

                )

            [2] => Array
                (
                    [file] => /volume1/web/phpvirtualbox/endpoints/api.php
                    [line] => 316
                    [function] => __call
                    [class] => vboxconnector
                    [type] => ->
                    [args] => Array
                        (
                            [0] => vboxGetGuestOSTypes
                            [1] => Array
                                (
                                    [0] => 
                                    [1] => Array
                                        (
                                            [0] => Array
                                                (
                                                    [data] => Array
                                                        (
                                                            [responseData] => Array
                                                                (
                                                                )

                                                        )

                                                    [errors] => Array
                                                        (
                                                        )

                                                    [persist] => Array
                                                        (
                                                        )

                                                    [messages] => Array
                                                        (
                                                        )

                                                )

                                        )

                                )

                        )

                )

            [3] => Array
                (
                    [file] => /volume1/web/phpvirtualbox/endpoints/api.php
                    [line] => 316
                    [function] => vboxGetGuestOSTypes
                    [class] => vboxconnector
                    [type] => ->
                    [args] => Array
                        (
                            [0] => 
                            [1] => Array
                                (
                                    [0] => Array
                                        (
                                            [data] => Array
                                                (
                                                    [responseData] => Array
                                                        (
                                                        )

                                                )

                                            [errors] => Array
                                                (
                                                )

                                            [persist] => Array
                                                (
                                                )

                                            [messages] => Array
                                                (
                                                )

                                        )

                                )

                        )

                )

        )

    [previous:Exception:private] => 
)


Location:http://127.0.0.1:18083/

 

Share this post


Link to post
Share on other sites

Virtual Maschine Manger is also installed i have to remove them that Virtualbox is working?

Please note my virtualbox folder is on my volume 1 (etx4) virtualmaschine manager has the share virtualcluster on volume2 (btrfs)

thank you for your feedback.

BR

Michael

 

 

Share this post


Link to post
Share on other sites

i don't have that error,

 

can you post ls -l  /volume1/web/phpvirtualbox/endpoints/lib

 

i'm using btrfs also, 

 

 

Share this post


Link to post
Share on other sites

permission looks like this :

 

root@XXXX:~#  ls -l  /volume1/web/phpvirtualbox/endpoints/lib
total 3256
drwxrwsrwx 1 root root     172 Oct 30 09:07 auth
-rwxrwxrwx 1 root root    2910 Feb 22  2017 authinterface.php
-rwxrwxrwx 1 root root    6913 Feb 22  2017 config.php
-rwxrwxrwx 1 root root       0 Feb 22  2017 index.html
-rwxrwxrwx 1 root root    4493 Feb 22  2017 language.php
-rwxrwxrwx 1 root root    2454 Feb 22  2017 utils.php
-rwxrwxrwx 1 root root  162430 Feb 22  2017 vboxconnector.php
-rwxrwxrwx 1 root root  546814 Feb 22  2017 vboxServiceWrappers.php
-rwxrwxrwx 1 root root 2589334 Feb 22  2017 vboxweb-5.1.wsdl
-rwxrwxrwx 1 root root     753 Feb 22  2017 vboxwebService-5.1.wsdl
root@XXXX:~#  ls -l  /volume1/web/phpvirtualbox/endpoints/lib/auth
total 36
-rwxrwxrwx 1 root root 5590 Feb 22  2017 ActiveDirectory.php
-rwxrwxrwx 1 root root 5662 Feb 22  2017 Builtin.php
-rwxrwxrwx 1 root root    0 Feb 22  2017 index.html
-rwxrwxrwx 1 root root 2409 Feb 22  2017 LDAP.php
-rwxrwxrwx 1 root root 7257 Feb 22  2017 MySQL.php
-rwxrwxrwx 1 root root 2849 Feb 22  2017 OpenMediaVault.php
-rwxrwxrwx 1 root root 1411 Feb 22  2017 WebAuth.php
 

Share this post


Link to post
Share on other sites

admin@DSM3615XS:/$ ls -l  /volume1/web/phpvirtualbox/endpoints/lib
total 3260
drwxrwsrwx 2 root root    4096 Oct 30 09:07 auth
-rwxrwxrwx 1 root root    2910 Feb 22  2017 authinterface.php
-rwxrwxrwx 1 root root    6913 Feb 22  2017 config.php
-rwxrwxrwx 1 root root       0 Feb 22  2017 index.html
-rwxrwxrwx 1 root root    4493 Feb 22  2017 language.php
-rwxrwxrwx 1 root root    2454 Feb 22  2017 utils.php
-rwxrwxrwx 1 root root  162430 Feb 22  2017 vboxconnector.php
-rwxrwxrwx 1 root root  546814 Feb 22  2017 vboxServiceWrappers.php
-rwxrwxrwx 1 root root 2589334 Feb 22  2017 vboxweb-5.1.wsdl
-rwxrwxrwx 1 root root     753 Feb 22  2017 vboxwebService-5.1.wsdl

admin@DSM3615XS:/$ ls -l  /volume1/web/phpvirtualbox/endpoints/lib/auth
total 36
-rwxrwxrwx 1 root root 5590 Feb 22  2017 ActiveDirectory.php
-rwxrwxrwx 1 root root 5662 Feb 22  2017 Builtin.php
-rwxrwxrwx 1 root root    0 Feb 22  2017 index.html
-rwxrwxrwx 1 root root 2409 Feb 22  2017 LDAP.php
-rwxrwxrwx 1 root root 7257 Feb 22  2017 MySQL.php
-rwxrwxrwx 1 root root 2849 Feb 22  2017 OpenMediaVault.php
-rwxrwxrwx 1 root root 1411 Feb 22  2017 WebAuth.php
admin@DSM3615XS:/$
 

mine is this


 

Edited by nemesis122

Share this post


Link to post
Share on other sites

Also,

 

when installing i remember there is a message asking to use admin account, (and configure web service to use php5.6 in the settings , then add soap extension, if i remember well)

 

i did this:  enable admin account on synology (disabled by default)

set a password to admin of the synology (strong password )

 

 

 

 

when installing the spk, i use admin and the password. 

 

 

you can also type in the synology in ssh:

 

root@XXXX:~# netstat -an | grep 18083
tcp        0      0 127.0.0.1:18083         0.0.0.0:*               LISTEN

 

when vbox is installed and working, should return nothing with virtualbox not installed or not started.

 

 

If you did not enabled admin account, try activate it before installing the spk

 

 

 

 

Share this post


Link to post
Share on other sites

to access root in  synology you have to connect with putty with your username and password (service ssh activated)

 

then sudo -i and type your user password, you should have root@xxxx# 

Share this post


Link to post
Share on other sites

see here the differents to your privilges

mine

drwxrwsrwx 2 root root    4096 Oct 30 09:07 auth

yours

drwxrwsrwx 1 root root     172 Oct 30 09:07 auth

what this means ??

thank you

 

Share this post


Link to post
Share on other sites

looks ok, auth is just a folder.

 

the problem in the message show an error connecting to the vbox service. phpvirtualbox can't find the port 18083, or 18083 is used by another app ?

 

i don't know why i dont have the problem.

 

i'll try to uninstall and reinstall the spk in the evening

Share this post


Link to post
Share on other sites

Hi Ygor

admin account is active 

webstaion is installed with soap extension php 5.6 is installed all is fine.

realy i dont know what the problem is but on my ssh with this command 

root user is now active nothing changed 

on this port no other app is running 18083

netstat -an | grep 18083 

there is no message this is fine?

but i have installed virtual maschine manager from synology maybe this is the problem ?

is there a log files where i can understood why it is not working ?

thank you

Michael

 

 

Edited by nemesis122

Share this post


Link to post
Share on other sites

i could reproduce the issue by uninstall / reinstall

 

-> install the package and don't select run after install -> reboot synology -> go to package center start the app

 

-> then click on the vbox icon in the menu, no more errors

 

when start is good, the shell output looks like this:

:~$ netstat -an | grep 18083
tcp        0      0 127.0.0.1:18083         0.0.0.0:*               LISTEN
 

 

and  lsmod return the kernel modules loaded: (these are not loaded if you run without reboot, that looks like to be the issue)

 

the error come from phpvirtualbox wich is not related to virtualbox (maybe an insmod command missing to load the driver without reboot ?)

 

:~$ lsmod | grep box
vboxpci                15225  0
vboxnetadp             18580  0
vboxnetflt             17736  0
vboxdrv               373485  3 vboxnetadp,vboxnetflt,vboxpci

 

 

then all good for my box (dsm 3615xs, 3617 may have different kernel or architecture).
 

if you still have an issue you can try edit vbox 5.0.40 spk and see if this error persist (and if the command outpout are the same)

 

 

the kernel i have with dsm 6.1.4 U1 : 

:~$ uname -a
Linux XXXX 3.10.102 #15217 SMP Fri Nov 3 04:39:47 CST 2017 x86_64 GNU/Linux synology_bromolow_3615xs
 

 

Edited by ygor

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.