Virtualbox and phpVirtualbox on XPEnology


Recommended Posts

I am very very much hoping that it will be working again soon! I really love Xpenology so far and was thrilled that it existed after i outgrew my real Synology so that i could build the box i needed to match my requirements!

 

The only thing that is missing is VirtualBox!

 

I shall wait excitedly! :smile:

Link to post
Share on other sites

It does work if you can downgrade xpenoboot to the previous version. After updating dsm to 5.2 I flashed xpenoboot back to 5.2-5592.2. Everything has been fine for the past month or so, but it definitely doesn't work on every setup, so I can't say it's a guaranteed fix.

 

Once we get a fixed xpenoboot then it should work again.

Link to post
Share on other sites

should it work with 5.2 5664-3?

:cry:

I get:

 

Exception Object
(
   [message:protected] => The virtual machine 'MT' has terminated unexpectedly during startup because of signal 11
   [string:Exception:private] => 
   [code:protected] => 0
   [file:protected] => /volume1/web/phpvirtualbox/endpoints/lib/vboxconnector.php
   [line:protected] => 2429
   [trace:Exception:private] => Array
       (
           [0] => Array
               (
                   [file] => /volume1/web/phpvirtualbox/endpoints/lib/vboxconnector.php
                   [line] => 951
                   [function] => remote_progressGet
                   [class] => vboxconnector
                   [type] => ->
                   [args] => Array
                       (
                           [0] => Array
                               (
                                   [progress] => 61154f6ca71d42a7-0000000000000004
                               )

                       )

               )

           [1] => Array
               (
                   [file] => /volume1/web/phpvirtualbox/endpoints/api.php
                   [line] => 316
                   [function] => __call
                   [class] => vboxconnector
                   [type] => ->
                   [args] => Array
                       (
                           [0] => progressGet
                           [1] => Array
                               (
                                   [0] => Array
                                       (
                                           [progress] => 61154f6ca71d42a7-0000000000000004
                                       )

                                   [1] => Array
                                       (
                                           [0] => Array
                                               (
                                                   [data] => Array
                                                       (
                                                           [responseData] => Array
                                                               (
                                                                   [progress] => 61154f6ca71d42a7-0000000000000004
                                                                   [info] => Array
                                                                       (
                                                                           [completed] => 1
                                                                           [canceled] => 
                                                                           [description] => Starting VM
                                                                           [operationDescription] => Creating process for virtual machine "MT" (headless)
                                                                           [timeRemaining] => Array
                                                                               (
                                                                               )

                                                                           [timeElapsed] => Array
                                                                               (
                                                                                   [days] => 16846
                                                                                   [hours] => 21
                                                                                   [minutes] => 11
                                                                                   [seconds] => 41
                                                                               )

                                                                           [percent] => 0
                                                                       )

                                                               )

                                                           [success] => 1
                                                           [key] => 53474945cfd7ac0bf8114767c209c2a6
                                                       )

                                                   [errors] => Array
                                                       (
                                                       )

                                                   [persist] => Array
                                                       (
                                                       )

                                                   [messages] => Array
                                                       (
                                                       )

                                               )

                                       )

                               )

                       )

               )

           [2] => Array
               (
                   [file] => /volume1/web/phpvirtualbox/endpoints/api.php
                   [line] => 316
                   [function] => progressGet
                   [class] => vboxconnector
                   [type] => ->
                   [args] => Array
                       (
                           [0] => Array
                               (
                                   [progress] => 61154f6ca71d42a7-0000000000000004
                               )

                           [1] => Array
                               (
                                   [0] => Array
                                       (
                                           [data] => Array
                                               (
                                                   [responseData] => Array
                                                       (
                                                           [progress] => 61154f6ca71d42a7-0000000000000004
                                                           [info] => Array
                                                               (
                                                                   [completed] => 1
                                                                   [canceled] => 
                                                                   [description] => Starting VM
                                                                   [operationDescription] => Creating process for virtual machine "MT" (headless)
                                                                   [timeRemaining] => Array
                                                                       (
                                                                       )

                                                                   [timeElapsed] => Array
                                                                       (
                                                                           [days] => 16846
                                                                           [hours] => 21
                                                                           [minutes] => 11
                                                                           [seconds] => 41
                                                                       )

                                                                   [percent] => 0
                                                               )

                                                       )

                                                   [success] => 1
                                                   [key] => 53474945cfd7ac0bf8114767c209c2a6
                                               )

                                           [errors] => Array
                                               (
                                               )

                                           [persist] => Array
                                               (
                                               )

                                           [messages] => Array
                                               (
                                               )

                                       )

                               )

                       )

               )

       )

   [previous:Exception:private] => 
)

Link to post
Share on other sites

[EDIT: FIXED. I screwed up the .5 usb upgrade. Working now!! Now I can RIP DVDs directly!! wooo!!]

 

I just discovered this spk.. been looking for something like this for like... ever! great! what is the trick?

I'm on 4644.5 and the latest(?) version of seba/dodo-dk/DI4bI0 VB install 5.0.14-105127-3

 

Because I'm lazy, I downloaded the preconfigured VM from Microsoft for win10 Edge testing. after importing it, i get a Signal 11 error. This seems to be common in this thread. I've never found a post that tells what it is or what the fix is if there is one.

 

P.S. I've also tried installing win10x64 on its own in a new container via ISO. Same result.

 

Am I missing something in the config? or?

Edited by Guest
Link to post
Share on other sites

Hi,

 

I have Xpenology DSM 5.2 running on HP Microserver N36L with XPEnoboot 5.2-5544.5, on it i have installed phpvirtual box (VirtualBox_x64_5.0.14-105127-3.spk).

My problem is that VMachines with network interface configuration as bridged don't see local LAN. They don't get IP from DHCP, when I switch to NAT everything works fine, but some machines must operate in bridge mode.

 

Can somebody guide me throught this problem?

Link to post
Share on other sites

Hello all

 

First i must said big thanks to xpenology and phpvirtualbox creators. Very good work. :grin:

 

Second, sorry for bad english i'm french. :-|

 

Three : Question :

 

I haved a virtual image of windows 7 in virtualbox on my xpenology core i5 32GB asrock.

All work good but i want install bluestack + a bot for clash of clan on my windows 7 VM.

The problem is i can't install bluestack or use others android emulator because i can't activate 3d acceleration in phpvirtualbox.

Droid4x and MEmu same result , "your graphic card need to be updated".

Guest addition are installed in the windows 7 VM.

 

I think it's because the host don't have openGL and 3d support, because no drivers are installed on the host who are an xpenology.

 

I haved try to enable 3d with virtualbox commandline with SSH with putty and i have this error ? :

DiskStation2> /opt/VirtualBox/VBoxManage modifyvm "Windows 7 Sp1 x64" accelerate

3d on

VBoxManage: error: Failed to initialize COM! (hrc=NS_ERROR_FAILURE)

 

if i load VM on another PC with virtualbox on it and i check accelerate 3d and then reload the vm with phpvirtualbox the accelerate 3d is checked but i can't launch the VM i have this message :

 

"This VM was configured to use 3D acceleration. However, the 3D support of the host is not working properly and the VM cannot be started. To fix this problem, either fix the host 3D support (update the host graphics driver?) or disable 3D acceleration in the VM settings (VERR_NOT_AVAILABLE)"

 

How can i do this ?

 

Can i install a driver for my graphic card on my xpenology ? with a linux driver perhaps because xpenology kernel is a 3.0.15 ?

Or i need to compil a new kernel with graphic card driver for wpenology ? so i must ask for this here if creator can add the driver because i don't know this very well ?

I haved seen many post for asked driver add but there is only network or storage, this is logic for a nas perhaps, but now with virtualization on a nas we must have graphic driver too, no ? !!!

 

This is frustrating because all work good but without graphic card driver on host system, virtualbox was restricted in his use.

 

I have seen tutorial for installing androidx86 in virtualbox for play clash of clan but my goal is to put a bluestack + bot install in a VM and not only play clash of clan in a VM.

 

Thanks for your reply :wink:

Edited by Guest
Link to post
Share on other sites
Hi,

 

I have Xpenology DSM 5.2 running on HP Microserver N36L with XPEnoboot 5.2-5544.5, on it i have installed phpvirtual box (VirtualBox_x64_5.0.14-105127-3.spk).

My problem is that VMachines with network interface configuration as bridged don't see local LAN. They don't get IP from DHCP, when I switch to NAT everything works fine, but some machines must operate in bridge mode.

 

Can somebody guide me throught this problem?

 

 

I got the same problem here, have try to reinstall a new windows but problem still there.

 

To be exact since last update bridge mode not working after a fews seconds/minutes after a boot.

Link to post
Share on other sites

Same problem here (N36, CM5709c integrated Broadcom NIC).

Maybe broken Broadcom driver in Xpenoboot release => .4?

 

"5.2-5644.4 (23/12/2015)

!!! Possible iSCSI issues with this build !!!

Fix latest 5644 pat issue

Fix broadcom issues (add missing firmwares)"

 

And, too many dropped packets in this release :sad:

 

HP> ifconfig
eth0      Link encap:Ethernet  HWaddr 00:11:32:36:A1:53
         inet addr:10.0.0.10  Bcast:10.0.0.255  Mask:255.255.255.0
         inet6 addr: fe80::211:32ff:fee6:a759/64 Scope:Link
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:443093 errors:0 dropped:540 overruns:0 frame:0

Link to post
Share on other sites
Bridge works if only 1 VM is booted, more than 1 all VMs are non-responsive on the network is what I am seeing.

 

Indeed, the same case here. Booting second VM in bridge mode making Vbox unresponsive. Cannot kill the process, cannot unload kernel module. Only hard restart is helping.

Link to post
Share on other sites

Same problem here.

 

I have 2 VM, 1 windows 7 and 1 unbuntu, in bridged mode with different ports for each VM.

If i launch a second VM when the first is running phpvirtualbox stop responding, the VM stop at 20% and after, same if i try to stop the packet virtualbox not responding and same if i try to shutdown the xpenology server not responding.

Only hard shutdown work after this.

 

:roll:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.