seba

Virtualbox and phpVirtualbox on XPEnology

Recommended Posts

any updates ? I would install dsm 5.1 but until phpVirtualBox not ' working on new dsm not perform ugrade !!

Thanks Seba expect more news

Share this post


Link to post
Share on other sites

Hi everyone !

 

First, let's thank Seba for this awesooome work.

 

Next, let's talk about... issues :sad:

This package seems broken on DSM 5.1 environment,

it's probably because the kernel module isn't compatible with the machine's Linux Kernel.

 

Seba (... stien ? are you french ? :grin:), are you still working on this package ?

Perhaps you could post the package creation process so the community could help you ?

 

Thanks in advance,

take care !

 

Trublion

Share this post


Link to post
Share on other sites

Hi,

To help troubleshoot problems here are few tips:

 

Virtualbox should create log file at following location /var/log/vbox.log.

 

From ssh try this do start drivers

/var/packages/virtualbox/target/scripts/vboxdrv.sh start

of this goes without error then

/var/packages/virtualbox/target/scripts/vboxinit.sh start

and finally if vboxinit was without errors

/var/packages/virtualbox/target/scripts/vboxweb-service.sh start

 

I've added this to first post as well for reference. Since I won't get my mb anytime soon from repair, you are welcome to try and fix package. Basically you need to setup crosscompile environment for info use Synology guide at their website. Source for vbox driver you can find in "All distributions" package at virtualbox download page (use AMD64).

Share this post


Link to post
Share on other sites

Hi seba, thank you for your help.

Have you a donation link?

 

I tested the postet commands with no error.

Serverdrive2> /var/packages/virtualbox/target/scripts/vboxdrv.sh start
Starting VirtualBox kernel modules ...done.
Serverdrive2> /var/packages/virtualbox/target/scripts/vboxinit.sh start
Serverdrive2> /var/packages/virtualbox/target/scripts/vboxweb-service.sh start
Serverdrive2> 

 

Then i startet the Virtual Machine in the phpVirtualBox. Error comes "The virtual machine 'WinXP' has terminated unexpectedly during startup with exit code 1"

 

In the /var/log/vbox.log file:

[spoiler=]

VirtualBox web service 4.3.12 r93733 linux.amd64 (May 16 2014 15:15:59) release log
00:00:00.005302 main     Log opened 2015-02-08T12:49:03.084424000Z
00:00:00.005309 main     Build Type: release
00:00:00.005316 main     OS Product: Linux
00:00:00.005321 main     OS Release: 3.2.40
00:00:00.005326 main     OS Version: #7 SMP Thu Jan 29 14:30:34 CST 2015
00:00:00.005402 main     DMI Product Name: Synoden
00:00:00.005439 main     DMI Product Version: -1
00:00:00.005693 main     Host RAM: 1998MB total, 1691MB available
00:00:00.005708 main     Executable: /opt/VirtualBox/vboxwebsrv
00:00:00.005711 main     Process ID: 17241
00:00:00.005714 main     Package type: LINUX_64BITS_GENERIC
00:00:00.030683 SQPmp    Socket connection successful: host = 127.0.0.1, port = 18083, master socket = 9
00:00:06.702704 SQPmp    Request 1 on socket 10 queued for processing (1 items on Q)
00:00:06.703100 SQW01    New SOAP thread started
00:00:06.703215 SQW01    Processing connection from IP=127.0.0.1 socket=10 (0 out of 1 threads idle)
00:00:06.714936 SQPmp    Request 2 on socket 11 queued for processing (1 items on Q)
00:00:06.715432 SQPmp    Request 3 on socket 13 queued for processing (2 items on Q)
00:00:06.715703 SQW02    New SOAP thread started
00:00:06.715785 SQW02    Processing connection from IP=127.0.0.1 socket=11 (0 out of 2 threads idle)
00:00:06.741628 SQW01    Processing connection from IP=127.0.0.1 socket=13 (0 out of 2 threads idle)
00:00:06.753128 SQPmp    Request 4 on socket 14 queued for processing (1 items on Q)
00:00:06.754395 SQW03    New SOAP thread started
00:00:06.756993 SQW03    Processing connection from IP=127.0.0.1 socket=14 (0 out of 3 threads idle)
00:00:06.845763 SQPmp    Request 5 on socket 10 queued for processing (1 items on Q)
00:00:06.845885 SQW02    Processing connection from IP=127.0.0.1 socket=10 (0 out of 3 threads idle)
00:00:06.989657 SQPmp    Request 6 on socket 11 queued for processing (1 items on Q)
00:00:06.989771 SQW02    Processing connection from IP=127.0.0.1 socket=11 (0 out of 3 threads idle)
00:00:07.453663 SQPmp    Request 7 on socket 10 queued for processing (1 items on Q)
00:00:07.453742 SQW03    Processing connection from IP=127.0.0.1 socket=10 (1 out of 3 threads idle)
00:00:08.215297 SQPmp    Request 8 on socket 11 queued for processing (1 items on Q)
00:00:08.215407 SQW02    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)
00:00:08.237700 SQPmp    Request 9 on socket 10 queued for processing (1 items on Q)
00:00:08.237785 SQW03    Processing connection from IP=127.0.0.1 socket=10 (2 out of 3 threads idle)
00:00:08.278853 SQPmp    Request 10 on socket 11 queued for processing (1 items on Q)
00:00:08.278955 SQW02    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)
00:00:08.309959 SQPmp    Request 11 on socket 10 queued for processing (1 items on Q)
00:00:08.310060 SQW01    Processing connection from IP=127.0.0.1 socket=10 (2 out of 3 threads idle)
00:00:09.881433 SQPmp    Request 12 on socket 11 queued for processing (1 items on Q)
00:00:09.881553 SQW03    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)
00:00:10.041978 SQPmp    Request 13 on socket 10 queued for processing (1 items on Q)
00:00:10.042074 SQW02    Processing connection from IP=127.0.0.1 socket=10 (2 out of 3 threads idle)
00:00:11.320362 SQPmp    Request 14 on socket 11 queued for processing (1 items on Q)
00:00:11.320675 SQW01    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)
00:00:14.319348 SQPmp    Request 15 on socket 10 queued for processing (1 items on Q)
00:00:14.319448 SQW01    Processing connection from IP=127.0.0.1 socket=10 (2 out of 3 threads idle)
00:00:15.271024 SQPmp    Request 16 on socket 11 queued for processing (1 items on Q)
00:00:15.271123 SQW02    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)
00:00:15.292925 SQW02    API method name:            IProgress::COMGETTER(ErrorInfo)
00:00:15.293031 SQW02    API return code:            0x80004005 (NS_ERROR_FAILURE)
00:00:15.293099 SQW02    COM error info result code: 0x80004005 (NS_ERROR_FAILURE)
00:00:15.293135 SQW02    COM error info text:        Error info is not available, operation is still in progress
00:00:15.319944 SQPmp    Request 17 on socket 10 queued for processing (1 items on Q)
00:00:15.320054 SQW03    Processing connection from IP=127.0.0.1 socket=10 (2 out of 3 threads idle)
00:00:17.319580 SQPmp    Request 18 on socket 11 queued for processing (1 items on Q)
00:00:17.319684 SQW01    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)            
00:00:17.357205 SQPmp    Request 19 on socket 10 queued for processing (1 items on Q)                           
00:00:17.357295 SQW02    Processing connection from IP=127.0.0.1 socket=10 (2 out of 3 threads idle)            
00:00:17.377446 SQPmp    Request 20 on socket 11 queued for processing (1 items on Q)                           
00:00:17.377561 SQW01    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)            
00:00:21.135321 SQPmp    Request 21 on socket 10 queued for processing (1 items on Q)                           
00:00:21.135424 SQW03    Processing connection from IP=127.0.0.1 socket=10 (2 out of 3 threads idle)
00:00:25.134649 SQPmp    Request 22 on socket 11 queued for processing (1 items on Q)               
00:00:25.134750 SQW02    Processing connection from IP=127.0.0.1 socket=11 (2 out of 3 threads idle)
- vbox.log 64/64 100%

 

 

Thank you very much.

 

Dodo

 

Edit: If i start it manual:

Serverdrive2> ./usr/local/virtualbox/opt/VirtualBox/VBoxManage startvm WinXP --type headless
Waiting for VM "WinXP" to power on...
VBoxManage: error: The virtual machine 'WinXP' has terminated unexpectedly during startup with exit code 1
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component Machine, interface IMachine
Serverdrive2> 

Share this post


Link to post
Share on other sites

Same here.

 

You can try this on your NAS, it may help you :

 

/var/packages/virtualbox/target/scripts/vboxdrv.sh start (-> supposed to say "done")

/var/packages/virtualbox/target/scripts/vboxdrv.sh status (-> "started" or something like that)

/var/packages/virtualbox/target/scripts/vboxdrv.sh stop (-> failed !)

 

 

And if you call VBoxHeadless binary, it will display an error message saying that the Kernel module isn't available.

 

Perhaps you should recompile Vbox with the newest toolchains ?

(tried on DS415+... so with an x86_64 Atom Avoton CPU)

Share this post


Link to post
Share on other sites

Hi all,

 

Same problem here sinds i have upgraded my DS713 to DSM 5.1

 

The virtual machine 'linuxtest' has terminated unexpectedly during startup with exit code 1

 

for me unable to solve this problem, could Seba please have a look in to this. Espacialy for Virtual box i have upgrade by DS713 from 1GB RAM to 4GB RAM. it would be very nice to get it working again.

so please Saba could you solve the issue. It would be appriciated very much!

 

Kind Regards MMarc

Share this post


Link to post
Share on other sites

I have Compiled the linux-header and linux-Image (5.1 Toolchain and Source).

Installed it under 5.1 Debian CHRoot and then i Installed the Virtualbox.

I have Setup Virtualbox with "vboxdrv Setup"...

 

No errors, then i have replaced the Original Seba VirtualBox Folder and the Kernel Files under /lib/modules/3.2.40/

but it don't work.

 

Same problem.

 

Serverdrive2> ./VBoxHeadless                                                                 
VBoxHeadless: Error -1908 in suplibOsInit!
VBoxHeadless: Kernel driver not installed

VBoxHeadless: Tip! Make sure the kernel module is loaded. It may also help to reinstall Virt
ualBox.
Serverdrive2> 

 

I don't have the know how, the full Weekend wasted..:smile:.

Share this post


Link to post
Share on other sites

Hi, i have make some mistakes.

Today i have a little bit success with compiling...

 

I have make the new VirtualBox Kernels and it works on my System.

Someone want to test?

 

I can't Upload anything here, so send me a PN with your mail...

 

Dodo

Share this post


Link to post
Share on other sites
Hi, i have make some mistakes.

Today i have a little bit success with compiling...

 

I have make the new VirtualBox Kernels and it works on my System.

Someone want to test?

 

I can't Upload anything here, so send me a PN with your mail...

 

Dodo

 

PM sent.

Share this post


Link to post
Share on other sites
Hi, i have make some mistakes.

Today i have a little bit success with compiling...

 

I have make the new VirtualBox Kernels and it works on my System.

Someone want to test?

 

I can't Upload anything here, so send me a PN with your mail...

 

Dodo

 

just tested it, and it works !!!

 

thank you very much

 

tested it on DSM 5.1 update 2 HP N54L

Share this post


Link to post
Share on other sites

@rthga81

Email send

 

@all

I have a Virtual Windows XP with Bridged Network, but the Windows don't become a IP from Router. Static IP works, but very very slow to connect. Somebody any idea?

Share this post


Link to post
Share on other sites

Yup after replacing the files it worked! If Seb don't mind I can recreate the SPK file... I will have this posted on the blog in a bit with download links too. Unless you guys want to do this another way - totally up to you!

 

thanks so much for your help!

Share this post


Link to post
Share on other sites

Here is a link Guys. Seba I left your name on it for the credit. I just updated the files and repackaged. If you want this removed just leave a message or email and I will remove ASAP.

 

This package will now work with DSM 5.1 on Synology DS 1513+ and DS1515+ tested on both systems. Enjoy

 

Thanks guys

 

i will be back with an update link.

Edited by Guest

Share this post


Link to post
Share on other sites

@all

I have a Virtual Windows XP with Bridged Network, but the Windows don't become a IP from Router. Static IP works, but very very slow to connect. Somebody any idea?

 

Turn off Windows Firewall; Once I turned windows firewall off and made sure I was not bridging to a bonded connection the DHCP router picked up the Windows Machine and I had no problems since logging in or out.

Share this post


Link to post
Share on other sites

I turned it off but don't help.

Same Problem with a Virtual Debian.

 

Under OpenMediaVault with VirtualBox it works.

Share this post


Link to post
Share on other sites

So is it working or not? or are there just some limitations and which ones?

I don't want to take any risk as I am using one virtual machine in production.

Thank you for your work and dedication!

Share this post


Link to post
Share on other sites

I have last xpenoboot with latest os, but after install last virtualbox spk, this pakage doesnt start((

How i can view logs for this package??

 

p.s Contributor, please fix version of virtualbox in packet from 4.3 to 4.5. After installation we can see 4.3 v in packages center.

 

thanks 4 u work.

Share this post


Link to post
Share on other sites

I successfully installed the original .SPK file and manually updated the four files provided earlier (before the re-packaging). This is on 5.1-5022-update 2.

 

I also tried the re-packaged .SPK file - on a DS1512+, VM running on an i7 and whitebox hardware. The new .SPK file will install successfully, but will never 'run'. I haven't had a chance to dig through the log files, but I suspect that there is an issue with the re-package. I tested on both 5.0-4482 and 5.1-5022-update 2.

Share this post


Link to post
Share on other sites

I am not able to figure out how to repackage the file and make it work. I replace the .ko files in the package than repackage the tgz. Recreate the SPK and it installs but will not start. It seems that it is grabbing information from another location.

 

I can replace the .ko files with the new kernels though that were provided and it works perfectly fine. /shrug. I will break apart all the files tonight and try to figure it out.

 

Also, i put together a fast blog to explain how to copy files over using SCP - It's a pain.

 

http://rysnas.com/wordpress/

 

Seba could you be of help with this sir?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now