seba

Virtualbox and phpVirtualbox on XPEnology

Recommended Posts

1 hour ago, nemesis122 said:

virtual manager deinstalled also is not working :-(

 

i could reproduce same error (but it is a generic error from php GUI, [not related to oracle virtualbox  server], it just means vboxSRV is not started -> so no port 18083 listenning)

 

check the previous post and try

Edited by ygor

Share this post


Link to post
Share on other sites

done with reboot and not exute after the installtion:

my information looks like this

login as: admin
admin@192.168.0.51's password:
Could not chdir to home directory /var/services/homes/admin: No such file or directory
admin@DSM3615XS:/$ :~$ netstat -an | grep 18083
admin@DSM3615XS:/$ netstat -an | grep 18083
admin@DSM3615XS:/$ lsmod | grep box
vboxpci                15225  0
vboxnetadp             18580  0
vboxnetflt             17736  0
vboxdrv               373485  3 vboxnetadp,vboxnetflt,vboxpci
megaraid_mbox          27683  0
megaraid_mm             7552  1 megaraid_mbox
admin@DSM3615XS:/$ uname -a
Linux DSM3615XS 3.10.102 #15217 SMP Fri Nov 3 04:39:47 CST 2017 x86_64 GNU/Linux synology_bromolow_3615xs
admin@DSM3615XS:/$
 

Share this post


Link to post
Share on other sites

OK, so on my side the issue is solved, the modifed package is working fine!

I don't know if every step was necessary or not, but

  • I've activated admin user,
  • changed apache to nginx and added soap to php in webstation
  • created a folder for VMs under my users home (after install I've changed the path also in config).

So basically I've did everything what is described in the installation steps of the package.

Thanks for your help!!!

Share this post


Link to post
Share on other sites
1 hour ago, nemesis122 said:

done with reboot and not exute after the installtion:

my information looks like this

login as: admin
admin@192.168.0.51's password:
Could not chdir to home directory /var/services/homes/admin: No such file or directory
admin@DSM3615XS:/$ :~$ netstat -an | grep 18083
admin@DSM3615XS:/$ netstat -an | grep 18083
admin@DSM3615XS:/$ lsmod | grep box
vboxpci                15225  0
vboxnetadp             18580  0
vboxnetflt             17736  0
vboxdrv               373485  3 vboxnetadp,vboxnetflt,vboxpci
megaraid_mbox          27683  0
megaraid_mm             7552  1 megaraid_mbox
admin@DSM3615XS:/$ uname -a
Linux DSM3615XS 3.10.102 #15217 SMP Fri Nov 3 04:39:47 CST 2017 x86_64 GNU/Linux synology_bromolow_3615xs
admin@DSM3615XS:/$
 

Do an uninstall reboot check that web station is well configured, install the SPK, and unselect run after install, reboot and run the package. Be sure to have loader 1.02b . Your setup should work. 

Edited by ygor

Share this post


Link to post
Share on other sites

Hi ygor

I have done complete reset from the maschine create a new USB stick to sure it is 1.02b 

created the storage JBOD with 4 hardisk as etx 4 

installed webstation /install php 5.6 check the box SOAP 

create the virtualbox share 

install virtualbox not run after the installtion 

reboot run virtualbox and it is not working.

:-( 

i can reset again and prepare a fresh installtion and when you have time we can do a teamviewer sessions ?

 

Share this post


Link to post
Share on other sites

what this means 

I've activated admin user,

the user is activated  by default??????????????????????????????????????????????????????????

Share this post


Link to post
Share on other sites
1 hour ago, nemesis122 said:

what this means 

I've activated admin user,

the user is activated  by default??????????????????????????????????????????????????????????

admin user is disabled by default in synology

 

you have to go in the user panel and enable admin then set a strong password for this account.

 

as posted in topic:

 

Virtualbox should create log file at following location /var/log/vbox.log.

If you need to troubleshoot vbox from ssh try this to start drivers:
-> /var/packages/virtualbox/target/scripts/vboxdrv.sh start (check kernel driver are loaded: lsmod | grep vbox)
if this goes without error then:
-> /var/packages/virtualbox/target/scripts/vboxinit.sh start
and finally if vboxinit was without errors:
-> /var/packages/virtualbox/target/scripts/vboxweb-service.sh start -> this is the software listening to port 18083 (check vboxwebservice is listenning: netstat -an | grep 18083)

 

 

 

Share this post


Link to post
Share on other sites

 

Hi Ygor

the admin user is activated as it was before because by the installtion the user where is given is : admin (given by me by a fresh install.)

Virtualbox should create log file at following location /var/log/vbox.log.

--> Permission denied to view this file ?

-> /var/packages/virtualbox/target/scripts/vboxdrv.sh start 

--> no such file or directory

do you have time for a teamviewer session i have it all prepared and notet the admin password to a word document maybe you see the dumb things what i have done :-)???

Fresh installtion is ready jbod created and webstation installed with php 5.6 and soap bockj checked

 

Edited by nemesis122

Share this post


Link to post
Share on other sites

your setup looks good, 

the error you have, i canno't reproduce, kernel modules are loaded with success.

 

Maybe related to vbox5.1.30, change the package 5.0.40 and try it on dsm 6.1.4 it may help

 

vbox5.1.30 was probably removed for a reason from http://spk.diablos-netzwerk.de/

 

but it work well on my AMD 

 

 

Share this post


Link to post
Share on other sites

can not install VirtualBox_x64_5.1.30-118389-1 &     VirtualBox_x64_5.0.40-115130-1_6.1.4

my device is ds218+   DSM version is 6.14-15217 update 1          

fatal error like this:   install [virtualbox] faild 

your kernel 4.4.15+ is not supported by this package!

 

what can i do??help!!

 

Share this post


Link to post
Share on other sites
4 hours ago, mandolin said:

can not install VirtualBox_x64_5.1.30-118389-1 &     VirtualBox_x64_5.0.40-115130-1_6.1.4

my device is ds218+   DSM version is 6.14-15217 update 1          

fatal error like this:   install [virtualbox] faild 

your kernel 4.4.15+ is not supported by this package!

 

what can i do??help!!

 

 

Sorry mandolin but my kernel version is the following:

Linux NAS 3.10.102 #15217 SMP Fri Nov 10 20:08:59 CST 2017 x86_64 GNU/Linux synology_bromolow_3615xs

 

 

Maybe it's possible to change the REQUIRED_KERNEL_VERSION="3.10.102" to your kernel, but it's your responsability, I don't know what can happens.

Edited by jarugut

Share this post


Link to post
Share on other sites
5 hours ago, jarugut said:

thx a lot, i try another method...

 

 

Sorry mandolin but my kernel version is the following:

Linux NAS 3.10.102 #15217 SMP Fri Nov 10 20:08:59 CST 2017 x86_64 GNU/Linux synology_bromolow_3615xs

 

 

Maybe it's possible to change the REQUIRED_KERNEL_VERSION="3.10.102" to your kernel, but it's your responsability, I don't know what can happens.

 

Share this post


Link to post
Share on other sites

in ssh if you type #uname -a

 

and have linux kernel 4.4.* it won't work with virtualbox package

 

dsm 6.1.x use kernel 3.10.102

 

kernel 4.4.* is for dsm beta 6.2.x

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now