seba

Virtualbox and phpVirtualbox on XPEnology

Recommended Posts

First of all I'd like to thank trantor, gnuboot and nanoboot for their work on making xpenology available and of course to Synology for making this great OS.

 

Second, just one thing was missing on my new xpenology box and that was virtualization software. So I decided to run Virtualbox on it and use phpVirtualbox as frontend. After some work (and a bit of learning, I'm new in xpenology :smile: ) I managed to create spk package.

 

So this is what I put together:

  1. Virtualbox 4.3.12-93733
  2. phpVirtualbox 4.3-1

these two are combined into one spk file for easy installation. Keep in mind I only used nanoboot's image so I don't know if it will work with others. Drivers are compiled with 3.2.40 kernel. If you wish to try it this is what you need.

 

Requirements:

  1. Only bromolow arch is supported
  2. VT-x needs to be enabled in bios and CPU has to be x64
  3. Web service (apache-web) needs to be enabled and path /phpvirtualbox/ available
  4. Min version of DSM is 5.0-4418 (DSM 5.1 unsupported at the moment)

 

Notes:

  • Standard disclaimer goes here :smile:, this means you are using this package at your own risk,
  • You can, and I suggest you do, try spk on nanoboot installed in VMWare player.
  • phpVirtualbox needs to know password of user under which vbox is running, Virtualbox runs under root/admin user so you need to supply
    password during install.
  • Proper solution is to run vbox under separate account but for that I need to find more time to learn how to do that in/from spk file.
  • Virtualbox should create log file at following location /var/log/vbox.log.
  • If you need to troubleshoot vbox from ssh try this do start drivers:
    /var/packages/virtualbox/target/scripts/vboxdrv.sh start
    if this goes without error then:
    /var/packages/virtualbox/target/scripts/vboxinit.sh start
    and finally if vboxinit was without errors:
    /var/packages/virtualbox/target/scripts/vboxweb-service.sh start

During install you have some options you can set:

  1. You can disable phpVirtualbox authentication, if enabled user/pass is admin/admin
  2. Enable advanced configuration items
  3. Enable startup/shutdown configuration
  4. What to do with guest VM on host shutdown

 

Use this package at your own risk.

Download link (92 MB):

https://mega.co.nz/#!lk0DnKyT!AhQ73eNA_1uiPRSQRWYosZ0BP7SgOkp24F6B5SDIAF0

Edited by Guest

Share this post


Link to post
Share on other sites

oh my goodness! This is exactly what i'm looking for.

 

Seba, what hardware have you tested this with? Bare metal install or ESXi?

Share this post


Link to post
Share on other sites

I can not start the VM. My set up is using ESxi5.5. The error message was the CPU is not supported with VT-x. I guess I have to try bare metal install?

Share this post


Link to post
Share on other sites

Its alive! Its alive!

Thank you very much for this. It was so much needed.

Works great on native installation HP N54L, Nanoboot.

Share this post


Link to post
Share on other sites

XPEH :

 

Do you have the option to install 64bit Virual machine? mine only limits to 32bit.

Share this post


Link to post
Share on other sites

I haven't try to create a new machine. As a quick test , I have converted and imported existing WinXP 32 bit VM. Works fine.

 

edit:

 

I have tried Win8.1 64 bit. Works fine.

Share this post


Link to post
Share on other sites
I can not start the VM. My set up is using ESxi5.5. The error message was the CPU is not supported with VT-x. I guess I have to try bare metal install?

 

Hi sorry for the late reply, been busy. I tested (and built) this on my laptop intel core2duo e8400 under Vmware player 6.0 and I run it on bare metal, Supermicro X10SBA mb with onboard Celeron j1900, with latest nanoboot.

Share this post


Link to post
Share on other sites

Is 64bit VM available for you? I don't know why I can not choose any 64bit VM OS. Does this depends on Java version install on DSM? because DSM only install 32bit Java from Java Manager ( the official Java installer for DSM ) .

Share this post


Link to post
Share on other sites

I can create 64bit VM now. Only in bare metal install. it's independence from Java version installed.

Share this post


Link to post
Share on other sites
I can create 64bit VM now. Only in bare metal install. it's independence from Java version installed.

 

Great glad it worked. :smile:

 

Sent from my Nexus 7 using Tapatalk HD

Share this post


Link to post
Share on other sites

About once every 2 days, I would not able to login through phpVirtualBox. I get the error during login:

 

SOAP-ERROR: Parsing WSDL: Couldn't load from '/volume1/web/phpvirtualbox/lib/vboxwebService-4.3.wsdl' :

failed to load external entity "/volume1/web/phpvirtualbox/lib/vboxwebService-4.3.wsdl"

Share this post


Link to post
Share on other sites

It's bug in phpVirtualBox http://sourceforge.net/p/phpvirtualbox/discussion/help/thread/605de475/ and http://sourceforge.net/p/phpvirtualbox/bugs/16/ or php. Some say they fixed it when they enable php_openssl in php.ini http://stackoverflow.com/questions/11082889/soap-error-parsing-wsdl-couldnt-load-from. My nas is not on 24/7 so it did not happen to me.

Share this post


Link to post
Share on other sites

PLEASE host this on a repository so others can contribute to the code and add it to e.g. Synocommunity.

Thanks :smile:

 

 

What modifications did you apply? Is it possible to share the source/compilation directory?

Share this post


Link to post
Share on other sites

As I throubleshoot the error SOAP-ERROR: Parsing WSDL , the only work-around is to stop Web Services, and start it back.

Share this post


Link to post
Share on other sites
PLEASE host this on a repository so others can contribute to the code and add it to e.g. Synocommunity.

Thanks :smile:

 

 

What modifications did you apply? Is it possible to share the source/compilation directory?

 

I don't have real Synology box to test this. That is the reason why this is not hosted in proper repository. Also I don't know if it would be of much use to host it, since you would need to have one of the syno boxes with at least I3 and if you have that much money you'd use separate Vm host.

Beside scripts for integration with DSM everything is stock. You just have to crosscompile drivers from source which I took from "all distributions" AMD64 version of virtualbox package.

Share this post


Link to post
Share on other sites

Thank you for this!! It works excellent on HP N54L microserver!

I needed to play/stream via upnp flac/cue files and ape/cue files and after installing a linux distro I installed foobar and a upnp addon on and it works perfect!! Thank you again! I think you should host this on a repository, you never know what does someone needs...

Share this post


Link to post
Share on other sites

I am not able to make USB available in guest OS.

VBoxManage list usbhost
Host USB Devices:

vboxusers group is not created during installation. Manual creation of this group and adding admin user to it did not help.

Any suggestions?

Share this post


Link to post
Share on other sites
I am not able to make USB available in guest OS.

VBoxManage list usbhost
Host USB Devices:

vboxusers group is not created during installation. Manual creation of this group and adding admin user to it did not help.

Any suggestions?

I don't use USB on guests in this setup so I didn't test that. What you can do is to check if Extensions are installed (check log for VM) they are required for USB it they are (and they should be) I'm out of ideas until I try that for myself. I guess this can be problematic since syno boots from USB and I guess he won't release control of USB to other app (this is wild guess).

Share this post


Link to post
Share on other sites

clunc

 

I see this sometimes on my box. It happens if I reboot the xpenology and start phpvirtualbox without waiting long enough for everything to get up and running, but also sometimes "it just happens". What works for me is go to the package center, stop the Virtualbox, wait a bit, then start (i.e. "run") the vbox package.

 

Andrew

Share this post


Link to post
Share on other sites

Hi,

 

First of all, thanks Seba for your hard work.

 

I successfully installed package on my Proliant. Everything is working fine.

I'm trying to run Mavericks into VirtualBox. I have a little problem when trying to access VM over RDP : there's a big mouse lag.

I read the problem could be fixed using "absolute pointing device" when running "VBoxManage".

 

I tried to run "VBoxManage" under Putty but it says "not found".

 

Any suggestions? Soorry, i'm a total noob...

 

++

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now