bigkris74

New Build (Baremetal) - Experiences - B365 + i5-9400

Recommended Posts

Long time user of Xpenology under ESXi on older hardware. Started a new baremetal build with new hardware and thought I'd share my experiences. Haven't been able to find anyone using the B365 chipset so thought I'd give it a go and report on functionality.

 

CPU = Intel i5-9400

Motherboard = Asrock B365M Pro4 Micro ATX

RAM = 16GB HyperX Fury 2666Mhz (2x 8GB)

NIC = HP NC360T PCIe (Dual Intel NIC)

USB = Sandisk Cruzer Fit 8GB

 

Will be recycling old hardware in but not there yet, just validating new hardware.

 

HBA = LSI 9201-16i 16 port PCIe (IT mode)

Hard Drives = 8x 3TB Seagate Enterprise Drives, 4x 256GB SSD (Brand escapes me at the moment)

Case = Fractal Node 804

 

 

The Good

 

  • All basic functionality worked, out of box.
  • Using 918+ 1.04b loader booted and performed install, no issues.
  • UEFI boot works.
  • Patched to latest build via GUI without issues.
  • Powers off, reboots and WOL all working perfectly. (Had issues on some old hardware)
  • Cold boots fast with no delays. (have read other experienced long boot times)
  • Didn't need to tweak BIOS settings at all for first boot. I did subsequently go back and tuned some BIOS settings as follows. Disabled onboard NIC (I219V, knew it wasn't going to work), disabled onboard audio and wifi/bluetooth (no module installed anyway), disabled C1E state.
  • CPU temp is monitored in Xpenology (Have had issues before with some hardware reading sensor)
  • Seems to have full fan control with all options available but requires further validation. Again hasn't worked with some older hardware I've used but that may not be surprise to other users.
  • CPU/Cores recognised and report accurately thanks to FOXBI's "ch_cpuinfo.tar" mod.
  • VMM works and detected CPU & core correctly. Quick built a Win server 2016, powered on and booted fine. I only ran it for about 15 minutes but looked and worked well.
  • With MB, CPU, RAM, PCIe NIC Card and 1 SSD connected and booted to Xpenology, seems to idle around 20w power usage but will confirm with more accurate meter.

 

The Bad

 

  • Onboard NIC is not recognised. As with all newer motherboards, the Intel I219V is not recognised, I knew it wouldn't, but have a stack of old PCIe Intel NICs so no issue for me.
  • Hardware transcoding looks to be an issue. Cannot get /dev/dri folder to appear. Have done some BIOS settings with the GPU, to no avail. Have tried i915.alpha_support=1 in the GRUB file to no avail. To be fair, there seems to be little info on this setting and I'm probably putting it in the wrong location. I will troubleshoot further and advise. Was really a nice-to-have for me as I run separate Intel NUC for Plex, which handles the transcoding role well.

 

That's probably it for now, from a couple of hours testing last night, so pretty pleased so far.

 

If people are interested, I'll continue to update thread as further testing and commissioning occurs.

 

Cheers.

 

Edited by bigkris74
  • Thanks 1

Share this post


Link to post
Share on other sites
On 9/13/2019 at 2:49 AM, bigkris74 said:

Onboard NIC is not recognised. As with all newer motherboards, the Intel I219V is not recognised, I knew it wouldn't, but have a stack of old PCIe Intel NICs so no issue for me.

 

you could try out the new extra.lzma's it contains latest e1000e driver 3.6.0 so you i219v should work with this

Share this post


Link to post
Share on other sites

Please LMK if you can get transcoding to work. I want to do a bare metal build on a 804 and have no idea what the best motherboard would be.

 

I would like to also add a 10GB Nic.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.