• 0
Talisker

Y a t’il un moyen de récupérer mes données

Question

Bonjour à tous 

 

jusqu’à hier j’avais un super HP N54L avec ces 6 disks en DSM 5.2 il me semble 

 

malheureusement hier le microserver c’est arrêté sans prévenir. Le bouton power est orange, les led réseau clignotent mais le server ne démarre pas ....

 

premiere question, avez vous déjà eu ce genre de soucis ? Si oui avez vous une solution pour réanimer le malade ? Savez vous où trouver un nouveau N54 ? 

 

seconde question, savez vous si il y a possibilité de récupérer les donnés si il n’y a pas moyen de relancer le server ?

j’aurai éventuellement le possibilité dans quelques temps de monter une machine de guerre (gros server Dell avec gros cpu et plein de mémoire.) mais avec aucune garantie de compatibilité de matériel avec xpenologie. A la limite avec machine virtuelle (sous virtualbox). 

Mais sachant que je n’ai que des interfaces SAS sur ce server est ce que je ne risque pas de flinguer les données sur les disk SATA du N54

 

Voila beaucoup d’interrogations 

 

merci par avance 

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Salut,

 

tu veux dire que ton N54L ne s'allume plus du tout c'est ça ? Donc soit c'est la CM qui est grillé, soit c'est l'alim.

 

Pour récupérer les données , tout dépend comment a été créé ton volume. Si tu as fait du RAID5 (ou SHR) sur >=3 disques alors tu vas grave galérer. Il existe des solutions payantes pour monter virtuellement le RAID sur un autre OS (Windows ou Linux) je pense à UFS Explorer mais il faut compter 150€ la licence. Si tu as plusieurs volumes en RAID1 alors un simple ext2fs devrait pouvoir lire les données sur les disques.

 

Quoiqu'il en soit avec ta future machine de guerre si le matos n'est pas nativement géré alors installe l'hyperviseur ESXi dessus comme OS hôte et crée une machine virtuelle en mappant tes disques dessus. DSM devrait n'y voir que du feu.

Share this post


Link to post
Share on other sites
  • 0

Salut,

Si tu avait que des volume simple le récupération n'est pas tres compliqué

Comme le dit @nicoueron cela se complique avec des "gros" raid.

 

Pour l'installation dans une autre machine, DSM ne voit pas le diff du moment que le matériel est compatible. Sinon il faut virtualisé.

 

Pour se qui est de ta machine, cela n'est peut être que l'alim qui a cramé suite a une surtension, un orage, ... dans se cas il suffit de la remplacer puis si tu as un RAID le NAS va re-démarrer, contrôler le RAID, et le reconstruire au besoin puis tout reviendra a la normale.

 

Si tu es dans le coin de Metz/Thionville (57), on peu pourquoi pas s'arranger pour que je te prête ma config de test, qui fonctionne très bien sur Xpenology afin au moins que tu puisse de nouveau avoir accès a tes données.

 

De plus payé une licence a 150€ pour remonter un RAID n'a pas trop de sens a mon avis, autant acheter une config d'occasion. ( - de 100€ )

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Malheureusement c'est un gros SHR composé des 6 disks

3x2To et 3x3To

 

Je ne sais pas si la machine est HS

Pour résumer elle est derrière un onduleur qui lui n'a pas sauté, pas eu d'orage hier en fin d'après midi 

Quand j'ai découvert que le server ne répondait plus, la led du bouton power était orange et le logo HP était bleu. Les disks étaient arrêtés tout comme l'alim

Actuellement quand il est branché, la lumière du bouton power est orange et les led de la carte réseau clignote mais rien d'autre

Quand j'appuie sur le power rien ne se passe ... En tout cas pas d'odeur suspecte ...

 

Sur un autre forum quelqu'un m'a dit que l'alim serait peut-être en protection. Ça vous parle ?

 

Pour ta proposition de me prêter ta machine de teste, ça m'intéresse pas mal en dernier recours. Je bosse au Luxembourg, donc pas loin de Metz/Thionville (j'habite du coté belge par contre)

D'ici 15 jours je suis en déménagement. Pour cette dernière solution on pourrai regarder après.

 

Merci à tous pour votre aide 

 

PS: pour ma machine de guerre, il va s'agir d'un gros Xeon avec 96Gb de ram et carte graphique quatro... pour les disques c'est un controler SAS avec 8 slot hot plug. Je pensais vraiment faire une machine virtuelle pour un DSM 

 

Share this post


Link to post
Share on other sites
  • 0
il y a 43 minutes, Talisker a dit :

pour ma machine de guerre, il va s'agir d'un gros Xeon avec 96Gb de ram et carte graphique quatro... pour les disques c'est un controler SAS avec 8 slot hot plug. Je pensais vraiment faire une machine virtuelle pour un DSM

💪^^

 

il y a 43 minutes, Talisker a dit :

Sur un autre forum quelqu'un m'a dit que l'alim serait peut-être en protection. Ça vous parle ?

Perso ça ne me dit rien mais possible qu'un fusible dans l'alim soit grillé. Le truc c'est que logiquement tu ne devrais avoir aucune led d'allumée dans ce cas.

Au pire il existe des alim de remplacement pour le N54L https://www.amazon.fr/Alimentation-Remplacement-FSP270-60LE-DPS-150TB-630295-001/dp/B07M8D4X9S#customerReviews

 

Share this post


Link to post
Share on other sites
  • 0

Les alimentations ( de bonnes qualité ) ont généralement des fusibles a réarmement auto et des fusibles "classiques".

En théorie, la débrancher quelques minutes suffit a relancer le truc :D Rien n’empêche de l'ouvrir pour regarder le type de fusible et les tester. ( Attention les condos de se genre d'alim peuvent rester chargés toutes une nuit, même débranché ! ) 

 

Les prises de ta maison sont-elle équipé de la terre ? Si oui, alors peu de chance que se soit un problème d'orage, .. l'onduleur aurait fait le taf !

Share this post


Link to post
Share on other sites
  • 0

À vérifier aussi, mais de mémoire on peut connecter un disque SATA sur un contrôleur SAS, je suis quasiment certain d'avoir fait ça sur un serveur Dell il y a quelques années.

Google devrait pouvoir le confirmer.

Sinon, monter un ESXi sur l'autre serveur et mapper les disques en RDM me semble être une bonne solution de repli si l'alimentation (au cas où c'est bien elle qui est en cause) ne veut pas repartir.

Jacques

Share this post


Link to post
Share on other sites
  • 0
Le 26/08/2019 à 22:51, JacquesF a dit :

À vérifier aussi, mais de mémoire on peut connecter un disque SATA sur un contrôleur SAS, je suis quasiment certain d'avoir fait ça sur un serveur Dell il y a quelques années.

Google devrait pouvoir le confirmer.

 

Je confirme, j'ai moi mème des disques Sata monté dans un enclosure SAS.

 

 

Le 26/08/2019 à 22:51, JacquesF a dit :

Sinon, monter un ESXi sur l'autre serveur et mapper les disques en RDM me semble être une bonne solution de repli si l'alimentation (au cas où c'est bien elle qui est en cause) ne veut pas repartir.

Jacques

 

C'est une excellente idée.

Attention toutefois si tu passes par un contrôleur Raid différent.

Il risque de demander de créer un Raid (Même si tu en avait un sur l'autre serveur) et tu perdras tes données.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.