gadreel

9th Gen Intel CPU

Recommended Posts

Hi,

 

When searching with the words "9th gen" nothing comes up.

I would like to know if XPEnology will work with a 9th gen Intel CPU (Core-i5 9400F).

 

Thanks.

Share this post


Link to post
Share on other sites
25 minutes ago, gadreel said:

Hi,

 

When searching with the words "9th gen" nothing comes up.

I would like to know if XPEnology will work with a 9th gen Intel CPU (Core-i5 9400F).

 

Thanks.

it should work, try the 1.04b loader first.  Let us know how it goes...

Share this post


Link to post
Share on other sites
1 minute ago, painkiller895 said:

it should work, try the 1.04b loader first.  Let us know how it goes...

Thank you. I will.

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/19/2019 at 12:27 AM, painkiller895 said:

it should work, try the 1.04b loader first.  Let us know how it goes...

 

@painkiller895Unfortunately unless I am doing something wrong the 219 Nic does not work therefore Synology Assistant cannot find it. I do not know, I see posts that other people with similar motherboards (AsRock B360) the 219 Nic works fine on the 1.04b Loader. Does not work on mine though. Tried on ESXI and works fine. Tried on an old PC 4thGen Intel 4790K and again I could see the synology but not on this PC with that NIC.

 

Any ideas?

Edited by gadreel

Share this post


Link to post
Share on other sites

@jensmander I did. I even tried other loaders and none works. I am wondering... I am looking at a video tutorial how to add .ko drivers on the extra.lmza file. If I get the updated Intel drivers for this NIC will it work? Is the issue with the I219-V because somebody has to compile the driver or something else?

Share this post


Link to post
Share on other sites
30 minutes ago, Olegin said:

@Olegin So adding another .ko wont work for DMS 6.2 can you load the driver in another way?

 

Will IG-88 approach work on DMS3615XS for DSM 6.1?

Share this post


Link to post
Share on other sites
1 час назад, gadreel сказал:

@Olegin So adding another .ko wont work for DMS 6.2 can you load the driver in another way?

 

Will IG-88 approach work on DMS3615XS for DSM 6.1?

Yes 2 times.

Share this post


Link to post
Share on other sites
Posted (edited)

Just for others that search and find this thread.  9th Gen Intel CPU's (and really all Haswell and later Intel CPU's) work fine with XPEnology.

 

OP's problem is with his particular motherboard NIC being too new for the driver and no effective way to add a driver with the latest DSM versions.

One solution would have been to add a compatible add-in Intel NIC as many have done.  Virtualization also would solve the NIC compatibility problem.

Edited by flyride

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, flyride said:

Just for others that search and find this thread.  9th Gen Intel CPU's (and really all Haswell and later Intel CPU's) work fine with XPEnology.

 

OP's problem is with his particular motherboard NIC being too new for the driver and no effective way to add a driver with the latest DSM versions.

One solution would have been to add a compatible add-in Intel NIC as many have done.  Virtualization also would solve the NIC compatibility problem.

 

@flyride OK. I read my last post and it can be a bit confusing. As flyride said, I have a Core-5 9400F, Nvidia GT610 and B360M mini ITX that comes with an I219-V NIC that is not compatible with DSM. Olegin also mentioned that is not possible to inject any drivers with DSM 6.2 to support this NIC. Because I have the GT610 on my only available PCI Express I cannot buy another compatible Intel NIC.

 

Since Bare Metal is out of the picture, I tried installing DSM 3616xs with ESXI. ESXI can it be very confusing at some point and it requires 2 cores and 4GB of RAM just to run the software and it does not support any RAID functionalities unless you have a hardware Raid (B360M chicp DOES NOT have). I was able to install DSM just fine (so many videos online how to do that) but when I tried to update the DSM to the latest version it did not work out. I could not see the DSM from the Synology assistant.

 

In the forum I could find any posts/tutorials whether is possible to install DSM as a VM under Unraid. But I went digging into Unraid forums and read posts of users that successfully installed PXEnology as a CentOs VM under Unraid. I use the synoboot.img for 3615xs as my primary disk (USB) and a qcow2/SATA as my secondary disk (Data Disk). Unraid can it be a bit harder than ESXI because you do not have as many GUI options as ESXI. The trick with Unraid is that at the Network Bridge in XML mode (you cannot do it in Form mode) you have to change the type of network card from whatever it is to "e1000e" which is compatible with DSM. That and some modifications with the Sata controller I was able to install the latest DSM under Unraid. You can even install a previous DSM version and then update it to the latest from DSM. It worked for me.

 

I will attach my XML here incase somebody in the future would like to try it.

 

Unraid for me is a better solution because it has Software Raid, cache drives and also you can use docker without installing it in DSM.

ds3615xs_unraid.xml

Edited by gadreel

Share this post


Link to post
Share on other sites

I'm glad you found something that worked for you.  The comment about ESXi and RAID is strange.  ESXi does support a software RAID in the virtualization layer, but the whole point of running DSM is not to do that and allow DSM to provide the software RAID anyway.

 

Many folks have installed virtualized DSM with KVM under a generic Linux installation; it would seem that you've done the equivalent but using UNRAID as your Linux environment.

 

Share this post


Link to post
Share on other sites
On 8/22/2019 at 6:55 PM, gadreel said:

 

@painkiller895Unfortunately unless I am doing something wrong the 219 Nic does not work therefore Synology Assistant cannot find it. I do not know, I see posts that other people with similar motherboards (AsRock B360) the 219 Nic works fine on the 1.04b Loader. Does not work on mine though. Tried on ESXI and works fine. Tried on an old PC 4thGen Intel 4790K and again I could see the synology but not on this PC with that NIC.

 

Any ideas?

Try one of these

Dell Intel PRO 1000 PT Dual Port PCIe x8 Gigabit Ethernet Network Card G174P  or OEM Dell G174P Intel Pro/1000 PT Dual Port Gigabit PCI-E Network Card

You can get this on ebay these worked for me...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.