Jump to content
XPEnology Community

N54L network issue


Recommended Posts

I have been away on holiday and shutdown my HP N54L running 4.3 and when coming back I have powered the system back on but can't seem to get any network connectivity from it.


The NIC of the back of the box looks fine it is flashing green/orange etc but it doesn't seem to come online. I have connected directly on the box and am able to get into the system and if I run ifconfig I only get showned the lo interface and a address.


I run etc/rc.network restart I get the following messages


ifconfig: SIOCSIFADDR: No such device

Unloading module llc ... [FAILED]


I have also tried running ifconfig eth0 netmask broadcast up but get the same message "ifconfig: SIOCSIFADDR: No such device"


Any idea's what could be going on? I had manually configured a static IP on the box which had been working fine for months.

Link to comment
Share on other sites

No I can't do anything on the box remotely, the NIC interface just doesn't come online.


I have been playing around with it for a little bit and found the config for eth0 under /etc/sysconfig/network-scripts/ifcfg-eth0 which is configured as below







Guessing I may have broken something as when I run ifconfig I get the following message now


ifconfig: eth0: error fetching interface information: Device not found


Looking under /etc/sysconfig/networking I only have the file ifcfg-lo and not sure if I should have a file there for eth0 or not?


Anyone with a better understanding of this would be much appreciate, I just want to get my files off so I can rebuild the thing now.

Link to comment
Share on other sites

Thanks for the reply, when I run that I get the following.


[3.162228] jme: JMicron JMC2XX Ethernet driver version 1.0.8

[10.072501] usbcore: registered new interface driver ethub


So looks like it does have the driver, any other idea's?

Link to comment
Share on other sites

Is that all it shows?


what is inbetween (boot times 3 seconds to 10 seconds?)


eg mine shows


MicroDS> dmesg | grep "eth"
[    4.012497] jme: JMicron JMC2XX ethernet driver version 1.0.8
[    5.738922] e1000e 0000:02:00.0: eth0: (PCI Express:2.5GT/s:Width x1) 00:1b:21:c2:82:72
[    5.739022] e1000e 0000:02:00.0: eth0: Intel(R) PRO/1000 Network Connection
[    5.739081] e1000e 0000:02:00.0: eth0: MAC: 3, PHY: 8, PBA No: E46981-006
[    5.802623] pcieport 0000:00:06.0: eth1: Tigon3 [partno(BCM95723) rev 5784100] (PCI Express) MAC address 3c:d9:2b:02:0c:ca
[    5.802720] pcieport 0000:00:06.0: eth1: attached PHY is 5784 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])
[    5.802774] pcieport 0000:00:06.0: eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[    5.802826] pcieport 0000:00:06.0: eth1: dma_rwctrl[76180000] dma_mask[64-bit]
[   10.404404] usbcore: registered new interface driver ethub
[   11.554060] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   12.374998] ADDRCONF(NETDEV_UP): eth1: link is not ready
[   14.008049] e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
[   14.011405] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   14.829887] pcieport 0000:00:06.0: eth1: Link is up at 1000 Mbps, full duplex
[   14.829887] pcieport 0000:00:06.0: eth1: Flow control is off for TX and off for RX
[   14.835049] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[   24.850009] eth0: no IPv6 routers present


Is the lan port disabled in the bios?



Link to comment
Share on other sites

  • Create New...