Terramaster F5-221 no driver ?


Recommended Posts

Hello,

i've set one xpenology 6.2.2 on Proxmox VM and it works perfectly. 

I've bought Terramaster F5-221 and a WD red 8 To, to have a true backup if ******* happens on Proxmox...

I've tried to set DS918+ and DS3617xs with Jun'loader 1.04b    and Jun'loader 1.03b but no LAN.

 

I've setted vid, pid, sn with xpenology.github link, mac1 & mac2. 

When i did lspci -k ... i saw :

 

r8169 : RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (Realtek)
ahci : ASM1062 Serial ATA Controller (ASMedia Technology Inc)

 

Any suggestion ? Thanks a lot

Link to post
Share on other sites
  • 5 months later...

just use the updated driver extension (extra.lzma) for your DSM version you want to use and the NIC card will be recognized.

I got the f2-420 quadcore dualbay and i'm on DSM 6.2.2 upd 4 3615xs(latest one available); without the updated driver extension i've been stuck ok 6.2 because of the NIC not recognized just as you

Edited by Herrnobiz
Link to post
Share on other sites
  • 2 weeks later...

I am unable to boot xpenology - I tried different USB sticks, different loaders (1.03+1.04) and edited the grub.conf accordingly (VID,PID,SN,Mac1,Mac2) but kernel does not even start. What am I doing wrong? Can somebody help me? I'd love to test DSM on my F5-221...

Thank you in advance... 

Link to post
Share on other sites
  • 10 months later...

I've managed to install last 918+ release 6.2.3 in my terramaster F5-221, without needing any driver apart from the native ones.

 

First of all, I didn't purchase a vga to 12pin adaptor as this nas does not count with a 12 pin header as a video output. Luckily, I just needed to break a tab to uncover the hdmi port in the back of the nas to access to a video output. This way, by connecting the HDMI to a screen and an USB keyboard, I have access to the bios, and I can override the boot drive. I cant change the boot order permanently, as the bios is locked to not allow that, but Ive discovered a workarround that I'll explain later.

 

I've flashed the 1.04b for 918+ in a cruzer fit 2.0 flash drive, and It booted up. I had to mount the usb in my computer, tweak the grub.config for updating the vid and pid the flash drive and the mac address of the network adaptors. Then booted again, this time I've installed synology, even, using an official image directly donwloaded by the wizard. And all worked perfectly. Finally, I had to tweak a little bit the bios, to teach it to boot from the flash drive instead of the disks. As the drives are configured as legacy, and the flash drive has both legacy and UEFI boot options, I've configured the bios, in the boot tab, for booting only UEFI disks, and that's it!

 

 

 

  • Like 1
Link to post
Share on other sites
  • 9 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.