Jump to content
XPEnology Community

Dell PowerEdge T320 DSM version?


zKA1RONz
 Share

Recommended Posts

jun's loader 1.04b supports haswell or later cpus only, so my T320, which uses sandy bridge en wont be able to use it.

 

however, i read that important notice about using 1.03b or earlier version loaders will make a kernel break if I use dsm 6.2.1 -~~~-.

 

Does this mean that I am limited to DSM 6.2 because I use 1.03b loader?

 

Or Will I be able to use later versions of DSM, just not that 6.2.1 -~~~~-?

Link to comment
Share on other sites

Hello and welcome to the forum.

 

5 hours ago, zKA1RONz said:

jun's loader 1.04b supports haswell or later cpus only, so my T320, which uses sandy bridge en wont be able to use it.

 

It's not the loader that defines which architecture is used but rather the Synology model that the loader was designed to simulate. In the case of loader v1.04b it's DS918+. In your case since your hardware is using a sandy bridge type CPU you are indeed correct when you say you can't use loader v1.04b because DS918+ is designed to work with Haswell or later intel architectures.

 

5 hours ago, zKA1RONz said:

however, i read that important notice about using 1.03b or earlier version loaders will make a kernel break if I use dsm 6.2.1 -~~~-.

 

The loader doesn't brake anything. In fact technically it's DSM that brakes the loader's hack. What happened is that since DSM 6.2.1 Synology introduced some more stringent checks during kernel boot time and those checks meant that people using non official PCI hardware (as in hardware that Synology actually condone and use in their own Synology models) would prevent upgrading to DSM 6.2.1. The way to bypass this is by simply using official like hardware parts so that the kernel does not choke on boot. Another way is to go all the way virtual. This bypasses many of the problems intrinsic to hardware.

 

5 hours ago, zKA1RONz said:

Does this mean that I am limited to DSM 6.2 because I use 1.03b loader?

 

No. You are limited to using loader v1.03b (either DS3615 or DS3617 model) BECAUSE of your CPU architecture. You are NOT limited to DSM 6.2 and you can go all the way up to DSM 6.2.2 AS LONG AS you have the correct hardware. I haven't looked in details your hardware specs though so I leave that up to you but you can always add a PCI card that is compatible and make the upgrade.

I would suggest the following reads:

https://xpenology.com/forum/forum/78-dsm-updates-reporting/

and

and

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...