Проблема с поврежденной DSM.


Recommended Posts

Всем привет.

Прошу помощи.

После обновления с 6.0.2 на 6.1.7 спустя месяц случилось странное, веб-службы перестали нормально загружаться. 

Я больше не могу попасть по SSH в систему DSM, сам сервер пингуется, виртуалки в Virtualbox продолжают работать и доступны удаленно.

Затем выяснилось, что у меня как минимум одна плашка памяти битая. 

мои действия далее. 

- Избавлюсь от памяти. 

- Отключаю основной рейд с данными и поврежденным DSM.

- Я беру новый SSD диск, ставлю на него новую систему, настраиваю.

- Все ОК работает.

- Подключаю основной рейд. 

- Все становится ровно так же как было прежде, система не грузится, но пингуется. Synology assistant сервер не видит.

 

Как правильно вычистить corrupted DSM не потеряв данные с рейд массива?

Edited by Realmagnum
Link to post
Share on other sites

Данные с раздела, где установлена DSM удалить.

Т.е. подключить винты к компу (что-нить юниксоподобное) и отформатировать два первых раздела по 2 Гб.

Тогда система грузанется с ССД, и накатит заново систему на рейд

Link to post
Share on other sites

А рейд не развалится если я буду диски по отдельности форматить эти разделы?

Я не уверен в своей квалификации чтобы рейд собрать под произвольным линуксом и форматнуть разделы сразу в рейде.

 

Link to post
Share on other sites

Рейд какой? Если первый (два диска) - ничего с ним не будет.

Во всяком случае, я как только не извращался (где-то моя тема есть по восстановлению данных)

Тема

 

Edited by SDL2000
Link to post
Share on other sites
14 часа назад, Realmagnum сказал:

По ssh/telnet доступа нету.

А массив зеркало RAID1.

Делайте как написал SDL2000 поочередно на каждом из дисков, но только форматировать!!! и не в коем случае не удалять указанные разделы.

Link to post
Share on other sites

Скачал образ parted magic, загрузился, на обоих дисках из раид-массива по 2 первых раздела отформатировал в ext4.

Перегрузился, synology assistant так и не увидел DSM.

Пинг проходит, по SSH зайти не могу.

Virtualbox загрузился исправно, виртмашина появилась в сети и могу зайти на нее по SSH.

http://192.168.0.1/phpvirtualbox/ - отображается только страница логина, после ввода пароля интерфейс грузится с ошибками и нормально не работает, гайку крутит.

поменял местами порты подключения, DSM в synology assistant появилась потом снова пропала. 

В остальном поведение аналогичное. 

Что посоветуете?

Link to post
Share on other sites

Когда включал DSM прислала письма: 

Тема: "

MM_NAS Checksum mismatch on MM_NAS. Please check Log Center for more details."

Тело письма: "Files with checksum mismatch were detected on your volumes. Please restore the files with a backup, and check the logs and S.M.A.R.T. information for the health status of disks."

Тема: "MM_NAS Volume 2 (Main RAID1 Data) on MM_NAS is running out of space"

Тело письма: "The available space of volume 2 (Main RAID1 Data) on MM_NAS is running out; please delete some files to free space.
Total capacity: 2745.99 GB
Available capacity: 261.23 GB (9.51%)"

 

Вот какого черта ей не нравится?

Вопрос: А если загрузится без РАИД-массива а уже к рабочей DSM на горячую подрубить эти рейдовые диски?

Link to post
Share on other sites
В 12.07.2019 в 15:09, SDL2000 сказал:

Во всяком случае, я как только не извращался (где-то моя тема есть по восстановлению данных)

А вот цитата "На данный момент Xpenology признает этот винт, при загрузке написал, что системный раздел поврежден, предложил восстановить, восстановил."

В какой момент хренолоджи предлагает восстановление?

Link to post
Share on other sites
Just now, Realmagnum said:

А вот цитата "На данный момент Xpenology признает этот винт, при загрузке написал, что системный раздел поврежден, предложил восстановить, восстановил."

В какой момент хренолоджи предлагает восстановление?

После загрузки системы. У меня-то система стояла на разделах.

Вы, если форматируете системные разделы - то системы нет. Должна при запуске предложить установить систему.

Вариант, если в виртуалке, добавить виртуальный диск. Ну к примеру на 16 гигов. Поставить систему, потом подключить этот рейд. 

 

Загрузчик-то правильный используете? Проверенный?

 

Link to post
Share on other sites
24 minutes ago, Realmagnum said:

Скачал образ parted magic, загрузился, на обоих дисках из раид-массива по 2 первых раздела отформатировал в ext4.

Перегрузился, synology assistant так и не увидел DSM.

Пинг проходит, по SSH зайти не могу.

Virtualbox загрузился исправно, виртмашина появилась в сети и могу зайти на нее по SSH.

http://192.168.0.1/phpvirtualbox/ - отображается только страница логина, после ввода пароля интерфейс грузится с ошибками и нормально не работает, гайку крутит.

э....

если вы отформатировали 2 первых раздела не всех дисках у вас DSM не может грузится...ей просто неоткуда...

Или у вас больше 2-х винтов? Или вы всё же после форматирования устанавливали DSM загружаясь c новой подготовленной флешки, но просто не стали про это писать?

Edited by TeleDDim
Link to post
Share on other sites

Если вы обратили внимание, у меня есть c правильным загрузчиком рабочая и настроенная DSM, стоящая на отдельном SSD 480Гб. Она работает, если в компе оставить только один SSD диск. Если подключить RAID массив с основным объемом данных происходит шняга, описанная выше.

Вот я хочу и знать, ну какого же хрена все зашибись работает без этого несчастного моего раида.

 

Edited by Realmagnum
перефразировал.
Link to post
Share on other sites
13 минуты назад, Realmagnum сказал:

Вот я хочу и знать, ну какого же хрена все зашибись работает без этого несчастного моего раида.

Видимо корень зла в вашем первом посте, на дисках данные не только в системных разделах попортились, но и в самом рейде.

В 12.07.2019 в 09:23, Realmagnum сказал:

Затем выяснилось, что у меня как минимум одна плашка памяти битая.  

 

Link to post
Share on other sites
Just now, Realmagnum said:

Если вы обратили внимание, у меня есть c правильным загрузчиком рабочая и настроенная DSM, стоящая на отдельном SSD 480Гб. Она работает, если в компе оставить только один SSD диск. Если подключить RAID массив с основным объемом данных происходит шняга, описанная выше.

Вот я хочу и знать, ну какого же хрена все зашибись работает без этого несчастного моего раида.

Не обратил. Извиняюсь.

Система на железе стоит? Или на виртуалке. Не очень понял из первого поста.

Сами винты проверяли? СМАРТ у них нормальный? Если один винт подкинуть, что происходит? UFS Explorer пробовали натравливать на винты?

Link to post
Share on other sites
11 минуту назад, Olegin сказал:

Видимо корень зла в вашем первом посте, на дисках данные не только в системных разделах попортились, но и в самом рейде.

 

6 минут назад, SDL2000 сказал:

Система на железе стоит? Или на виртуалке. Не очень понял из первого поста.

Сами винты проверяли? СМАРТ у них нормальный? Если один винт подкинуть, что происходит? UFS Explorer пробовали натравливать на винты?

Система стоит на железе. Винты в норме. Смарт тоже. 

 

Когда загружался в parted magic, запускал встроенный какой-то файловый менеджер, он автоматом нашел LVM раид раздел с моими данными и смонтировал его. Я вижу все свои файлы. И на проблемном ext4 раид1-разделе и на SSD диске с btrfs.

Отдельно UFS Explorer не запускал. 

Link to post
Share on other sites

Попробуйте один винт подкинуть

 

В БИОСЕ ничего не меняли? И точно разделы по 2Гб отформатировали?

Если к рабочей системе другие винты подкинуть на эти же SATA - видит?

Не проверяет он целостность рейда на этапе загрузки. Он их как физическое устройство в крайнем случае должен увидеть.

А тут что-то тормозит

Edited by SDL2000
Link to post
Share on other sites

Сата порты живые. Этот же самый SSD на всех портах работает на ура.

Подкидывание на живую в систему дисков ни к чему не привело. 

Сам он рескан не делает. 

Принудительный перебор цифр Х через "echo "- - -" > /sys/class/scsi_host/hostX/scan" ни к чему не привело, хоть "dmesg | tail" показывает что реакция на рескан есть. 

Скрытый текст

sh-4.3# dmesg | tail
[ 5066.783122] ata1: hard resetting link
[ 5067.089840] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[ 5067.102899] ata1.00: configured for UDMA/133
[ 5067.102911] ata1: EH complete
[ 5075.591475] ata2: hard resetting link
[ 5075.896084] ata2: SATA link down (SStatus 4 SControl 300)
[ 5075.896101] ata2: EH complete

 

Link to post
Share on other sites
25 minutes ago, Realmagnum said:

Подкидывание на живую в систему дисков ни к чему не привело. 

Я имел ввиду на выключенную систему. Т.е. подключить один диск - и включить.

Попробовать с другими дисками.

Попробовать БЕЗ ssd. Т.е. только один диск с рейдом впихнуть, и заново систему поставить.

Если все ок - второй диск потом отзеркалируется.

Link to post
Share on other sites
On 7/12/2019 at 8:23 AM, Realmagnum said:

мои действия далее. 

- Избавлюсь от памяти. 

- Отключаю основной рейд с данными и поврежденным DSM.

- Я беру новый SSD диск, ставлю на него новую систему, настраиваю.

- Все ОК работает.

- Подключаю основной рейд. 

- Все становится ровно так же как было прежде, система не грузится, но пингуется. Synology assistant сервер не видит.

 

Как правильно вычистить corrupted DSM не потеряв данные с рейд массива?

  • беру новый SSD диск, ставлю на него новую систему, настраиваю
  • Все ОК работает.
  • все диски с рейд монтируем на другую машину и сливаем все файлы по этому сабжу
  • те же все диски с рейд жестко форматируем по полной програме
  • ставим назад все отформатирование чистые диски
  • Все становится ровно

да, да, да  понимаю что хочется с наименьшими телодвижениями мигрировать, нема столько дисков и нет желания по новому настраивать права и все прикладнухи

 

но это рабочий способ а не гадания на кофейной гуще и перебор циферок уже как почти вторую неделю если считать с первого поста потерпевшего

 

 

Link to post
Share on other sites
Just now, 91844 said:

да, да, да  понимаю что хочется с наименьшими телодвижениями мигрировать, нема столько дисков и нет желания по новому настраивать права и все прикладнухи

Да тут можно попробовать разобраться. Система НЕ СТАРТУЕТ с подключенными дисками. Значит она пытается с них что-то грузить.

Второй вариант - драйвера.

 

Предложил попробовать с другими дисками. 

Можно другой загрузчик попробовать

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.