Recommended Posts

Hello,

 

since WOL has not worked for me out-of-the box, I decided to create this thread where we can share experience on this topic.

 

For some reason activating WOL over the GUI (Control Panel|Hardware) fails and does not have any effect. If WOL is supported by your HW configuration this is how you should get it running (DSM4.2):

 

Prerequisite:

• Find out the real MAC address of your Ethernet adapter (not the faked one by xpenology!) e.g. by booting linux/win form liveCD

• Enable WOL options corresponding to your HW in BIOS

 

1. Activate the WOL setting on your Ethernet adapter:

a. Enable SSH service (Control Panel|Terminal) and login (e.g. via putty) as root with admin password

b. Run following command: “ethtool -s eth0 wol g” (assumed eth0 is your Ethernet adapter)

2. Power off your system as usual

3. Now wake-up your system by sending a WOL magic packet using the REAL MAC address of your Ethernet adapter. There are many tools over internet which can do this; such a functionality is integrated in some router’s FW (e.g. dd-wrt)

 

Your system should boot up normally -this worked for me on two different systems. Now I am searching for a good way how to persist this setting in synology.

As a work-around you can set up a task (executing the above command) with DSM 4.2’s integrated Task Scheduler or via the 3rd party “Cronjob Editor” which is periodically executed once the system has booted.

 

Have fun!

Share this post


Link to post
Share on other sites
Now I am searching for a good way how to persist this setting in synology.

Have fun!

 

Voici la solution:

 

On se loggue avec Putty sur le DSM avec root comme user et le pwd d'admin.

On va dans /etc avec cd .. puis cd etc

On crée le fichier rc.local avec la commande Touch rc.local

On ouvre avec VI le fichier rc.local et on y met la commande suivante ethtool -s eth0 wol g

On sauve puis on redémarre le PC.

On réveille le pc en envoyant le paquet à l'adresse mac du DSM pas celle de la carte réseau du PC.

 

Georges

Share this post


Link to post
Share on other sites

My N36L get perfect WOL with the help from chinese forum:

http://nas1.cn/thread-64278-1-1.html

1. modify the /etc/synoinfo.conf wol_enabled_options=“” and eth0_wol_options="" to "g"

2. put the attached file to /usr/syno/etc/rc.d/ and give the file execuable permission。

Share this post


Link to post
Share on other sites
My N36L get perfect WOL with the help from chinese forum:

http://nas1.cn/thread-64278-1-1.html

1. modify the /etc/synoinfo.conf wol_enabled_options=“” and eth0_wol_options="" to "g"

2. put the attached file to /usr/syno/etc/rc.d/ and give the file execuable permission。[attachment=0]S99ZZZ_Shutdown.rar[/attachment]

reboot and enjoy

 

Works perfectly on a N40L. Thanks!

Share this post


Link to post
Share on other sites
My N36L get perfect WOL with the help from chinese forum:

http://nas1.cn/thread-64278-1-1.html

1. modify the /etc/synoinfo.conf wol_enabled_options=“” and eth0_wol_options="" to "g"

2. put the attached file to /usr/syno/etc/rc.d/ and give the file execuable permission。[attachment=0]S99ZZZ_Shutdown.rar[/attachment]

reboot and enjoy

 

Works perfectly on a N40L. Thanks!

 

Where find : "/var/packages/shutdown_script/DSShutdown.sh" ?

Share this post


Link to post
Share on other sites
My N36L get perfect WOL with the help from chinese forum:

http://nas1.cn/thread-64278-1-1.html

1. modify the /etc/synoinfo.conf wol_enabled_options=“” and eth0_wol_options="" to "g"

2. put the attached file to /usr/syno/etc/rc.d/ and give the file execuable permission。[attachment=0]S99ZZZ_Shutdown.rar[/attachment]

reboot and enjoy

 

Works perfectly on a N40L. Thanks!

 

Where find : "/var/packages/shutdown_script/DSShutdown.sh" ?

 

It is already there. There is nothing else that you need to do.

 

Side note, there is a weird bug. In order to keep using the WOL future the NAS has to be turned off by the iPhone DS Finder app? Everytime I turn the NAS off in the webinterface WOL doesn't work until I shut it down through the app... Could anyone confirm this?

Share this post


Link to post
Share on other sites

i have not /var/packages/shutdown_script/ in /var/packages/

 

can you send me "DSShutdown.sh" ?

Share this post


Link to post
Share on other sites
My N36L get perfect WOL with the help from chinese forum:

http://nas1.cn/thread-64278-1-1.html

1. modify the /etc/synoinfo.conf wol_enabled_options=“” and eth0_wol_options="" to "g"

2. put the attached file to /usr/syno/etc/rc.d/ and give the file execuable permission。[attachment=0]S99ZZZ_Shutdown.rar[/attachment]

reboot and enjoy

Jason,

 

Since the N36L does not support S3 sleep, what state are you waking your machine up from over the LAN? And how do you get it to go into that state in the first place

 

Thanks.

Share this post


Link to post
Share on other sites
My N36L get perfect WOL with the help from chinese forum:

http://nas1.cn/thread-64278-1-1.html

1. modify the /etc/synoinfo.conf wol_enabled_options=“” and eth0_wol_options="" to "g"

2. put the attached file to /usr/syno/etc/rc.d/ and give the file execuable permission。[attachment=0]S99ZZZ_Shutdown.rar[/attachment]

reboot and enjoy

Works great on HP N54L.

MAC address has to match the real NIC's MAC address and WOL enabled in the BIOS.

Synology Assistant wakes it up perfectly.

Share this post


Link to post
Share on other sites

Hi,

 

I applied this modification to validate WOL on my DSM4.2 . But now my xpenology does not boot anymore. I have no network access to see what happens via putty. I would like to know how to remove this modification ?

 

Tanks for your help.

 

Patrice

Share this post


Link to post
Share on other sites
Hello,

 

since WOL has not worked for me out-of-the box, I decided to create this thread where we can share experience on this topic.

 

For some reason activating WOL over the GUI (Control Panel|Hardware) fails and does not have any effect. If WOL is supported by your HW configuration this is how you should get it running (DSM4.2):

 

Prerequisite:

• Find out the real MAC address of your Ethernet adapter (not the faked one by xpenology!) e.g. by booting linux/win form liveCD

• Enable WOL options corresponding to your HW in BIOS

 

1. Activate the WOL setting on your Ethernet adapter:

a. Enable SSH service (Control Panel|Terminal) and login (e.g. via putty) as root with admin password

b. Run following command: “ethtool -s eth0 wol g” (assumed eth0 is your Ethernet adapter)

2. Power off your system as usual

3. Now wake-up your system by sending a WOL magic packet using the REAL MAC address of your Ethernet adapter. There are many tools over internet which can do this; such a functionality is integrated in some router’s FW (e.g. dd-wrt)

 

Your system should boot up normally -this worked for me on two different systems. Now I am searching for a good way how to persist this setting in synology.

As a work-around you can set up a task (executing the above command) with DSM 4.2’s integrated Task Scheduler or via the 3rd party “Cronjob Editor” which is periodically executed once the system has booted.

 

Have fun!

I got this when I tried ethtool -s eth0 wol g

 

"Cannot get current wake-on-lan settings: Operation not permitted

not setting wol"

Share this post


Link to post
Share on other sites

Hi,

 

The WOL works perfectly through my local network :I can wake up my N54L.

 

But how to wake up it through an other network like the 3G??

Share this post


Link to post
Share on other sites

Hello,

Using Trantor distrib of DMS4.2, i do not have DSShutdown.sh anywhere on the disk (do not even have a package directory)

And if i install the S99ZZZShutdown.sh script, then the machine is no more reachable when powering up. I have unplug/replug the ethernet cable to reach it.

So, i do not know what to do more: WOL does not work :sad:

Share this post


Link to post
Share on other sites

how do I give the script executable permissions? Just figured this out:

 

chmod 777 S99ZZZ_Shutdown.sh

 

not familiar with linux, took a little more googling. WOL works now.

Share this post


Link to post
Share on other sites

The only thing you have to do in my humble opinion is to find the REAL (hardware) MAC-adres and then every WOL-command wil work. (If in BIOS enabled and the NIC support it)........................the only trick is HOW to find the REAL MAC-adres?................................well, you can find it trough : /var/dmesg (via putty/SSH of course)

 

For example write it to : /var/dmesg >readme

then open the file readme for example with the VI-editor and search for "mac" (/mac ) and you will find the real Mac-adres.

something like :

4.670955] tg3 0000:02:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18

[ 4.671048] tg3 0000:02:00.0: setting latency timer to 64

[ 4.722294] pcieport 0000:00:06.0: eth0: Tigon3 [partno(BCM95723) rev 5784100] (PCI Express) MAC address 38:ba:ae:a0:fe:d8

[ 4.722378] pcieport 0000:00:06.0: eth0: attached PHY is 5784 (10/100/1000Base-T Ethernet) (WireSpeed[1], EEE[0])

[ 4.722421] pcieport 0000:00:06.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]

[ 4.722462] pcieport 0000:00:06.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]

[ 4.732906] bromolow_synobios: module license 'Synology Inc.' taints kernel.

Write down the MAC-adres, then quit the VI-editor (:q!)

 

The output of dmesg is a list of kernelmessages so.................

 

Best regards,

Léon

 

To get a 10 you could also change the MAC-adres in the Vender file (with a HEX-editor) so that even the DSM-software will output the wright MAC.

Share this post


Link to post
Share on other sites

Hello,

I use WinSCP to have the access to system files.

At the first log with SCP protocol, I have a first error message "-sh: groups: not found , but after OK I have the access to the folder.

But when I want to save the synoinfo.conf file after modification I have the same message and scp: /etc/synoinfo.conf: Permission denied.

If someone could help me :wink:

Thanks a lot

Share this post


Link to post
Share on other sites
Hello,

I use WinSCP to have the access to system files.

At the first log with SCP protocol, I have a first error message "-sh: groups: not found , but after OK I have the access to the folder.

But when I want to save the synoinfo.conf file after modification I have the same message and scp: /etc/synoinfo.conf: Permission denied.

If someone could help me :wink:

Thanks a lot

 

Did you find your answer and get it working?

 

You need to login with SCP using the username "root" and not the name used to login to DSM, password remains the same as you created at setup.

Share this post


Link to post
Share on other sites
Hello,

I use WinSCP to have the access to system files.

At the first log with SCP protocol, I have a first error message "-sh: groups: not found , but after OK I have the access to the folder.

But when I want to save the synoinfo.conf file after modification I have the same message and scp: /etc/synoinfo.conf: Permission denied.

If someone could help me :wink:

Thanks a lot

 

Did you find your answer and get it working?

 

You need to login with SCP using the username "root" and not the name used to login to DSM, password remains the same as you created at setup.

 

Thank you for the information. That was exactly the answer I was looking for.

Share this post


Link to post
Share on other sites

What exactly is the script S99ZZZ.sh doing?

Does WOL works without this script, just by enabling it with "g" as described above?

Share this post


Link to post
Share on other sites

What exactly is the script S99ZZZ.sh doing?

Does WOL works without this script, just by enabling it with "g" as described above?

Share this post


Link to post
Share on other sites

Sorry guys, still trying to figure out what script S99ZZZ.sh above is doing.

 

Why "put the attached file (S99ZZZ_Shutdown.rar) to /usr/syno/etc/rc.d/ and give the file execuable permission"???

 

Anyone?

Share this post


Link to post
Share on other sites

Sorry guys, still trying to figure out what script S99ZZZ.sh above is doing.

 

Why "put the attached file (S99ZZZ_Shutdown.rar) to /usr/syno/etc/rc.d/ and give the file execuable permission"???

 

Anyone?

Share this post


Link to post
Share on other sites

Hi, I have activated WakeOnLan on BIOS on my DSM 4.3..

 

I have changed my /etc/synoinfo.conf:

 

wol_enabled_options=“” to wol_enabled_options=“g”

eth0_wol_options="" to eth0_wol_options="g"

 

And then i have put S99ZZZ_Shutdown.sh on /etc/syno/etc/rc.d and "chmod +x S99ZZZ_Shutdown.sh"

 

And i can wake up my N54L locally but not connected to another outside network..

 

What have I to do to can wake up on wan? open udp 9 port is the only thing to do? This port is open to IP N54L or broadcast address?

 

I would appreciate any help.

 

Thanks.

Share this post


Link to post
Share on other sites

xpenology dsm 5.0 update 5

 

Motherboard Gigabyte z87x-ud5h connected to netgear r7000 .

 

Manage to work wol in lan and over internet , but i cannot shutdown !! Keep power on (restarts) after 2-3 sec .

 

Any help?

Share this post


Link to post
Share on other sites

Hi all! My problem is that I can wake up my server from LAN, but there is no way to wake up from the Internet. On the other hand I can't find my original MAC address, please somebody explain me the way to define it! Which port should I use to WOL? I tried 7,9,5000. I have a asrock q1900-itx motherboard. I modified the eth0 setting and wol to "g" and added a shutdown script. I have no more idea what to check. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now