T-REX-XP

Atomic Pi - Xpenology build

Recommended Posts

Hello guys, 

 

I have got Atomic PI SBC. and i'm trying to install os from ds918.

The loader booting process looks good, network is works fine. But i have got one problem. This pc doesn't have sata controller, so any other usb disks, internal emmc doesn't recognized as available for installation.

 

As an alternative to install on bare metal, i have try to use xpenology-docker project. 

 

Any body knows where i can download kernel modules with virtio ??? because i have got problem with network and storage, in this case.

 

 

Thanks.

Share this post


Link to post
Share on other sites

Oh, if you want to f..ck for funny - f..ck yourself and save your money.

  • Confused 1

Share this post


Link to post
Share on other sites
7 hours ago, Olegin said:

Oh, if you want to f..ck for funny - f..ck yourself and save your money.

 

I am not entirely sure what message exactly you intended to convey here (humour attempt perhaps?) but looks to me borderline.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi could you use an usb to sata controller?

 

btw how did you get arround the booting process cause mine won't boot from uefi with an usb stick :-( 

Edited by RC97F
added url

Share this post


Link to post
Share on other sites
40 minutes ago, RC97F said:

btw how did you get arround the booting process cause mine won't boot from uefi with an usb stick

I don't have any problem with booting. I have used the microsd card and usb flash drive, all work fine. As a result, I have got xpenology ds918 in recovery mode, that available on my network. But at least one main problem still presented: no HDD available for installation (( Yes, I have tried USB HDD.

Share this post


Link to post
Share on other sites

A few updates:

 

I'm trying to use xpenology-docker project.

OS: Ubuntu server (last)

 

The default configuration of this container contains unsupported network adapter model.

So, I have changed model to e1000, after that it is starting to work on bootloader as eth0. But port 5000 still not response on host os.

 

Looks like the IP address for the virtual machine is not correct:

current ip: 169.bla.bla.bla
ip from VM config: 20.20.20.21


Also i don't have the admin password(( Variant with admin:123456 is not valid.

 

I't is an experiment for me. I wold like to create something like portable nas, based on xpenology, without active cooling.

Looks like the main problem of this SBC: missing pci slot.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.