dedmsk

Slow boot on GIGABYTE GA-J3455N-D3H and Jun's Loader v1.04b DS918+

Recommended Posts

1 час назад, dedmsk сказал:

dancing dancing
I figured out the console.
successfully received a log file...

 

Shalom Izzy, you better get a poppy shake than a crap car :)

Share this post


Link to post
Share on other sites

Can I disable video in grub.cfg???

in bios I can't disable video 

Share this post


Link to post
Share on other sites
Posted (edited)

Try my extra : (no need to disable anything in bios)

 

Change of this extra.lzma >

- removed drivers i915.ko drm_kms_helper.ko drm.ko in usr/lib/modules

- removed reference of this drivers in etc/rc.modules

 

Installation >

sudo -i
echo 1 > /proc/sys/kernel/syno_install_flag
mkdir -p /mnt/synoboot1
mkdir -p /mnt/synoboot2
mount /dev/synoboot1 /mnt/synoboot1
mount /dev/synoboot2 /mnt/synoboot2

Remove extra2.lzma and replace extra.lzma by the one attach at this is post in /mnt/synoboot2

 

Important > clean /usr/lib/modules/update/*  - Be careful with the rm ! :)

 

rm -rf /usr/lib/modules/update/*

And reboot.

 

you might not have KP on i915 but you''ll probably lost your LAN, since this motherboard only have an old PCI port, i have no clue about a LAN card in PCI that might work.

 

Alternatively you can use a dongle USB3 > LAN, a one with a ax88179 chips like this one > https://www.amazon.fr/gp/product/B00MYTSN18/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

 

This chipset work natively with the DSM driver :

 

[ 240.104583] ax88179_178a 2-3:1.0 eth1: register 'ax88179_178a' at usb-0000:00:15.0-3, ASIX AX88179 USB 3.0 Gigabit Ethernet, 00:0e:c6:bd:d5:13
[ 240.118675] usbcore: registered new interface driver ax88179_178a

 

extra.lzma

Edited by real3x
  • Like 1
  • Thanks 3

Share this post


Link to post
Share on other sites
Try my extra : (no need to disable anything in bios)
 
Change of this extra.lzma >
- removed drivers i915.ko drm_kms_helper.ko drm.ko in usr/lib/modules
- removed reference of this drivers in etc/rc.modules
 
Installation >
sudo -iecho 1 > /proc/sys/kernel/syno_install_flagmkdir -p /mnt/synoboot1mkdir -p /mnt/synoboot2mount /dev/synoboot1 /mnt/synoboot1mount /dev/synoboot2 /mnt/synoboot2

Remove extra2.lzma and replace extra.lzma by the one attach at this is post in /mnt/synoboot2
 
Important > clean /usr/lib/modules/update/*  - Be careful with the rm !
 

rm -rf /usr/lib/modules/update/*

And reboot.
 
you might not have KP on i915 but you''ll probably lost your LAN, since this motherboard only have an old PCI port, i have no clue about a LAN card in PCI that might work.
 
Alternatively you can use a dongle USB3 > LAN, a one with a ax88179 chips like this one > https://www.amazon.fr/gp/product/B00MYTSN18/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1
 
This chipset work natively with the DSM driver :
 

[ 240.104583] ax88179_178a 2-3:1.0 eth1: register 'ax88179_178a' at usb-0000:00:15.0-3, ASIX AX88179 USB 3.0 Gigabit Ethernet, 00:0e:c6:bd:d5:13[ 240.118675] usbcore: registered new interface driver ax88179_178a

 
extra.lzma


Why Ethernet card not work ?


Отправлено с моего iPhone используя Tapatalk

Share this post


Link to post
Share on other sites

Because a big part of Realtek Ethernet Chips stop to work under the last update. Gigabyte dont communicate on witch Realtek Chips they integrate on this motherboard. I've just find the pid/vid/rev Device [10ec:8168] (rev 0c) > the rev 0c is the important thing, but i did not find the corresponding realtek model.

 

But try the update with my extra.lzma and we'll see if the lan work :)

Share this post


Link to post
Share on other sites

Another question...

If I install xpenology on VMware.

transcode work?

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/26/2019 at 4:56 PM, dedmsk said:

Connect to serial console.

But I see only garbage...

 

Setting correct 1150200/8n

photo_2019-06-26_17-37-21.jpg

I am experiencing the same problem.

Now, while not being a guru, I'm not a newbie either..

I'm running Jun's 1.04b on an Asrock J4105-ITX, which has a physical COM connector.

what I've tried so far: 115200bps, 8n1, no flow control.

I tried two different USB adapter, an FDTI 232RL and a Prolific 2303. Same garbage.

I modified grub.cfg  (and re-flashed) to lower the baud rate to 38400:

if serial --port=0x3F8 --speed=38400;then
        set has_serial=true
        terminal_input --append serial
        terminal_output --append serial
else
        clear
fi

hoping that it was corruption due to the  high baudrate but no.. same as above.

I tried using logical inversion of the RX using Winterm at both the above baudrates.. same garbage.

 

Anyone got an idea of what else I might try?

..and @dedmsk : you said you solved this issue.. might you please tell me how?

Many thanks!

Edited by ilgrank

Share this post


Link to post
Share on other sites
19 hours ago, ilgrank said:

I am experiencing the same problem.

..and @dedmsk : you said you solved this issue.. might you please tell me how?

Many thanks!

 

I believe he said what he did to fix his issue.

 

On 6/28/2019 at 7:56 PM, dedmsk said:

Today I buy USB-RS232 cable and change male connector to female. In 2 hours I will try the cable in action

 

Do not change the baud rate.

 

Share this post


Link to post
Share on other sites
8 hours ago, Polanskiman said:

 

I believe he said what he did to fis hix issue.

 

 

Do not change the baud rate.

 

I'll try to buy a different adapter then (the only doubt I have so far is that both the adapters I'm currently using are TX/RX only, and do not carry CTS/RTS data)

.. but while we are at it.. why I should not change the baud rage in grub.cfg? Any undesired side-effect?

 

Share this post


Link to post
Share on other sites
I'll try to buy a different adapter then (the only doubt I have so far is that both the adapters I'm currently using are TX/RX only, and do not carry CTS/RTS data)

.. but while we are at it.. why I should not change the baud rage in grub.cfg? Any undesired side-effect?

 

 

The actual question is, why change it?  Your problem is related to the adapter I think. Check out what I said here:

 

 

 

Share this post


Link to post
Share on other sites

I'll answer a couple of questions of mine:

1) You can change the baudrate, but it will be switched back to 115200 after Grub, so as @Polanskiman said, it is not worth to change it.

2) The problem lies NOT in the cables, but in the CTS/DSR lines, which I had *not* connected as usually (99% of the times) they're not needed.

I switched to a full (9 pins connected) adapter and it worked at first try.

Then I switched back to my arduino usb to serial, connected the missing pins and it worked too.. mistery solved :)

Now I can finally try to figure out the remaining issues..

 

Again, many thanks to everyone who helped!! :)

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/29/2019 at 5:25 PM, real3x said:

Try my extra : (no need to disable anything in bios)

 

Change of this extra.lzma >

- removed drivers i915.ko drm_kms_helper.ko drm.ko in usr/lib/modules

- removed reference of this drivers in etc/rc.modules

 

Installation >


sudo -i
echo 1 > /proc/sys/kernel/syno_install_flag
mkdir -p /mnt/synoboot1
mkdir -p /mnt/synoboot2
mount /dev/synoboot1 /mnt/synoboot1
mount /dev/synoboot2 /mnt/synoboot2

Remove extra2.lzma and replace extra.lzma by the one attach at this is post in /mnt/synoboot2

 

Important > clean /usr/lib/modules/update/*  - Be careful with the rm ! :)

 


rm -rf /usr/lib/modules/update/*

And reboot.

 

you might not have KP on i915 but you''ll probably lost your LAN, since this motherboard only have an old PCI port, i have no clue about a LAN card in PCI that might work.

 

Alternatively you can use a dongle USB3 > LAN, a one with a ax88179 chips like this one > https://www.amazon.fr/gp/product/B00MYTSN18/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

 

This chipset work natively with the DSM driver :

 


[ 240.104583] ax88179_178a 2-3:1.0 eth1: register 'ax88179_178a' at usb-0000:00:15.0-3, ASIX AX88179 USB 3.0 Gigabit Ethernet, 00:0e:c6:bd:d5:13
[ 240.118675] usbcore: registered new interface driver ax88179_178a

 

extra.lzma 1.48 MB · 21 downloads

Can't mount synoboot2

Wrong fs type or resource busy (((

 

synoboot1 successful mount

Edited by dedmsk

Share this post


Link to post
Share on other sites
Posted (edited)

Can i write new image with changes with extra.lzma and delete extra2 and do fresh install ?

 

my Xpenology is dead 😂

Edited by dedmsk

Share this post


Link to post
Share on other sites

Yes, just keep one extra on your new usb boot. Take the one in my sign, it work perfectly on the GA-3455N-d3H.

Share this post


Link to post
Share on other sites
Posted (edited)

replace extra

delete extra2

and network not work

:: Loading module r8168[   26.822904] BUG: unable to handle kernel paging request at 0000000700000005

 

Can attach work img file for GA-J3455N-D3H ?

Edited by dedmsk

Share this post


Link to post
Share on other sites

Is you DSM installation new ? if not you have to :

 

Important > clean /usr/lib/modules/update/*  - Be careful with the rm ! 

 

rm -rf /usr/lib/modules/update/*

And if the DSM is new, it's probably a bios error, make sure that all is uefi in bios setting, specially the LAN

Share this post


Link to post
Share on other sites

Successful update!!!

Replace extra.lzma but not delete extra2.lzma

 

THANKS!!!!

Share this post


Link to post
Share on other sites
On 6/29/2019 at 4:25 PM, real3x said:

 

Alternatively you can use a dongle USB3 > LAN, a one with a ax88179 chips like this one > https://www.amazon.fr/gp/product/B00MYTSN18/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

What is my best to use this USB3 ethernet dongle? Should I disable MOBO NIC? Or should I left internal NIC enabled and add another NIC on grub.cfg?

Share this post


Link to post
Share on other sites

If i remember well, you have nothing to do, just plug the dongle and you'll get a new LAN ip. If it dont work you can try to disable the onboard NIC.

 

You're on a J4105B-ITX ? it's a RTL8111H, and this NIC is reported to work with 6.2.2-24922 Update 2.

 

 

 

 

Share this post


Link to post
Share on other sites
9 minutes ago, real3x said:

If i remember well, you have nothing to do, just plug the dongle and you'll get a new LAN ip. If it dont work you can try to disable the onboard NIC.

 

You're on a J4105B-ITX ? it's a RTL8111H, and this NIC is reported to work with 6.2.2-24922 Update 2.

 

 

 

 

J4105B-ITX here.  Hardware transcoding is working  on 6.2.1 update 6 and custom extra.lzma.

I tried and updated two times on a test disk 6.2.2 changing extra.lzma, deleting extra2.lzma on 1.04 loader and deleting /usr/lib/modules/update/* . It worked flawlessly but none of the two times I tried hardware transcoding was working. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.