Jump to content
XPEnology Community

DSM 6.1 not available anymore after changing IP address


chrIsYs
 Share

Recommended Posts

Hello community, 

 

I've set up my very first NAS, a HP Microserver Gen8 and installed Synology 6.1 on it.

The last few days I spent doing setup and I'm almost finished. But now I have a problem and hope someone can help me.

At first I struggled to make my NAS available from external access and therefore did some settings regarding fixed IP address and DDNS etc., still got problems here but that is not the point for now.

My main problem now is, that I had the private IP address 192.168.178.100 (for Ethernet-Port 1) set on my router (FritzBox 7430), later because of DDNS settings it also got static on the NAS.

Because that IP address is within DHCP range, I wanted to change the IP address to 192.168.178.15, unfortunately I was extremely stupid for a few seconds and first did this change on the router!!!

Even though I tried to immediately update the NAS too (router said this action takes effect after restarting the device), it was already to late, I couldn't connect the DSM anymore.

So I tried to undo my last router change, and changed the IP address back to 192.168.178.100, but no success, still not possible to access the DSM.

I did some restarts, changed the LAN port. Also tried to access via different network on Ethernet-Port 2, but that one also seems to be blocked.

I also restarted the router, deleted any information set on the router and let the device re register, but nothing changes.

 

I always get the same Synology error saying "Sorry accessing page is not available".

Funny fact, when doing a ping it answers correctly, doing telnet on the IP address with port 5000 I get a "connection refused". (regarding first mentioned problem from external access, I always got refused to even though portforwarding was set on the router, so I am wondering if the NAS itself blocked and not some firewall...)

 

I'm out of ideas now. I have no clue what to do next.

My last resort would have been by connecting with Linux and SSH, but since of security reasons I still didn't want to make this available, so this option is blocked at the moment.

 

What the heck could I do now? I just can't understand the problem. Why isn't it possible to connect to the DSM after changing back to the old IP address? All shares etc. are still available, as a NAS it works atm, but I'm not able to do any administration anymore.

 

Usually at this point I would go into ILO and do some work local, but in this case I can not see anything.

I don't even have a idea how to reinstall or whatever without wiping the drives...

 

I hope there is someone with an idea because I'm kinda lost now.

Maybe the solution is easy and I'm just not seeing it.

 

Thanks in advance.

Best regards

Link to comment
Share on other sites

1 - Do you find it if you use the Synology Assistent?

If so, is that IP it shows you the same as you try to connect to?

2 - Do you have another PC at home, that you can try to connect from, in case your IP has been autoblocked?

 

 

btw:

What "Branded Hardware" are you using? (in regards to this subforum...)

Edited by bearcat
Added a Q
Link to comment
Share on other sites

Unfortunately not, neither find.synology.com nor the Synology Assistant detect a "Synology" device (this has been working before). Now they find just nothing.

 

Yes I do, I also tried to connect with my smartphone from both networks.

Tested it also with another computer and I do have the same errors.

 

One more problem appeared, it does not work correctly as a NAS. It does show all the shares, but when trying to open them it gives an error. An attached USB-HDD does also appear and can be accessed. The NAS is definitely in the network and working, but it blocks everything now...

 

I assumed under branded any major company like HP in this case. Wrong interpretation?

Link to comment
Share on other sites

Ok, I've been troubleshooting today together with a colleague at work (he's Linux administrator) and we weren't able to do anything.

The ports are open but we can not get anything. It looks like the HTML entries etc. might have been shuffled and there is nothing to open at the port we go in. No idea where it went and since there is no SSH access available at this point there probably is no other option than reinstalling the DSM.

 

Any suggestions on how to maybe just update?
I was thinking of making a new bootloader for 6.2 and then just updating?

Any way how to force an update from a state where I can't enter DSM?

Or do I have to boot Linux, wipe the discs, then boot loader and install DSM again by using find.synology.com.

 

Should I go with 6.1 again (older and more stable?) or go with 6.2 now?

Edited by chrIsYs
Link to comment
Share on other sites

Oops somehow I missed the info about it being a G8 Microserver... that's why I added the last Q.

 

I'm sure you have already tried this, but have you shut down both the NAS and the router, booted the router and then the NAS?

 

Let me see if I got this correctly, 

did you first set a fixed adress directly on the NAS,

or did you first reserve the DHCP given adress (within the DHCP scope), then setting it to a different, but fixed IP directly on your router?

 

Seeing your other problems, with the "disappearing" shares, it seems like there are some other problem "hidden" somewhere.

Are you using Jun's 1.02b bootimage?

And, are you using the 3615 or the 3617 variant?

 

Depending on how much (important) data you have on your NAS, the fastest way might be to do a full clean install.

 

You might be lucky, and do a "migrate" install, going from 15 to 17, or the other way around, 

and by so, deleting the settings (and apps) but keeping your data.

Or you may boot a linux distro, and format the system partition(s) on your disk(s), keeping the data partition(s) intact.

(btw: if it's important, you allready have at least 2 backups of your data;-) )

 

Or, while running the live-linux, you might edit the files keeping your network config, resetting it to defaults (DHCP).

 

BTW:

Are you only using the internal nic's on your G8, or have you installed any extra nic's?

(in case you want to go the 6.2.x way).

 

Link to comment
Share on other sites

  • 2 weeks later...

Sorry for not answering, was busy the last days.

The time I had I used for resetting my NAS. I went with a full wipe! Booted from a Live-Linux, wiped the drives and then I began from zero again.

Before and this time again I used DS3617xs 6.1 Jun's Mod V1.02b for this as a boot loader and installed DSM 6.1 again.

Only thing changed this time, instead of using a USB-stick as a bootloader, I changed to SD card (was surprised this worked that smooth).

 

Anyway I learned from my errors and the first things I did was to setup a backup admin and of course, activate SSH.

Tested SSH and worked. I did the usual setup stuff and for the last few days it just ran and did what it should as a NAS (moving data, streaming music to radio, streaming video to TV...), no problems there.

But now of a sudden this changed...

I was doing some research regarding my NAS hardware, therefore logged into DSM, everything ok, after some time I wanted to see the performance from the CPU and RAM and was surprised it didn't change in anyway, wanted to open another window within DSM and suddenly -white screen- and the same message as before, page not available!

What the heck?

Services for Windows were still available, music streaming etc. also no problems, but DSM down.

This time I logged into SSH, did some research regarding Linux commands and important services.

Using the command synoservicectl etc.

Checking the services nginx, DSM and synoscgi.

Nginx ok, DSM and synoscgi obviously down, restarting ended with an error.

 

Here some output:

Quote

root@NAS:~# synoservicectl --restart DSM
DSM failed to restart... error unknow [0x4000 servicectl_status.c:27]

 

root@NAS:~# synoservice --status DSM
service [DSM] status=[error]
required upstart job:
        [synoscgi] is stop.

 

root@NAS:~# synoservicectl --status synoscgi
synoscgi stop/waiting

root@NAS:~# synoservicectl --restart synoscgi
synoscgi restarted.

root@NAS:~# synoservicectl --status DSM
DSM failed to get status... error unknow [0x4000 servicectl_status.c:27]

root@NAS:~# synoservicectl --restart DSM
DSM failed to restart... error unknow [0x4000 servicectl_status.c:27]

 

So what on earth is this error [0x4000 servicectl_status.c:27] ???

Why did this happen again?

It looks exactly like the error before.

Since it seemed like I could't get up and running again, I tried a system reboot.

But this was unfortunately no help.

The only thing changed was, that it now also isn't available for Windows anymore. All the shares are no longer available (like before).

Luckily I still could connect via SSH, but I have no clue what to do next.

 

Something seems to be wrong, but I have no idea what.

Is it possible that the HP Microserver is not the best hardware for an Xpenology NAS?

Did anyone else run into such problems?

 

If I should need to re-setup, I'm thinking of using 6.2 this time, speaking of:

On 6/3/2019 at 8:31 PM, bearcat said:

Are you only using the internal nic's on your G8, or have you installed any extra nic's?

(in case you want to go the 6.2.x way).

Yes I'm only using the internal 2 ports (ILO also over Port 1).

 

And if 6.2 also shouldn't work I might need to give up and go with FreeNAS (which would be kinda sad, I got to like the DSM).

I also exported a log from the shell and attached it.

 

Hope to find some way.

 

Best regards and thanks in advance.

NAS Log.txt

Link to comment
Share on other sites

My idea is to make a sidegrade and move your installation to DS3615. I have 3 Microserver Gen 8 which runs very fine with DSM 6.2.2 under ESXi and bare metal.
I have made some tests with DS3617 and only got issues I never see with the DS3615-Branch.

There are howtos in this forum how to make the move from DS3617 to DS3615.
The most important part is to set the NIC to Intel E1000E (if on ESXi) or use a real Intel NIC and set the hdd-controller to SATA. Details are written in the howtos for sure.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...