Jump to content
XPEnology Community

Booting without GPU and other HW issues


Recommended Posts

Hey guys,

first of all, thank for all the hard work you've put into this project, I am so glad I found you ^^

currently I am using nanoboot on latest version of DSM (after going with 5-beta, 4458 u2 and so on) and it worked flawlessly with 3x 250GB disks. So I was like let's finish this, I bought a 3TB Seagate in NAS version, plugged it into my rig, that is:


GA P35-DS4 v1.1

C2D E6750

some DDR2 RAM of course, got 2x1GB for dual and one other 1GB, which I am using now (it's enough, so far..)

(+some random old ati card PCIe from some PC I found around the house : )


ofc a usb stick with the nanoboot.


I have 2 questions regarding this:

1) the easier one, my friend offered me his http://www.asus.com/Motherboards/P5QE/ with dual LAN, can I use this board the be able to forward internet connection, just like I would do in windows ? Anything regarding the boot loaders is pure magic for me :smile:


2)the harder - due to chipset limitations and bios versions, I was not able to run the 3TB drive as 3TB, it was showing in BIOS just as a 2TB drive, of course. So I googled a bit and since I want to be future ready, the 2 sata ports on different chipset is not a solution, I tried flashing from original F4 bios to latest official F14, which didn't help, so I went with modded one http://forums.tweaktown.com/gigabyte/48085-gigabyte-modified-bios.html F15b. Which is nice in being able to detect 3TB disk just fine, it's showing 3000GB in BIOS and also in DSM, so to sum it up, it's fine. It however did change one more thing. The need for gpu to be present :sad:


Here is the actual question: how can I get it to run without a gpu ? How are you guys doing it ? I don't to invest into some passive gpu that would just be eating more power, even though the disk compatibility is priceless, so far I was able to get all hw without any cost ( not counting the disk itself) in case my NAS project would fail, I can just use the disk in my desktop and "no harm done".


Point is, it was running fine with F4 bios and old disk without a gpu, with quiet cpu cooler it was noiseless and didn't eat much power, now I am not sure what to do.

I tried BIOS settings halt on no errors, actually this is how I was able to get it to run without a GPU in the first place previously.


So the goal is to be able to boot without a gpu and the rest can stay as it is, what is even better is that I am not able to qflash back, b/c the usb stick I used to flash(twice so far..) is now not loading as HDD-0 (or how it was..) but as a floppy A, even though it's showing correct space parameters (total/free space on usb stick) it's showing just "..."as for "go one folder up" but with no actual content, even though I just have two bios files there in root and nothing else, I was able to flash it twice previously, right.

So I probably just flashed the need to have a gpu, like most of the motherboards have (that's what google said, I spent a dear lot of time with that one).

Any ideas ? Thanks a lot for reading this one, pardon my english :smile:



Link to comment
Share on other sites



oh my sheet. I just suddenly realized what else changed since the flashing of the bios. I changed the loader from gnoboot to nanoboot. I realized it when I saw numlock switched on (while booting nanoboot without GPU..) so I was like maybe it's those "greeen-I don't knows-OKs" not being ok, like missing gpu.. and well, I loaded gnuboot 10.5, ALSO I HAVE the latest 4482, which can't be installed from gnoboot, right ?

Well, I hope this helps someone else.

These are the best topics, that are answered themselves, right ? :grin:

Take care guys

Link to comment
Share on other sites

  • Create New...