Recommended Posts

Да что-то я малость забыл указать все параметры, прошу прощения за это.

Начем по порядку

1. Мать Gigabyte GA-F2A88XM-D3H сетевой порт гигабитный

2. DSM 5.2.5644 Update3

[spoiler=].......

Гигабит построен для примера, на одном свиче гигабитном и к нему подключены шнурком бук, моя рабочая машина, и НАС. У всех стоит в параметрах сети гигабит а в DSM сотка. Шнурки все проверены, несколько раз менялись местами DSM 100 Мбит\с

[spoiler=]713bf4fe2976t.jpg

 

Свитч тупой Dlink 1100 серии. 8 портовый, все порты гигабитные, проверены подключением в каждый порт бук.

Нда... Очень умных мыслей у меня нет... Малый бубен и перебор.

1 Загрузить Nas с live образа Ubuntu (или др. ОС /установить windows и пр.) - попытаться понять проблема софта или железа. Как вариант если есть сетевушка отдельной платой воткнуть в Nas её и посмотреть с DSM и другой OS.

2 Обесточить все оборудование в LAN (физически вынуть на 10 минут все из розеток включая сетевые фильтры рабочего компа, NAS, кабель из LAN из бука). Кабель Lan который сейчас в NAS не использовать при тестировании. Воткнуть Кабель от бука в NAS (не меняя порты в свиче). Включить рабочую машинку и NAS. Если не помогло, то повторить опыт с ноутом.

3 Отписаться и если не решилось, то ждать др. советов.

 

Все что перечислили уже проверено, перепробовано. С любого лайф-сд или UNIX-live сетка определяется корректно 1Гбит\с, в данный момент нету под рукой сетевой карты на 1Гбит\с чтоб воткнуть ее и проверить. Думаю трабла именно в загрузчике. Думал может кто тоже сталкивался.

ЗЫ. Народ а кто отпишется на счет сетевой карты на 1Гбит\с и загрузчика DSM 5.2. У всех все нормально встала. Или это я такой криворукий))

Link to post
Share on other sites
.......

Нда... Очень умных мыслей у меня нет... Малый бубен и перебор.

1 Загрузить Nas с live образа Ubuntu (или др. ОС /установить windows и пр.) - попытаться понять проблема софта или железа. Как вариант если есть сетевушка отдельной платой воткнуть в Nas её и посмотреть с DSM и другой OS.

2 Обесточить все оборудование в LAN (физически вынуть на 10 минут все из розеток включая сетевые фильтры рабочего компа, NAS, кабель из LAN из бука). Кабель Lan который сейчас в NAS не использовать при тестировании. Воткнуть Кабель от бука в NAS (не меняя порты в свиче). Включить рабочую машинку и NAS. Если не помогло, то повторить опыт с ноутом.

3 Отписаться и если не решилось, то ждать др. советов.

Все что перечислили уже проверено, перепробовано. С любого лайф-сд или UNIX-live сетка определяется корректно 1Гбит\с, в данный момент нету под рукой сетевой карты на 1Гбит\с чтоб воткнуть ее и проверить именно в DSM. Думаю трабла именно в загрузчике. Думал может кто тоже сталкивался.

ЗЫ. Народ отпишитесь на счет сетевой карты на 1Гбит\с и загрузчика DSM 5.2. У всех все нормально встала. Или это я такой криворукий))

Link to post
Share on other sites
Обновление 5.2-5644.5 от 14/02/2016

[spoiler=VirtualBox работает]vbox1.png?psid=1

vbox2.png?psid=1

 

Можешь поделиться .vmdk а то я никак не смог установить :sad:

rauan честно вот я не понял что вы просите у народа. .vmdk Это диски для виртуальных машин. То есть у вас на реальном железе устнаволена DSM поднята Virtual Box и у вас проблемы с разворачиванием виртуалок? Тогда https://dev.windows.com/en-us/microsoft ... vms/linux/ официальные триальные windows. Неофициальные linux http://www.osboxes.org/vmware-images/ . Можно linux в официальных репозитариях смотреть. Однако лучше все ставить ручками.

Edited by Guest
Link to post
Share on other sites
[spoiler=]
.......

Нда... Очень умных мыслей у меня нет... Малый бубен и перебор.

1 Загрузить Nas с live образа Ubuntu (или др. ОС /установить windows и пр.) - попытаться понять проблема софта или железа. Как вариант если есть сетевушка отдельной платой воткнуть в Nas её и посмотреть с DSM и другой OS.

2 Обесточить все оборудование в LAN (физически вынуть на 10 минут все из розеток включая сетевые фильтры рабочего компа, NAS, кабель из LAN из бука). Кабель Lan который сейчас в NAS не использовать при тестировании. Воткнуть Кабель от бука в NAS (не меняя порты в свиче). Включить рабочую машинку и NAS. Если не помогло, то повторить опыт с ноутом.

3 Отписаться и если не решилось, то ждать др. советов.

Все что перечислили уже проверено, перепробовано.

С любого лайф-сд или UNIX-live сетка определяется корректно 1Гбит\с, в данный момент нету под рукой сетевой карты на 1Гбит\с чтоб воткнуть ее и проверить именно в DSM. Думаю трабла именно в загрузчике. Думал может кто тоже сталкивался.

ЗЫ. Народ отпишитесь на счет сетевой карты на 1Гбит\с и загрузчика DSM 5.2. У всех все нормально встала. Или это я такой криворукий))

1 С загрузчиком более ранних версий пробовали? DSM можно для начало не трогать...

2 Напишите какая у вас сетевая карта

[spoiler=][b]Bob the Builder[/b] @PRIMAS4UNO

Работает из под chroot. Chroot есть пакетом в репозитарии сообщества https://synocommunity.com/packages .

...

из под chroot работают:

  • dmidecode
  • lshw
  • hwinfo
  • Inxi

 

 

[spoiler=dmidecode из под chroot]md-e1454118575687.png

 

[spoiler=inxi -Fx]md1.png

 

Link to post
Share on other sites

С загрузчиком более ранних версий пробовали? DSM можно для начало не трогать...

На данной платформе пока не пробовал, там копирование идет на данный момент. В работе у меня еще 3 DSM/ первый это 4.3 Там все в порядке 1Гбит\с.

Две платформы DSM 5.2.5592 одна 1Гбит\с вторая 10Гбит\с, это виртуалка на ESXi.

Плюс домашние 4.3 и 5.2.5592 там тоже все в норме 1Гбит\с

Link to post
Share on other sites

[spoiler=]

2 Напишите какая у вас сетевая карта

Работает из под chroot. Chroot есть пакетом в репозитарии сообщества https://synocommunity.com/packages .

...

из под chroot работают:

  • dmidecode
  • lshw
  • hwinfo
  • Inxi

 

Вот результат команды inxi

[spoiler=]8c338164c138t.jpg

 

Вот так у меня:

 

DSM 5.2-5592 Update 4

 

Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

driver: r8169 port: d000 bus-ID: 02:00.0

IF: eth1 state: up speed: 100 Mbps duplex: full mac: 00:11:00:00:00:00

Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

driver: r8169 port: e000 bus-ID: 01:00.0

IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 00:11:00:00:00:00

 

Гигабитный свитч -гиг. 100 Мегабитный - сотка.

 

 

PS: Версию загрузчика не соображу как посмотреть...

Edited by Guest
Link to post
Share on other sites

Вот так у меня:

 

DSM 5.2-5592 Update 4

 

Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

driver: r8169 port: d000 bus-ID: 02:00.0

IF: eth1 state: up speed: 100 Mbps duplex: full mac: 00:11:00:00:00:00

Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

driver: r8169 port: e000 bus-ID: 01:00.0

IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 00:11:00:00:00:00

 

Гигабитный свитч -гиг. 100 Менабитный - сотка.

 

 

PS: Версию загрузчика не соображу как посмотреть...[/size]

 

Мои сетевые данные

Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

driver: r8168 port: e000 bus-ID: 01:00.0

IF: eth0 state: up speed: 100 Mbps duplex: full

mac: 00:11:00:00:00:00

 

Версию можно глянуть при перезагрузке, если локально подключиться можно.

Так я же говорю все подключено к гигабитному свичу, я уже года три как все перевел на гигабит. что дома что на работе. а тут засада какая то. Ладно домашнюю вечером протестирую, там мать такая же. может чего найду, отпишусь.

Link to post
Share on other sites

....

Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

driver: r8169 port: e000 bus-ID: 01:00.0

IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 00:11:00:00:00:00

Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

driver: r8168 port: e000 bus-ID: 01:00.0

IF: eth0 state: up speed: 100 Mbps duplex: full

mac: 00:11:00:00:00:00

Вижу что разные. Что это значит не знаю.

Из странных фантазий - если для мамы несколько прошивок bios можно с ними поиграться.

 

PS

Card-2:eth0 state: up speed: 1000 Mbps duplex: full

Card:eth0 state: up speed: 100 Mbps duplex: full

Так я же говорю все подключено к гигабитному свичу, я уже года три как все перевел на гигабит.

Я не по умничать - просто хотел пояснить что на маме две встроенные сетевушки и одна подключена к свичу на 1000, а другая на 100.

Link to post
Share on other sites

....

Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

driver: r8169 port: e000 bus-ID: 01:00.0

IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 00:11:00:00:00:00

Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

driver: r8168 port: e000 bus-ID: 01:00.0

IF: eth0 state: up speed: 100 Mbps duplex: full

mac: 00:11:00:00:00:00

 

А вам не кажется это странным что чипы одни, но в вашем варианте используется драйвер 8169, а в моем 8168 драйвер???

 

 

Card-2:eth0 state: up speed: 1000 Mbps duplex: full

Card:eth0 state: up speed: 100 Mbps duplex: full

 

Так я же говорю все подключено к гигабитному свичу, я уже года три как все перевел на гигабит.

 

Я не по умничать - просто хотел пояснить что на маме две встроенные сетевушки и одна подключена к свичу на 1000, а другая на 100.

 

Я прекрасно понял что у вас задействованы две сетевые карты, одна на 100 вторая на 1000 Мбит\с. На работе сижу малость отвлекли.

Link to post
Share on other sites

...

А вам не кажется это странным что чипы одни, но в вашем варианте используется драйвер 8169, а в моем 8168 драйвер???

...

Это-то я понял. Я не понял поможет ли это вам сделать гигабит. Т.к. тут все в кучу xpenology, dsm, chroot debian... Моих знания Linux недостаточно. Но учитывая, что вы админите такую кучу серверов, то может вам понятней.

Link to post
Share on other sites

...

А вам не кажется это странным что чипы одни, но в вашем варианте используется драйвер 8169, а в моем 8168 драйвер???

...

Это-то я понял. Я не понял поможет ли это вам сделать гигабит. Т.к. тут все в кучу xpenology, dsm, chroot debian... Моих знания Linux недостаточно. Но учитывая, что вы админите такую кучу серверов, то может вам понятней.

Ну вот я как раз сейчас и смотрю, сравниваю драйвера 8169 8168. Если что узнаю сразу тут отпишусь.

Link to post
Share on other sites

r8168 : RTL8168B/8111B, RTL8168C/8111C, RTL8168CP/8111CP, RTL8168D/8111D, RTL8168DP/8111DP, and RTL8168E/8111E
r8169 : RTL8169S/8110S, RTL8169SB/8110SB, and RTL8110SC.

r8169 это Linux драйвер для сетевых чипов Realtek

а r8168 официальный/общий драйвер Realtek

 

Your answer is in the sentence :

add rmmod=r8169 to grub or syslinux.cfg in order to unload r8169 driver and force r8168.

This will unload r8169 driver and let r8168 to handle your card.

Linux Realtek drivers are shit :sad:

The old shitty r8169 driver from the kernel will be removed and replaced by the "new" r8169 from realtek web site in the next release.

Like I said before 5644.4 include "new" r8169 driver. It shouldn't create conflict with r8168/r8101 like the one present on previous releases.

в 5644.4 добавили новый modul/driver r8169_new.ko

driv.png

попробуйте добавить в загрузчик:

rmmod=r8169

LABEL xpenology
      MENU LABEL XPEnology DSM 5.2-5644
      KERNEL /zImage
      APPEND root=/dev/md0 ihd_num=0 netif_num=4 syno_hw_version=DS3615xs sn=xx mac1=xx vid=0x0EA0 pid=0x2168 loglevel=0 vga=0x305 rmmod=r8169

 

или

rmmod r8169
insmod /lib/modules/r8168.ko

или

rmmod r8169
insmod /lib/modules/r8169_new.ko

Link to post
Share on other sites
r8168 : RTL8168B/8111B, RTL8168C/8111C, RTL8168CP/8111CP, RTL8168D/8111D, RTL8168DP/8111DP, and RTL8168E/8111E
r8169 : RTL8169S/8110S, RTL8169SB/8110SB, and RTL8110SC.

r8169 это Linux драйвер для сетевых чипов Realtek

а r8168 официальный/общий драйвер Realtek

 

Your answer is in the sentence :

add rmmod=r8169 to grub or syslinux.cfg in order to unload r8169 driver and force r8168.

This will unload r8169 driver and let r8168 to handle your card.

Linux Realtek drivers are shit :sad:

The old shitty r8169 driver from the kernel will be removed and replaced by the "new" r8169 from realtek web site in the next release.

Like I said before 5644.4 include "new" r8169 driver. It shouldn't create conflict with r8168/r8101 like the one present on previous releases.

в 5644.4 добавили новый modul/driver r8169_new.ko

driv.png

попробуйте добавить в загрузчик:

rmmod=r8169

LABEL xpenology
      MENU LABEL XPEnology DSM 5.2-5644
      KERNEL /zImage
      APPEND root=/dev/md0 ihd_num=0 netif_num=4 syno_hw_version=DS3615xs sn=xx mac1=xx vid=0x0EA0 pid=0x2168 loglevel=0 vga=0x305 rmmod=r8169

 

или

rmmod r8169
insmod /lib/modules/r8168.ko

или

rmmod r8169
insmod /lib/modules/r8169_new.ko

 

Спасибо, я это тоже нарыл уже. Но так как машина была на работе а по удаленке не очень хотелось что-то делать оставил до утра. Сейчас проведу тест и отпишусь.

Link to post
Share on other sites

Доброе утро дорогие форумчане.

Простите меня грешного. Ввел я вас в заблуждение касаемо скорости.

У меня оказалась банальней. Мои коллеги шутники подсунули кабель с битой шиной. Он сам по себе работает на 100 Мбит\с, а когда проверял подсовывали исправный. А выявил я это тогда когда сегодня кроме меня на работе не кого нету, запустил еще раз live-CD и увидел что скорость не 1 Гбит\с а 100 Мбит\с. Хотя точно помню что проверял все было нормально. Воткнул другой кабель 1Гбит\с, загрузил DSM скорость гигабит. Придут коллеги прибью.

Так что все нормально со скоростью, и сетевыми картами. Не каких шаманств не надо.

ЗЫ. Коллеги живы просто поржали

Link to post
Share on other sites

Сегодня прилетело

Version: 5.2-5644 Update 5

 

(2016/02/19)

Fixed Issues

Updated Firewall filter policy to fix a security vulnerability caused by stack-based buffer overflow (CVE-2015-7547). This fix may impact read/write performance on the following models by no more than 15%, for which Synology is working on an enhancement in the future release.

16-series: DS216se

15-series: DS115j

14-series: EDS14, DS114, DS214se, RS214, DS414slim

13-series: DS213j, DS213air, DS213, DS413j

12-series: DS112, DS112+, DS112j, DS212, DS212j, DS212+, RS212, RS812

11-series: DS111, DS211, DS211+, DS211j, DS411, DS411slim, DS411j, RS411

10-series: DS110j, DS210j, DS410j

 

 

Соответственно, кто ставил? Безопасно?

Link to post
Share on other sites
Сегодня прилетело

Version: 5.2-5644 Update 5

 

(2016/02/19)

Fixed Issues

Updated Firewall filter policy to fix a security vulnerability caused by stack-based buffer overflow (CVE-2015-7547). This fix may impact read/write performance on the following models by no more than 15%, for which Synology is working on an enhancement in the future release.

16-series: DS216se

15-series: DS115j

14-series: EDS14, DS114, DS214se, RS214, DS414slim

13-series: DS213j, DS213air, DS213, DS413j

12-series: DS112, DS112+, DS112j, DS212, DS212j, DS212+, RS212, RS812

11-series: DS111, DS211, DS211+, DS211j, DS411, DS411slim, DS411j, RS411

10-series: DS110j, DS210j, DS410j

 

 

Соответственно, кто ставил? Безопасно?

Произвел обновление до update 5. Полет пока нормальный, копирование в 100 Гигов с раздела на раздел, с раздела в сеть, с сети на раздел. Много поточное копировании копирование всюду одновременно машинку не положило, сеть не упала. из пакетов не чего не тестировал. так как в работе мне надо тупо файловое хранилище. Нагрузка на процессор и память не большая. Единственное что заметил в браузере Firefox выскакивает окно о предложении остановить сценарий. До этого как то не обращал внимание.

Link to post
Share on other sites

Обновление iptables а точнее добавление netfilter модуля смущает только файлы /usr/syno/selfcheck/ - 4 файла

Так понимаю это что то похожее на сравнение файлов или аксесс листа для разрешения модулей и на защиту не должно оказать влияния. Содержат информацию о контрольных суммах и правах.

Link to post
Share on other sites
Доброе утро дорогие форумчане.

Простите меня грешного. Ввел я вас в заблуждение касаемо скорости.

У меня оказалась банальней. Мои коллеги шутники подсунули кабель с битой шиной. Он сам по себе работает на 100 Мбит\с, а когда проверял подсовывали исправный. А выявил я это тогда когда сегодня кроме меня на работе не кого нету, запустил еще раз live-CD и увидел что скорость не 1 Гбит\с а 100 Мбит\с. Хотя точно помню что проверял все было нормально. Воткнул другой кабель 1Гбит\с, загрузил DSM скорость гигабит. Придут коллеги прибью.

Так что все нормально со скоростью, и сетевыми картами. Не каких шаманств не надо.

ЗЫ. Коллеги живы просто поржали

:twisted: Зажарить и съесть коллег!

Link to post
Share on other sites
Единственное что заметил в браузере Firefox выскакивает окно о предложении остановить сценарий. До этого как то не обращал внимание.

 

Firefox стал прожорлив и зачастую ему мало оперативки. Как правило, в большинстве случаев, лечится простой настройкой.......

Инструменты - Дополнения - Плагины - Shockwave Flash - Включать по запросу

1cdec8921cfa0283e65d75363f830fdf.jpg

Link to post
Share on other sites
Единственное что заметил в браузере Firefox выскакивает окно о предложении остановить сценарий. До этого как то не обращал внимание.

 

Firefox стал прожорлив и зачастую ему мало оперативки. Как правило, в большинстве случаев, лечится простой настройкой.......

Инструменты - Дополнения - Плагины - Shockwave Flash - Включать по запросу

1cdec8921cfa0283e65d75363f830fdf.jpg

Я думаю что 16 гигов оперативы ему должно хватать. Ну или он подавился :grin:

Link to post
Share on other sites
Доброе утро дорогие форумчане.

Простите меня грешного. Ввел я вас в заблуждение касаемо скорости.

У меня оказалась банальней. Мои коллеги шутники подсунули кабель с битой шиной. Он сам по себе работает на 100 Мбит\с, а когда проверял подсовывали исправный. А выявил я это тогда когда сегодня кроме меня на работе не кого нету, запустил еще раз live-CD и увидел что скорость не 1 Гбит\с а 100 Мбит\с. Хотя точно помню что проверял все было нормально. Воткнул другой кабель 1Гбит\с, загрузил DSM скорость гигабит. Придут коллеги прибью.

Так что все нормально со скоростью, и сетевыми картами. Не каких шаманств не надо.

ЗЫ. Коллеги живы просто поржали

:twisted: Зажарить и съесть коллег!

Ну да они такие с юмором. Не чего я им все телевидение испорчу будут знать)

ЗЫ. Это касается серверов видеонаблюдения. Зуб за зуб, пачкорд за пачкорд :twisted:

Link to post
Share on other sites

Завёл 5.2-5644.5

Всё как обычно прекрасно завелось, но загрузочная флэшка не спряталась.

VID/PID перепроверял. Номер подхватывается из syslinux.cfg, mac-адреса подхватываются. Флэшка не прячется.

 

Попробовал другую флэшку, всё вроде бы корректно вписал. Не спряталась.

Автоматически монтирует USBshare1 - и всё тут.

 

Кто-нибудь с таким сталкивался?

Link to post
Share on other sites
  • XPEH locked this topic
Guest
This topic is now closed to further replies.