Recommended Posts

Это очень хорошая новость у меня самого были мысли попробовать. Вещь нужная ! Хоть вилдкарт и стоит от 50$ всё же лучше если бесплатно :smile:

Обновление и перевыпуск то же работает? Они пока в тестовом режиме поэтому по 3 мес. Позже увеличат.

Link to post
Share on other sites

В настройках DSM есть автоматически перенапрявлять http в https и HSTS

а чем это отличается? если и то и то будет принудительно отправлять на https даже если вводишь http

Link to post
Share on other sites

Перенаправление апачем с .htaccess или nginx-ом отличается от самой технологии многим, и к SSL никакого отношения не имеет кроме переадресации хоть на 7777 порт

Link to post
Share on other sites

да это я понимаю что к ssl не относиться, просто есть две одинаково работающих галки в настройках - вопрос в чем разница для пользователя, подключающегося к насу

Link to post
Share on other sites

ставь обе, для совместительства со старыми браузерами, перенаправление все понятно, а HSTS принудительное использование https, без первоначальной http сессии. Еще и само шифрование в настройках веб сервера можно поменять а так же использовать SNI - прикольная штука позволяет экономить IPшники

Link to post
Share on other sites

Еще HSTS помогает от http флуда когда кто-нибудь пытается просадить ваш сервер такой атакой, но тут более эффективны модули для веб сервера ограничивающие подключения для сессий, полезно при ddos и dos атаках, но от хорошего ddos мало эффективны даже такие как CSF (хотя по отзывам держит атаки до 50гб/с) все что выше аппаратный "арбор" лучше вроде нет, блатная штука и дорогая, ничего подобного pf, ipfw, iptables сдавать не получится, хотя то же не помешает но есть риск забанить нормальных юзеров, что не есть хорошо. Даже видел тех что целые подсети в бан, такими скриптами

Edited by Guest
Link to post
Share on other sites

отличие в том что когда стоит галка на "автоматически перенапрявлять http в https" то весь доступ к насу принудительно перенаправляется в https, что приводит к тому что браузер ругается на другие домены доступа допустим из локалки

 

а когда активирована только "HSTS" то перенаправляется только тот домен к которому прикреплён сертификат, браузер распознаёт что у домена есть два протокола и по умолчанию всегда включает https, при этом доступ с других доменов без https к насу проходит как и обычно по http

 

я например остановился пока на такой настройке по таким причинам:

  • браузеры не ругаются
  • страницы где допустим через vlc плагин проигрывается тв каналы с этого же сервера,не то что тормозят а и вообще не открываются через https
    ругается на то что vlc плагин использует ссылку на плейлист, а это уже другой источник и тем более не защищённый

[spoiler=значит работает зараза :smile:]sslfrei16.png

 

 

sslfrei13.png

 

https://gethttpsforfree.com ещё один ресурс

Link to post
Share on other sites

Здравствуйте!

На рабочей DSM_DS3615xs_5592 Update 2 решил обновится до последней версии, установил на флешку новый загрузчик(5.2-5644.4), после этого через Migrate установил DSM_DS3615xs_5644, но после завершения установки DS не видно в сети. Если принудительно перезагрузить сервер, тогда приходит уведомление на почту, что DS подключена к ИБП и все. При самой загрузке на мониторе все "ок" все загружается нормально.

Еще заметил, что после перезагрузки в течении 2-3 секунд есть реакция сервера на клавиатуру, а потом он как бы зависает и уже перестает реагировать на нажатия.

Пытался вернутся назад на 5592, но через Migrate не дает.

 

Что здесь можно предпринять? Как вернуть систему к жизни?

 

UPD: Только что получилось загрузить систему на 5.2-5644.4 со старым загрузчиком XPEnoboot_DS3615xs_5.2-5592.2.

Ничего не понимаю :shock:

 

В английской ветке пишут про новый загрузчик : - Time Backup works and don't freeze the system at boot,

а у меня как раз стоит Time Backup.

Может его удалить чтоб система могла запускаться с нового загрузчика ?

 

UPD2: Удалил Time Backup и все заработало с последним загрузчиком, получается сам с собой поговорил :grin::grin::grin:

 

Удалять пост не буду, вдруг кому пригодится.

Link to post
Share on other sites
Здравствуйте!

 

UPD2: Удалил Time Backup и все заработало с последним загрузчиком, получается сам с собой поговорил :grin::grin::grin:

 

Удалять пост не буду, вдруг кому пригодится.

 

Вчера при установке Time Backup сервер сразу завис. пришлось опять сносить системный раздел и ставить с 0.

 

Кстати вопрос к знатокам.

Вчера на Ubuntu подцепил все разделы.

Но не видно системного.

Можно как нибудь его все таки увидеть там?

 

P.S. iLo на HP вещь!!!

Link to post
Share on other sites
Вчера при установке Time Backup сервер сразу завис. пришлось опять сносить системный раздел и ставить с 0.

 

Получается кто попал точно так же при установке Time Backup, не обязательно сносить все и ставить с нуля, достаточно поставить на флешку старый загрузчик 5.2-5592.2, запустить систему и удалить Time Backup стандартным способом, через Web интерфейс DSM.

Потом нужно поменять загрузчик на флешке на последнюю версию, перезагрузится и все будет работать нормально.

Link to post
Share on other sites
Вчера при установке Time Backup сервер сразу завис. пришлось опять сносить системный раздел и ставить с 0.

 

Получается кто попал точно так же при установке Time Backup, не обязательно сносить все и ставить с нуля, достаточно поставить на флешку старый загрузчик 5.2-5592.2, запустить систему и удалить Time Backup стандартным способом, через Web интерфейс DSM.

Потом нужно поменять загрузчик на флешке на последнюю версию, перезагрузится и все будет работать нормально.

 

У меня при загрузке со старым загрузчиком происходила перезагрузка циклическая.

 

Конечно нервов потрепал мне сервер )))

За то я теперь умею использовать iLo )

Из данных потерял только хеши Transmission

Переустановил поверх и затерлись папки.

Надо было сохранить папку resume )

Ну да ладно, в Новом Году с новыми торрентами

 

 

UPD

Совсем забыл сказать. Теперь в отсеке под ODD крутится SSD Sandisk Ultra II на 240Gb в качестве SSD Cache на чтение.

[spoiler=Скриншот SSD Cache]b035f49ec0d56d88296b82db0d41c159.png

 

Link to post
Share on other sites

Может мне тоже кто нибудь подскажет в чем дело:

 

У меня система на двух дисках по 2 Тб в Raid1, всего места на разделе 1863 ГБ, на этот раздел резервируются фото и видео с домашнего компьютера через Cloud Station, общий объем этих папок 184 ГБ, плюс две камеры с лимитом записи по 100 ГБ, плюс музыка и резервные копии файлов с телефонов 110 ГБ, итого мои файлы должны занимать 466 ГБ, ну плюс приложения там всякие, но они не должны занимать много места. Торренты качаются на отдельный диск.

На данный момент на диске занято 1.38 ТБ.

 

Вопрос: куда делось столько свободного места, неужели это преобразование файлов в Photo Station виновато?

Edited by Guest
Link to post
Share on other sites
....резервируются фото и видео с домашнего компьютера через Cloud Station....

Ключевое место Cloud Station. Смотрите сколько копий резервирует Cloud Station

Link to post
Share on other sites
....резервируются фото и видео с домашнего компьютера через Cloud Station....

Ключевое место Cloud Station. Смотрите сколько копий резервирует Cloud Station

 

Спасибо вроде помогло, зашел в CloudStation и установил количество версий - 2 ( ранее было 38), почистил базу данных версий и на разделе стало доступно около 1 ТБ,

еще и Photo Station изображения кэширует, так что я думаю это нормально.

Можно ли установить количество версий 0 ?

 

Еще зашел через WinSCP на DiskStation, в корне много системных папок, из них в папке "proc" нашел большой файл ''kcore'', который весит около 135 ГБ, что это такое?

Link to post
Share on other sites

http://xpenology.com/forum/viewtopic.php?f=2&t=5026&start=1650#p51437

 

Re: XPEnoboot 5.2-5644.4 (23/12/2015)

Сообщение Trantor » 31 дек 2015 20:20

 

We found an issue in the kernel config that causes all this problems.

 

More testing is needed but there are good news:

- iSCSI block works

- iSCSI file works but without advanced features

- Time Backup works and don't freeze the system at boot

- VirtualBox package works (VMs run without segfault)

 

Maybe this will also fix dvb issues. (no adapter to test)

Edited by Guest
Link to post
Share on other sites
Вчера при установке Time Backup сервер сразу завис. пришлось опять сносить системный раздел и ставить с 0.

UPD

Совсем забыл сказать. Теперь в отсеке под ODD крутится SSD Sandisk Ultra II на 240Gb в качестве SSD Cache на чтение.

[spoiler=Скриншот SSD Cache]b035f49ec0d56d88296b82db0d41c159.png

А смысл такой большой под кеш ставить, я ставил 60гб и то ни разу не видел что бы он забивался, вот думаю поставить второй на 60гб для кешазаписи

Link to post
Share on other sites
Вчера при установке Time Backup сервер сразу завис. пришлось опять сносить системный раздел и ставить с 0.

UPD

Совсем забыл сказать. Теперь в отсеке под ODD крутится SSD Sandisk Ultra II на 240Gb в качестве SSD Cache на чтение.

[spoiler=Скриншот SSD Cache]b035f49ec0d56d88296b82db0d41c159.png

А смысл такой большой под кеш ставить, я ставил 60гб и то ни разу не видел что бы он забивался, вот думаю поставить второй на 60гб для кешазаписи

 

Была возможность купить 2 штуки по 240

но для второго нет места (

Link to post
Share on other sites
4528 работает на последнем nanoboot 4.1, позже уже xpenoboot реализовали совместными усилиями, а что у за проц ?

Оказалось все у меня работает как надо. Я когда прикручивал материнку в корпус - забыл поменять проц. Двухъядерник остался лежать на столе :sad:

Link to post
Share on other sites
Там вроде в справке по ssd система должна сама все посчитать и сказать какой по объему диск нужен.

тоже заглянул. система чего то там пережовывала минут 10 и насчитала мне:

kSK5U3Tn

я решил что она слишком много хочет!

и ограничился 128гб.

через сутки картинка имеет вид:

a1I3g5fN

система стала заметно веселее :smile:

Link to post
Share on other sites
  • XPEH locked this topic
Guest
This topic is now closed to further replies.