• 0
Sign in to follow this  
Silver Fang

How to connect to NAS outside home

Question

Hi,

I have set up VPN server in my Asus RT-AC-1900U router, PPTP with user name and password.

And it shows me what VPN server address to be used when connecting it from phone etc.

 

On my android phone Honor 8, I can get VPN to be connected.

But how do I connect to DS Photo or DS Video, do I need to enable anything on DSM?

Using the same IP address works when im home, but not when outside, do I need to use another IP when im outside?

 

Thanks in advance

 

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Uuuh... PPTP - the weakest VPN solution. I would rather setup the VPN-Server package in DSM and use OpenVPN. It‘s no miracle and much more secure than PPTP. Only thing to do on your router is to open the corresponding port (usually 1194 UDP) for DSM (NAT rule/port forwarding). You can decide if users can connect only to the NAS or the entire subnet.

Share this post


Link to post
Share on other sites
  • 1

Was trying to connect with my iPhone and iPad but couldnt see PPTP option.

After some googling I read it was removed after IOS 10, and PPTP is not secure.

 

Back to the Asus router and enabled OpenVPN instead, exported the config file, downloaded OpenVPN Connect app to iPhone and Honor 8, imported the config file and now its working fine 😃

 

Thanks so much for all the help, appreciate it alot, learning new things too 😃

 

Share this post


Link to post
Share on other sites
  • 0

I use the built-in FritzVPN at my Fritzbox 7590. When I connect me from outside with an Android Phone per VPN (IPSec Xauth PSK) I don't need change or use  IPs to connect with DSM or with Apps at Synology (e.g. DSNotes, Caldav, Carddav,...). I use the same ports from outside and I haven't transfer any Ports in my Fritzbox.

 

I can't say anything about your VPN-Solution at your Asus-Router. I think one advantage of using VPN from outside is that your status is as your are at home (in your home-net).

 

Sorry for my bad english.

Share this post


Link to post
Share on other sites
  • 0
The question(s) in this topic have been answered and/or the topic author has resolved their issue. This topic is now closed. If you have other questions, please open a new topic.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this