Recommended Posts

Hello guys, my bios on my N54l keeps loosing its settings when i restart xpenology.

i dont know if this has been posted before. i appologise if its a duplicate.

how do i write protect the bios or is there altenate bios to use.

 

Please help.

Link to post
Share on other sites

Really sorry about that. but thanks alot the other posts werent clear.

when you say NOT any schedule. is that like anything or only power.

would like to have smart running. but really appreciate the feedback,

 

Sorry please excuse my ignorance just want to make 100% sure

the settings should stick after disabling schedules.. ?

Link to post
Share on other sites

Hi!

 

You can use sheduled task (custom script/smart check). It is safe. These action only modify /etc/crontab file, you can check it via "vi" command.

 

Do not use sheduled poweroff or wakeup. These requires changing bios parameters and synology bios is not the same as n40/n54 bios, thus you will get reset issue.

Link to post
Share on other sites

Thanks. thats great wasnt using the power feature anyways only the smart. but its good to know. thanks for the info guys...

 

in other words DON'T use the power features...

 

although im still curious why it modifies the settings in the bios which don't use power settings ..

or does it just corrupt ur bios then replace a original copy .. ?

Link to post
Share on other sites

It's trying to write stuff to a SYNOLOGY BIOS

 

which the N54L isn't..../ cant / so it screws it up when attempting to do so.

 

eg

 

Real Synology bios probably has something / a setting etc to allow you to shut down the NAS.... then wake it back up at a certain time

 

eg only turn on between 5PM and 11PM.....then turn back off again.

 

N54L doesn't have this capability....along with other Synology capabilities..... which if you want / need you are best purchasing a REAL Synology.

 

If not and your happy with the N54L, then you have to also put up with some short comings from paying a cheaper price

 

.

Link to post
Share on other sites

stanza

 

oringially posted on another thread 17 Feb 2014 16:29

but no reply so far

 

I have installed the firmware [XPEnology DS3612xs DSM 4.2 build 3211++ (repack v1.2)] since Sep 2013 on a HP54L (only one hp54l on the lan and I don;t change MAC/serial no)

but one great issue annoy me without solution-the NAS disappear regularly (around once each month)

without any response

and I can only turn off and turn on again to regain access. I am horrified and worried about data loss

 

Original I plugin an additional Intel Pro 1000 PT Dual Port Server NIC during the install

after the machine hang after 1 week time for twice, I remove the card

it is better but still hang up almost every month

any idea to fix that

should I reinstall the whole thing

(i worry about wrap out all my server data and photos as I don;t have >2TB HD to backup again the 4x1TB raid)

 

Any hint why the NAS disappear regularly or should I just upgrade!!!

any other has similiar experience

 

Speedhk

Link to post
Share on other sites
  • 3 weeks later...

I had the same problem with my n54l and xpneology. I had auto shutdown\powerup configured and every time the system starts the date and other settings for achpi settings were getting overwritten. I was trying few things together but seems like the issue is resolved after that. Not exactly sure which one of the below action resolved the issue.

 

1. I deleted the power options for shutdown\powerup.

2. Made changes to .conf file for WOL.

3. Made changes to the conf files for eSata changes.

4. Made bios password protected.

 

Now i dont have the bios reset issue :smile:. trying to fix couple of other issues and i am done :geek:

 

1. WOL works within my home network but not from outside the network.

2. eSata got identified after the conf file changes but it made my sata hdd connected (volume2) not recognize even though the hdd is detected in bios and all settings are proper. xpneology was not detecting the hdd connected to the sata port. So i had to revert the esata conf changes for hdd to detect in xpneology.

 

Jay

Link to post
Share on other sites
On my N54L I can do WOL and timed power down and without resetting the bios.

 

I believe it's not the timed shutdown..... but the timed wakeup / turn on that causes the problem.

 

eg REAL synology has a spesh bios that can be configured to turn on at ZYZ time.......which naturally the Microserver doesn't.....and as such with it trying to modify that AREA of the bios on the microserver causes the issue.

 

.

Link to post
Share on other sites
  • 3 weeks later...
I had the same problem with my n54l and xpneology. I had auto shutdown\powerup configured and every time the system starts the date and other settings for achpi settings were getting overwritten. I was trying few things together but seems like the issue is resolved after that. Not exactly sure which one of the below action resolved the issue.

 

1. I deleted the power options for shutdown\powerup.

2. Made changes to .conf file for WOL.

3. Made changes to the conf files for eSata changes.

4. Made bios password protected.

 

Now i dont have the bios reset issue :smile:. trying to fix couple of other issues and i am done :geek:

 

1. WOL works within my home network but not from outside the network.

2. eSata got identified after the conf file changes but it made my sata hdd connected (volume2) not recognize even though the hdd is detected in bios and all settings are proper. xpneology was not detecting the hdd connected to the sata port. So i had to revert the esata conf changes for hdd to detect in xpneology.

 

Jay

 

Hi how could you make the bios password protected?

I avoid to use auto wake up and looks like it is working fine but would like to secure the bios settings

Link to post
Share on other sites