Jump to content
XPEnology Community

Chose which DSM version to boot?


Recommended Posts

Hey all


In order for you to better understand my setup let me do a quick recap.


1. Been running XPenology Trantor's 4.1 for over a year with the main volume being 3x 1TB in SHR (raid 5).

2. I recently added 2x 4TB drives, created a disk group with the two drives and then a volume (volume2 - SHR raid 1).

3. Wanting to upgrade to DSM 5.0 i first backed up what i wanted to keep from volume1 onto volume2.

4. Unplugged the 2 4TB drives (My thinking was to set aside the data in case the update goes wrong, i had been waiting to get these drives specifically to upgrade!)

5. Installed DSM 5.0 using gnoboot.

6. I wasn't able to "Migrate" during the install but the data/shares on my volume1 are still intact and accessible. 5.0 working great!


Here's where it gets interesting :grin:


7. Plugged the 2x 4TB back in.

8. With the 2x 4TB plugged in, still using the same gnoboot usb key, it nows boot into my OLD 4.1 install!

9. Wondering what happened to the 5.0 install i unplugged the 4TBs again and what do you know the 5.0 install works just fine.


So i can effectively boot one or the other now but is there a way to control on which disk or volume to boot on? I'm assuming the bootable kernel looks for the most recent version on the disks and boot that one? I was hoping to keep the data on both volumes for a while in case something goes wrong with this 5.0 install.


I think next time i want to do something like this i'll just add a disk but initialize it and then mount and copy to it using ssh, what do you think?

Link to comment
Share on other sites

Kind of solved.


I installed Trantor's 4.3 beta7 + update 2 on volume1. Did a clean installation over 5.0 4458.


With 4.3 running great i then plugged in the 2 4TB drives (now that's where it would boot to the DSM installation that was present on the 4tb volume when i tried gnoboot) but with Trantor's it booted onto my recently installed 4.3!


Upon booting, DSM immediately recognized volume2 and mounted the share i had created on it.




Clicked on repair and i was done.




This is exactly how i wanted it to behave so i'm pretty happy about that :razz: Too bad i won't be using 5.0 but that's fine.

Link to comment
Share on other sites

  • Create New...