Sign in to follow this  
Silver Fang

High CPU usage with Plex

Recommended Posts

Hi,

When I play the movie below on DS Video Station on my iPad Mini 4, CPU reach maximum 30%.

But when same movie is played on Plex, it reach 97%.

What could be wrong with my settings, I have not changed anything on the setting?

Any transcoding I must enable or so?

 

Have the latest Plex on my NAS, 1.15.4994, 64 bit.

 

Thanks in advance 

 

My NAS:

Case: Chieftec Compact Series IX-01B Mini-ITX

PSU: Chieftec AC Power Adapter CDP-085ITX 85W

Motherboard: ASRock J4105-ITX - Intel Gemini Lake - Intel Onboard CPU socket - DDR4 RAM - Mini-ITX

Memory: Corsair Vengeance SO-DIMM DDR4 2400MHz 2x4GB (CMSX8GX4M2A2400C16)

Hard drive: Seagate Barracuda ST4000LM024 128MB 4TB

USB stick: SanDisk USB 3.1 Ultra Fit 16GB

7EDB30D7-02A4-40A3-BBEE-A279EE54DA70.jpeg

Edited by Silver Fang

Share this post


Link to post
Share on other sites

Played the same movie on my Intel NUC with Intel Core i5 8259U and the CPU only reach max 2%.

Both Intel NUC and iPad Mini 4 is played with Plex player/app and through wi-fi.

 

See the setting on Plex Transcoder below.

 

AAB05257-25B2-4E33-ABB2-3883A95FC585.jpeg

Share this post


Link to post
Share on other sites
22 минуты назад, Silver Fang сказал:

Any transcoding I must enable or so?

You need Plex pass to activate hw trancoding in the Plex.

Share this post


Link to post
Share on other sites
3 minutes ago, Olegin said:

You need Plex pass to activate hw trancoding in the Plex.

 

Will it solve my problem if I have Plex Pass?

I thought the CPU was powerfull enough to handle it.

Share this post


Link to post
Share on other sites
10 часов назад, Silver Fang сказал:

Will it solve my problem if I have Plex Pass?

Скрытый текст

1737208827_.thumb.png.27783324f331e3dd72ef05e1651aac24.png

Скрытый текст

900648902_.thumb.png.81cfd373a2f6926964e6d243636e8034.png

Feel the difference...

Share this post


Link to post
Share on other sites

Before the plex pass, you'll first need a real Synology serial number to populate dev/dri folder and enable hardware transcoding, or it won't work at all. There's no generator, use one of your own serial if you have a unused real syno, buy a cheap used one just for this purpose or find one by trials and errors. Then, you'll need to migrate or reinstall your system again with the new serial, it won't work just by changing it in the grub file and rebooting.

Share this post


Link to post
Share on other sites
1 hour ago, pmchan said:

Before the plex pass, you'll first need a real Synology serial number to populate dev/dri folder and enable hardware transcoding, or it won't work at all. There's no generator, use one of your own serial if you have a unused real syno, buy a cheap used one just for this purpose or find one by trials and errors. Then, you'll need to migrate or reinstall your system again with the new serial, it won't work just by changing it in the grub file and rebooting.

 

I cant used the same serial number as the one I used to install ?

I mean the same serial number  everyone probably is using?

Can the serial be from any Synology or it must be from 918+?

 

Is there any tutorial on how to migrate the serial number?

Im already transferring files to the NAS and have Video Station set up good, just need to work on Plex and the transcoding.

Dont want to reinstall everything and start over.

 

Edited by Silver Fang

Share this post


Link to post
Share on other sites

Take a look at Olegin's "How to" (link in his signature) guide regarding software and hardware transcoding. Hardware transcoding only works with a legit serial number but it doesn't have to be a DS918+ one, you can use SN of an old syno for example. You say Videostation is set up good, does HW transcoding working when checked in settings? Check with ssh if "dev/dri" folder is populated (Olegin's link explains how to).

 

Look at Polanskiman tutorial, "Note4:" section for grub modification at boot, basically, just hit "c" key when USB boots and proceed as he explained.

 

Edited by pmchan

Share this post


Link to post
Share on other sites
2 hours ago, pmchan said:

Text
 

What is the password for admin?

I never added a password for that account.

I only set username and password for the account I use to login to DSM.

I enabled SSH service in DSM.

On windows 10, im using putty.

 

The serial and mac, I already edited with a number I got from this site before I flashed the image to the usb-memory.

 

 

Thanks in advance

Edited by Silver Fang

Share this post


Link to post
Share on other sites

I don't think most of the serial number/mac advice is required for plex hardware assisted transcoding. You likely need it for the bundled apps, but not for plex.

Also, 100% CPU usage is not an issue with Plex. It will work hard, 100%, to transcode till the buffer is full, then it will drop and throttle. This is expected plex behaviour for software transcode.

 

 

 

 

Share this post


Link to post
Share on other sites

Got it to work by:

 

Enabled SSH in DSM (NAS).

Enabled Admin user in DSM (NAS).

Downloaded PUTTY to Windows 10.

Opened PUTTY and entered the IP address from the NAS, and press open to enter the NAS.

Login as: admin

Password: I set a new password when enabled admin user account in DSM.

Paste with right click/Enter:

cd /dev/dri

Paste with right click/Enter:

cat /usr/syno/etc/codec/activation.conf

Results was below:

{"success":true,"activated_codec":["mpeg4part2_enc","h264_dec","h264_enc","mpeg4part2_dec","aac_dec","aac_enc","vc1_dec","vc1_enc","hevc_dec","ac3_dec"],"token"                           :"26e42f20ea913ecb6237e691394c6d77"}

 

 

Share this post


Link to post
Share on other sites

I'm kind of digging up on this but does someone tried HW transcoding on a VM? Does it work well or not worth the shot? They said it's not supposed to work on the Plex website but I'm curious.

 

Thank you ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this