qwert_wayne

DSM on Virtual Server

Recommended Posts

Hello there,

 

I successfully installed DSM 6.2 (loader 1.03b) on qemu on my laptop. I use the following line to start the virtual machine:

qemu-system-x86_64 -drive if=none,id=stick,file=synoboot1.qcow2,format=qcow2 -device nec-usb-xhci,id=xhci -device usb-storage,bus=xhci.0,drive=stick,bootindex=1 -drive id=disk,file=system1.qcow2,format=qcow2,if=none -device ich9-ahci,id=ahci -device ide-drive,drive=disk,bus=ahci.0 -m 512 -device e1000,netdev=network0,mac=00:11:32:2C:A7:85 -netdev user,id=network0,net=172.20.0.0/16,dhcpstart=172.20.246.57,hostfwd=tcp::5001-172.20.246.57:5000 -smp cpus=2,cores=1 -enable-kvm -nographic

Everything works fine.

 

My goal is to get this running on a virtual server. It has nested kvm enabled and I can run other linux images (like debian or ubuntu) on qemu/kvm on the virtual server. DSM with the line shown above does not work though. I can see the menu showing up with the three boot options, and the happy hacking text shows up (i think at least) for an instance, but then the system hangs and I do not get any serial output (with the command as shown above, the serial output is dumped into the console). CPU utilization then stays near 100%.

 

The only difference between the two systems is that I'm running antergos (arch) linux on my laptop and ubuntu 18.04 (also tried centos 7) on the server.

 

Is there anything besides nested kvm that the virtual server has to support?

 

Thank's for any help on this topic!

Share this post


Link to post
Share on other sites

I found out that DSM works on the server if I disable kvm.

 

Loading DSM

-cpu Nehalem                                     <- works
-cpu Nehalem -enable-kvm              <- does not work

 

Loading debian image

-cpu Nehalem                                     <- works
-cpu Nehalem -enable-kvm              <- works

 

How is that possible?

Share this post


Link to post
Share on other sites

If anybody else ever comes across the same problem:

I don't understand why, but v1.02b works with "-cpu Nehalem -enable-kvm" on my virtual server.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.