Jump to content
XPEnology Community

[SOLVED]Wake on LAN - Qualcomm Atheros AR8171


Recommended Posts



currently I am using this kind of board http://asrock.com/mb/overview.asp?cat=Specifications&Model=B85M-ITX und gnoBoot 10.5 alpha. Problem of all is that the WOL wont work. The ShutDown and WakeUp scheduler is working great just like the hibernation.


What I have done up to here:


1) PuTTY - "ethtool -s eth0 wol g" --> Cannot get current wake-on-lan settings: Operation not supported

not setting wol


2) WinSCP - synoinfo.conf - set WOL on eth0 to "g" --> no effect


3) Just activate it in DSM --> Set the option but if I save it, the check is gone. Same problem on the check for power if energy is back. (activated in UEFI)


The WOL option in UEFI is activated and I also tried the solution to deactivate any other energy saving options. I try to power up the system via MagicPackage (AVM FritzBox). There are three other PCs which working perfectly so there should be no problem with my router.


First of all I want to avoid a secondary NIC because there is only one PCIe slot and I want to use it another way. (I already red the topic in the german corner with the new NIC)


Can anyone help me please? Thanks for all effort!

Edited by Guest
Link to comment
Share on other sites

Hi @ all,


I tried to activate my WOL. For that I tried to find out whether the system recognize my NIC properly. So the last option under


is the NIC and as you can see the right driver is used by the DSM. But if I check my NIC with

ethtool eth0

there is no point for "Wake-On". That will explain the message that

ethtool -s eth0 wol g

"is not supported" --> there is nothing to set. So I checked out whether the NIC is listed under

cat /proc/acpi/wakeup

and as you can see, it is. BUT I wonder about the missing "Sysfs node" and the status "disabled". I checked my BIOS options again and WOL is activated.


My question to the community: Is it possible that the WOL doens't work because of the missing "Sysfs node" and is it possible to set this? If it is ---> How? I am not the linux or unix PRO so it would be nice to describe it a bit more in detail.


Any other thoughts are very welcome :wink:


@gnoboot: Can you give me a hint concerning your system or kernel?




Tank you for any effort :smile:

Link to comment
Share on other sites

  • 1 year later...

A few months after this thread was solved, Frédéric COIFFIER issued a patch that seems to have fixed the issue




Is anyone up to recompiling the DSM with this patch and uploading it so that mortals with no Linux understanding can make use of this fix? I'm sure plenty of HP MicroServer folk will be very appreciative :smile:

Link to comment
Share on other sites

  • Create New...