H310 IT Mode + 3x6TB Red + 1.04l DS918+ Speicherpool Absturz


Recommended Posts

Hallo Leute,

 

bin noch ziemlich neu in der Materie, habe viel gelesen und gestern das System auch schon zum laufen gebracht.

 

Aus Sicht der aufrüstbarkeit, Erhöhung der schreibgeschwindigkeit, einer paritätsplatte und einem großen speicherpool habe ich mich für ein RAID 5 System entschieden.

 

So da Mein Mainboard nur ein paar sata Ports hat und der das RAID Ressourcen frisst habe ich mich für den DELL HBA H310 entschieden, welchen ich erfolgreich auf den P20 IT Mode geflasht hab. Daran ist vorerst das Minimum angeschlossen, 3x6TB WD Red.

 

Anschließend wurde mit dem l1.04 Loader ein DS918+ auf die Beine gestellt und die die Platten würden auch sofort erkannt. Beim erstellen eines speicherpools musste ich feststellen, dass dies auf Grund der Größe ziemlich dauern kann. 

 

Bei 80-90% ist der Aufbau dann gescheitert. DSM wollte das neue RAID versuchen zu reparieren, wodurch der Speicher Manager nicht mehr reagiert hat. Nach vier Stunden war es mir dann zu viel, hab die Kiste neu gestartet weil nichts passierte und die Kiste in die Knie ging...

 

Nach dem Neustart rennt DSM wieder gewohnt wie es soll, aber meine drei WD REds werden nicht mehr erkannt. An einem separaten PC getestet laufen die haben auch schon die typische DSM Partitionierung. 

 

Dann die Ernüchterung. Der H310 blinkt nicht mehr, sprich die heartbeath LED ist aus. 

 

Also wieder H310 Flash Stock fertig gemacht und mit sas2flash.efi -listall versucht den cobtroller zu finden... Puste Kuchen... findet nicht als ob nichts verbaut ist.

 

Habt ihr einen Rat für mich?

 

Gruß 

 

Link to post
Share on other sites

Danke für den Hinweis. Habe den Fehler diagnostizieren können. Der Fehler war, dass ich ich dachte der mit einem passiven Kühlkörper ausgestattete Raidcontroller wird bestimmt nicht warm und benötigt keine Zusatzkühlung... Bullshit! Der wird kochend heiß. Nachdem ich da einen kleinen Lüfter draufgesetzt hab ist alles durchgelaufen und das RAID 5 konnte erstellt werden.

 

Jedoch hab ich nach 3-4 Tage Betrieb plötzlich immer wieder einen RAID Absturz. Bzw. er schreibt erst in oranger Warnmeldung die Systempartition sei abgestürzt und soll repariert werden. Diese kann ich reparieren und nach einem Reboot ist auch alles wieder im Lot nur weiß ich nicht so recht wie ich mit dieser Tatsache umzugehen habe. Ab und an so wie gerade eben ließ sich die Systempartition nicht reparieren und er schrieb daraufhin, dass das RAID abgestürzt ist und repariert werden soll. Dieses kann ich umgehen indem ich einen Neustart durchführe und die Systempartition anschließend repariere...

 

  • Nehmen wir mal an @jensmander hat Recht und die P19 Firmware wäre besser, kann ich diese einfach über die P20 IT Firmware spielen, oder muss ich die ganze Prozedur von vorne starten...?
  • Wie verhält es sich mit dem in DSM erstellten Software RAID 5? Ist diesen danach weiterhin verwendbar (Bei Neuflash des Dell H310 mit der P19 IT Firmware)?
    Oder mache ich mir hier zuviel Panik und der HBA ist wie der Name schon sagt wirklich mit der IT Firmware ein SATA Controller und reicht die Platten ein zu eins durch...?
  • Derweil habe ich ja eine DS918+ Maschine konfiguriert... Wenn ich nun einen neuen Stick für eine DS3617xs erstelle und das DSM neu aufspiele, ist dann dann Software RAID weiterhin verfügbar? Ich kann es ja für die Installation abkoppeln (Denke an die DS3517xs weil diese Treiberfreundlicher sein soll und vielleicht besser mit dem 310 HBA Laufen)

Vielen Dank für die Hilfe!

 

 

Unbenannt.JPG

Link to post
Share on other sites

Habe gestern einiges selbst erfolgreich testen können:

 

Quote

Nehmen wir mal an @jensmander hat Recht und die P19 Firmware wäre besser, kann ich diese einfach über die P20 IT Firmware spielen, oder muss ich die ganze Prozedur von vorne starten...?

Die Prozedur muss komplett von vorne durchgeführt werden, die P19 IT über die P20 IT ging nicht. Bin nun auf P19 IT und mal sehen was die Langzeiterfahrung zeigt...

 

Quote

Wie verhält es sich mit dem in DSM erstellten Software RAID 5? Ist diesen danach weiterhin verwendbar (Bei Neuflash des Dell H310 mit der P19 IT Firmware)?
Oder mache ich mir hier zuviel Panik und der HBA ist wie der Name schon sagt wirklich mit der IT Firmware ein SATA Controller und reicht die Platten ein zu eins durch...?

Alles ohne Probleme durchführbar und danach wieder verwendbar. DSM bekommt von Neuflash des HBA's gar nichts mit...

 

Quote

Derweil habe ich ja eine DS918+ Maschine konfiguriert... Wenn ich nun einen neuen Stick für eine DS3617xs erstelle und das DSM neu aufspiele, ist dann dann Software RAID weiterhin verfügbar? Ich kann es ja für die Installation abkoppeln (Denke an die DS3517xs weil diese Treiberfreundlicher sein soll und vielleicht besser mit dem 310 HBA Laufen)

 

Habe ich erstmal sein gelassen, aus Angst das es das RAID zerstört und weil ich nicht zu viele Variablen verändern wollte. Schauen wir zu erst einmal ob die P19 das RAID 5 stabil am laufen hält...

 

P.S.: Kann es sein das der Speicherpoolabsturz auch was mit einem fehlerhaften USB Laufwerk zu tun haben kann?? Ich hatte mir zur Sicherheit vor dem Flash ein Backup der wichtigsten DAten auf eine alte Externe gemacht. Die war schon die ganzen Tage angeschlossen mittel USB 3.0. Was mir zusätzlich zum Absturz des Speicherpools aufgefallen war, dass ich die Xpenology Kiste nicht mehr runterfahren konnte. Diese ging sofort wieder an, auch wenn ich diese Stromlos geschaltet habe. Gestern hatte ich dann vor dem Flashen die USB Platte entfernt und konnte danach "reproduzierend" die DSM mehrfach auschalten ohne das diese wieder anging. Nach Anstopseln der USB Platte, zack ging die DSM wieder an... jetzt meine Vermutung, kann es sein, dass die Externe auch ein Auslöser für den Absturz des Speicherpools ist? Der Absturz ist auch ein zwei mal passiert, als ich DAten von diesem auf der Externen gesichert habe...

 

P.P.S.: Eine Reparatur des Speicherpools, wenn die zweite Meldung kommt, wie oben im Screens dargestellt, in ROT mit Gefahr, kann nicht durchgeführt werden. Starte ich die DSM neu ist nur noch eine "Achtung" Meldung in Orange da, welche besagt, dass der Zugriff der Systemparition der drei RAID5 Platten fehlgeschlagen ist. Diese kann ich ohne Probleme reparieren und dann sind alle Meldung weg, das NAS in Ordnung und das RAID 5 voll funktionsfähig...  bin echt ratlos...

 

Unbenannt.JPG.f795cbbba0c8f4a40bec27629ea5bccb.JPG

 

Beste Grüße

Edited by WowaDriver
Link to post
Share on other sites

Die P19 läuft bei mir seit DSM 5.2 ohne Probleme, die P20 hat immer Mucken gemacht. Sowohl im originalen LSI9211-8 als auch im baugleichen DELL 310.

 

Ich würde sogar den DS3615XS gegenüber dem DS3617XS vorziehen oder die "Trickvariante" nehmen (Stick mit DS3617XS verwenden und passende PAT installieren, ausschalten, Stick mit dem Loader 1.03b für DS3615XS flashen und damit wieder booten, neuestes Update installieren). Das System bleibt als DS3617XS, ist aber durch den 3615-Loader aktualisierbar.

 

Wenn der Shutdown nicht läuft, müsstest Du Dein BIOS bzw. die Settings mal überprüfen. Welches Board verwendest Du dafür?

 

Der Speicherpoolabsturz hat mit dem USB nix zu tun. Der Stick wird nur für den Start ab BIOS POST benötigt. Sobald der Loader soz. "aktiv" ist, kommt der Rest von den Systempartitionen der Festplatten.

Edited by jensmander
Link to post
Share on other sites

Danke für die Rückmeldung.

 

Das Thema mit dem Shutdown hat sich erledigt. Das liegt ja komischerweise an der USB Platte sobald diese dran ist fährt die DSM wieder hoch nachdem Shutdown... keine Welche WakeonUSB Settings man da im Bios ausstellen kann. 

 

Als Board benutze ich ein noch rumliegen gehabtes z170 pro gaming von Asus mit einem i7 6700 inkl. 16gb ram da ich einiges vor habe parallel zu fahren unteranderem Virtualisierung von WIn10, ein paar Loxberrys, Überwachung mit 4-6 Cams und MediaServer....

 

Nachdem DSM heute den ganzen Tag lief, knappe 7 Stunden am Stück wo ich immer wieder drauf Zugriff hatte, habe ich mich vorhin auf der Arbeit von der Weboberfläche abgemeldet und bin Home gefahren. Daheim eben eingeloggt und festgestellt, dass der Speicherpool wieder abgestürzt ist.... :( auf bereits erwähnte weise repariert... aber das kann doch auf Dauer nicht sein. 

 

Sprich die P19 IT bringt mich bei dem Problem ebenfalls nicht weiter... Habe in einem anderen Forum gelesen das ein defekter Elko im Netzteil zum Absturz eines Speicherpools geführt haben soll... kann mir dies aber ehrlich gesagt nur schwer vorstellen. 

 

Ich fahre die Platten mittels der Energiesparfunktion nach 15 Min runter bei nicht Verwendung falls das für das Problem relevant sein kann... 

 

Wenn ich jetzt das RAID5 abklemme und auf DS3615XS oder DS3617XS umsteige, kann ich später das RAID5 wieder anklemmen und weiter nutzen? Oder muss dieses neu aufgebaut werden?

 

Hatte zu Testzwecken überlegt, komplett eine andere Festplatte, inklusive anderem Stick eine DS3615/17XS aufzusetzen und danach das RAID5 abzuklemmen um zu schauen was passiert... Ratsam? Bevor ich mir das Produktivsystem zerschiesse...

 

Gruß

Edited by WowaDriver
Link to post
Share on other sites

Habe gestern abend das Problem mit dem Speicherpool lösen können.

 

Es liegt am Spindown der Platten. Habe es reprozuieren können, wenn ich 10 min einstelle und am DSM mich auslogge ist jedesmal beim wieder einloggen der Speicherpool mit der Festplatte 8 ausgefallen. Siehe angehängte Screens.. in den SMART Werten der Platte sieht man auch, dass diese schon ca 120 Stromabbrüche hatten... Habe das Abschalten der Platten nun deaktiviert und seit dem keine Probleme mehr...

 

Im nachhinein habe ich so viel Zeit für die Felhersuche investiert und dabei benötige ich das Abschalten wahrscheinlich eh nicht, weil ich die Survailance Station aufzeichnen lassen möchte... und da eh entweder alle oder eben keine Platte abschaltbar ist ginge das doch sowieso nicht, richtig?

 

  • Die Fragen zur Umstellung auf DS3615/17XS bestehen aber weiterhin...
        -> Da an sich erstmal alles läuft bei meiner Hardware würdet iht die DS918+ oder eine der DS3615/17XS empfehlen? Will das RAID später auf bis zu 8 Platten erweitern...
        -> Ich möchte außerdem ein zentrale WIN10 Arbeitsumgebung im VMM einrichten, das läuft auch soweit sogut. Wenn ich grafischhungirige Tools wie CAD
             Anwendungen einsetzen will würde hier doch auch eine seperate GPU nicht schaden oder?

Bildschirmfoto 2019-03-06 um 22.23.28.png

Bildschirmfoto 2019-03-06 um 22.23.53.png

Bildschirmfoto 2019-03-06 um 22.24.11.png

Bildschirmfoto 2019-03-06 um 22.24.33.png

Link to post
Share on other sites

Hmtja... spin-down war und ist in XPEnology immer ein heikles Thema. Macht in Deiner Umgebung, wie Du bereits sagtest, auch nicht wirklich Sinn. Manche Mitforisten machen aus dem Thema auch eine Wissenschaft mit hypochondrischen Tendenzen 😅 Da werden Kisten mit 6 HDDs oder mehr verbaut, große Speicherpools angelegt und man überlegt, wo man nochmal 10W sparen kann. Das steht dann teils konträr dem Verschleiß der HDDs durch ständigen spin-down & spin-up der HDDs gegenüber (Platten altern nun mal schneller, wenn selbige ständig I/O-Zyklen ausgesetzt sind, wie jede Mechanik)...

 

Virtualisierung durch DSM für VMs mit CAD? Ich glaube, dass Du da nicht viel Freude mit haben wirst. Da könntest Du eher überlegen, als Unterbau ESXi zu verwenden und DSM ebenfalls zu virtualisieren. 

Link to post
Share on other sites
  • 1 year later...

Ich habe das exakt gleiche Problem.
Ein Dell H310 im IT-Mode, SpinDown aktiviert - und jedesmal sind die Volumes abgestürzt. Ätzend.
Die gleichen Platten direkt am Mainboard funktionieren einwandfrei. Es muss also am der Controllerkarte liegen.

 

Auf das Platten-Hibernate mag ich aber nicht verzichten. Eher tausche ich die Controllerkarte aus.
Wisst ihr zufällig, ob das Problem mit anderen Karten auch auftritt?

Link to post
Share on other sites

also in sachen spin down und lsi sas controller hat sich gezwegt das es da ein problem mit der 918+ gibt, das ist schon in der ursprünglichen version drin die jun im lader 1.04b hat, taucht nicht auf mit den treibern die man aus dem 6.2.2 source kompiliert aber mit denen hat man im momen kein s.m.a.r.t. und keine SN der disk

spin down sollte man bei 918+ mit lsi sas nicht aktivieren oder den neueren treiber verwenden - ist zumndest sicherer

warum das scheinbar nicht bei alllen passiert ist im moment nicht bekannt aber wenn man sicher sein will die zwei varianten wie genannt oder die 3615/17 woe die lsi sas treiber direkt von synology stammen, da funktioniert alles zuverlässig - nur gibts dann kein M.2 support und kein hardware transcoding

 

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

 

  • Thanks 1
Link to post
Share on other sites
3 hours ago, IG-88 said:

...oder die 3615/17 woe die lsi sas treiber direkt von synology stammen, da funktioniert alles zuverlässig - nur gibts dann kein M.2 support und kein hardware transcoding

 

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

 

Danke, da steht ja in der Tat schon eine Menge geschrieben.

Ich brauche weder M.2 noch Hardware-Encoding, deswegen versuche ich es vielleicht mal mit der 3617.

Andererseits gönnt sich die Dell H310 satte 6 Watt dauerhaft, auch im SpinDown. Was die als simpler HBA damit macht ist mir schleierhaft.

Kucke daher parallel nach Board mit mehr SATA Ports, welche die Karte entbehrlich machen. 

Link to post
Share on other sites
2 hours ago, Chili said:

Kucke daher parallel nach Board mit mehr SATA Ports, welche die Karte entbehrlich machen. 

wenn pcie 3.0 verfügbar is dann eine 5port karte mit jmb585 statt der üblichen 4port kaete mit marvell chip, die können nur pcie 2.0 und das ist bei 1 oder 2 lanes ziemlich dürdftig

 

Link to post
Share on other sites
59 minutes ago, IG-88 said:

wenn pcie 3.0 verfügbar is dann eine 5port karte mit jmb585...

Genau danach hatte ich bereits geschaut. Aus China billig zu bekommen, hier in D sind's hingegen knappe 100,- EUR.

Für einen ähnlichen Betrag kann ich wie gesagt auch gleich ein anderes Board mit direkt 8 oder 10 SATA Ports kaufen.

Da M.2 keine Rolle spielt (die sich die Labes sonst teilen würden), wären die Ports auch voll nutzbar.

Link to post
Share on other sites
11 hours ago, Chili said:

Für einen ähnlichen Betrag kann ich wie gesagt auch gleich ein anderes Board mit direkt 8 oder 10 SATA Ports kaufen.

vorsicht da gibts eine menge haken und ösen und keine gute performace

hatte irgendwo hier mal einen artikel dazu geschrieben

alles mit multiplexer kannst du knicken, da kommt dann nur die anzahl ports ohne multiplexer raus und bei den zwei boards mit 8xsata die auf pcie bride chip basieren (eins marvell un eins asm basiert) begrenzt jeweils der verwendete multiplexer (2 lanes und pcie 2.) die leistung

ich habe diese zwei karten hier noch rumliegen

 

jmb585, da gibts auch katen <50€ mit versand durch amazon die dann aus deutschalnd in 2 tagen bei dir sind z.b.

https://www.amazon.de/ADWITS-Express-Speichererweiterungskarte-JMB585-Controller-Support-Software-Desktop-PC-Server/dp/B07X21J35K/

evtl. findest du ja beim amazon auch was günstigeres mit jmb585, aus china dauert halt etwas länger aber andere karten sind das auch nicht

meine war so ~20 euro und kam aus china

Edited by IG-88
  • Thanks 1
Link to post
Share on other sites

Danke für den Link. Das hatte ich noch nicht gefunden.

Was mir gestern bereits aufgefallen war: die Delock-Karte hat keinen Kühlkörper, die günstigeren Karten schon. Das machte mich misstrauisch, weil dort zudem hin und wieder was von einem JMS585 stand ("S" statt "B"). Nicht, dass das irgendwelche Nachbauten sind... 

Edited by Chili
Link to post
Share on other sites

ahci zu benutzen ist nicht zwangsläufig billiger als die alten lsi sas controller aber der ahci support in dsm ist native und sollte unabhängig von zusätzlichen treibern sein

wenn die performance stimmt und der preis ok ist kann das durchaus ein auswahlkriterium sein

ich habe hier auch noch eine 10G netzwerkkarte die synology native ist so das ich selbst wenn nur native treiber gehen (wie es bei 6.2.2 eine zeit lang war) man auf nichts verzichen muss (man kann natürlich auch auf updates verzichten wenn die solche probleme machen)

 

btw. von der delock karte scheint es eine "neuere" variante zu geben die mit kühler kommt (wird schlicht eine anderer zulieferer sein, findet man sicher auch als china direkt angebot auf amazon oder aliexpress)

https://www.delock.com/produkte/G_90498/merkmale/2.html

 

mit "nachbauten" würde ich da nicht argumentieren da es keine wirkliche vorlage/referenz gibt außer vieleicht einem developer board vom chip hersteller

 

JMB/JMS - JM ist JMicron und das S oder M steht eigentlich für produktklassen S wäre eigentlich USB, B wäre PCIe/SATA, JMicron's Homepage kennt keinen JMS585, das werden schlicht falsch gewählte namen sein, die chinesen haben es nicht immer so mit lateinischen buchstaben, die schauen da sicher manchmal drauf wie wir auf deren kanji's und nehmen das nächst beste

 

und immer schön auf die specs der chips schauen und prüfen wie die karte aufgebaut ist (welche chips verbaut sind)

mit dem JMB585 gibts auch karten mit 5 x M.2 und 16x PCIe pins - der JMB585 kann nur pci 2x und da ist nur einer dieser chips drauf, die pins vom 16x sind da nur show (die wenig geld gekostet hat und die karte sogar unnötigerweise auf einen 16x slot begrezt) - ein pcie 4x pin out wäre der spec nach korrekt (2x gibts offiziell als karten-/pin-layout nicht, nur 1,4,8,16)

Edited by IG-88
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.