Jump to content
XPEnology Community

Help! Recovering from a volume crash


Recommended Posts

Hi,

 

I had a bit of a disaster today installing a new sata controller and I wonder if anyone has any advice. The short story is after installing a pci-e sata controller my volume crashed, so I moved the drives back to the onboard ports, which fixed the volume, but there seems to be some issues left behind as I'm getting all kinds of strange errors in the logs, dsm, and docker.

 

I've written a bit more detailed description below, but I put it in quotes so you can skip to my questions if you prefer

"

Basically I had 6 drives connected to my 6 onboard sata ports. 4 of the ports were older sata spec, so I installed a 4 port sata pci-e card and moved 4 of the drives (in the same order) to the new card. Everything went smoothly at first, but 30 minutes in, the volume crashed. So I shut down, moved the drives back to the onboard sata and booted up. Luckily the data was ok, but dsm said the system partition was corrupt. It prompted me to repair that, which was successful, then checked the file system which passed, and finally much relieved, I thought it was ok.

 

It also prompted to run data scrubbing, so I did that. As the day went on, things seemed to be running slowly, and at first I figured it was just the data scrubbing. However, more and more strange errors have started showing up I don't know where to begin to diagnose. First a docker container seemed to be frozen so I went to restart it and it wouldn't stop. Even killing it using ssh would hang. I checked /var/log/messages and noticed a lot of strange errors. I won't list them all, but the ones that seemed to repeat often were related to:

 

 synoscgi_SYNO.FileStation.List_2_list[1325]: AccessTokenSqlite.cpp - errors like database locked and resource unavailable

 

I don't know which sqlite database it's trying to access, so I'm not sure how to unlock.

 

I tried stopping docker and restarting the package, which seemed to make things worse because it seemed to hang trying to get into gui, or at least open very slowly. Some packages wouldn't start, I couldn't save container settings, etc.

 

There were multiple errors from docker, a few highlights:

 

 dirperm1 breaks the protection by the permission bits on the lower branch

can't umount /var/packages/Docker/target/docker/aufs/mnt/0: No such file or directory

 

There were also some user authentication errors in the dockerd logs, so I opened the user settings in control panel, but pulling up a user's settings gave an Operation failed error.

 

Also, I tried uninstalling and reinstalling web station, but i can't get through the install.

 

So, basically it's a mess. Most of the errors I search for on google don't even have results. Storage manager shows the drives and volume as healthy, but it's still running the consistency check. I'll leave that running overnight. I'm just not sure where to start on diagnosing the issue as I haven't seen a pattern which points to a specific possible cause of the problem.

"

My main question is, if I can't track down the issue and have to reinstall DSM, is there a way to do a clean install which wipes the system partition without losing my personal data on the volume? I have a hyper backup of my apps, settings and important files, will that restore to a fresh installation? Will the users and groups and share permissions all be restored, or will the ids be different and have to be set up again? Will encrypted folders still be accessible, and will the key manager store still work with the old password? etc... Never having had to restore settings, I don't know what exactly gets restored, especially on a clean install. I put so much time in configuring everything, the settings are almost as important as the data to me. Any tips would be great.

 

If it's not possible to do a clean install, what are my options? I don't have enough space to move all my data off the nas and wipe the volume. I could just try and restore the hyper backup, but I'm not sure if that will fix the problem or make it worse. As a last resort I could buy some hard drives, but if anyone has any other options or suggestions on where the errors might be coming from, that would be great.

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...