• 0
omar

Looking to upgrade from Gen8

Question

So I'm fed up of my Gen8 dying every few months with the error that the server page cannot be found.

Each time I have to reinstall xpenology and migrate to the new install.

I dont know why it happens with my server so frequently.
I even bought new drives and migrated my old server to new drives.

Still crashes for no reason.

Was even thinking of buying an actual synology box, but then say how expensive they still are.

 

So can someone suggest something else I can use which has an easy UI?
I know there's FreeNAS but that looks like a hassle for some things to set up last time I checked on that.

 

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0
11 hours ago, omar said:

So I'm fed up of my Gen8 dying every few months with the error that the server page cannot be found.

Each time I have to reinstall xpenology and migrate to the new install.

I dont know why it happens with my server so frequently.
I even bought new drives and migrated my old server to new drives.

Still crashes for no reason.

Was even thinking of buying an actual synology box, but then say how expensive they still are.

 

So can someone suggest something else I can use which has an easy UI?
I know there's FreeNAS but that looks like a hassle for some things to set up last time I checked on that.

 

HP Microserver Gen8 is a very reliable and stable machine. I have used this machine for 4 years now running Xpenology, runs 24/7, 365 days a year. It never miss a bit. I only shut it down just to upgrade or blow its dust out as it sucks it lot of fluff in, if you leaving it running for long as I do. I only upgraded just  last week to try something else. That being said... Using Jun's loader V1.03b to install DS3615xs on Gen8 is very stable though you will need a PCIE Intel NIC like HP NC360T.  If your Gen8 is not faulty; you should be okay. 

Alternatively, you can get something like Dell PowerEdge T20 or T30 (Xeon). All its hardware is compatible with newer DSM. T20 consumes less than 50W while running. 

When it comes to UI, IMHO nothing beats Synology......I have a real Synology box, Synology router and couple of Xpenology boxes but give other platforms a try. 
I hope this helps a wee bit.

Share this post


Link to post
Share on other sites
  • 0

I also really love Xpenology but a friend of mine uses Unraid and he loves that (and I do admit it looks quite decent too)  I've used openmediavault in the past and quite liked that Nas OS too.  I don't think they look as polished as Synology though.

Share this post


Link to post
Share on other sites
  • 0

@BanterBay idk why my Gen8 keeps needed to be flashed every 6 or so months. Sometimes it's sooner.

 

I always have this happen: Sorry the page you are looking for is not found

Untitled.png

 

The first time it happen was when I was trying to install the webstation, then read somewhere this may cause it.
So did a reinstall and didnt install the webstation.

Yet it keeps on happening.

I had a second Gen8 which is where I migrated old system to a new one.

Still randomly get the same error.

I actually turn my server off each night to save on electricity. Dont know if that's causing it. it shouldnt really should it.

 

 

Share this post


Link to post
Share on other sites
  • 0
On 2/18/2019 at 2:49 AM, omar said:

@Polanskiman  not really, but you can close it if you want.

 

If it is not answered I'll leave it open. Just making sure that users are following on the questions they ask. ;)

Share this post


Link to post
Share on other sites
  • 0

I dont think there is an answer to this really.
No one knows what causes servers to crash requiring you to reinstall synology, or how to prevent it
And from the looks of it, buying a different server costs almost as much as an actual synology server so you might as well get the real thing.

Share this post


Link to post
Share on other sites
  • 0

You seem to have some sort of compromised install or hardware problem that you reported long ago and has continued.

There are no responses, because others don't know why your system is randomly behaving that way, and the problem you describe is not happening to them.

 

Reading through all your posts, you don't seem to be very satisfied with XPEnology ever, and seem to be looking for a reason to use something else.

But if you do want to keep on, consider a validation test of your hardware (no overclock, full system and memory test, etc) and then a totally clean installation.  Also verify your function prior to installation of, or do not use root-level customization like ipkg/opkg.

 

Regarding your last statement about cost/value, I don't know where you come up with that; if it were true nobody would be using XPEnology

Synology doesn't even make a product with the features of my own box, for instance, and the closest (grossly inferior) match is more than twice the cost of my parts.

Share this post


Link to post
Share on other sites
  • 0

I have already tried a full clean installation on a second Gen8 server with 4 new HDDs
I then transferred the data across, not a migration.

And yes it still causes this crash/corruption or whatever makes that "cannot find page" error.

And as you said I ahve not had any responses to it, though if you look around, other people have had the same issue, although just a small number.

And I would like something else to use, cos would you like to reinstall your server twice a year or more?
Of course I would love to continue using xpenology, but as said I am getting a bit tired of having to do these reinstalls.

But yeah maybe I should test the hardware, maybe the ram module has degraded and is causing problems.

Share this post


Link to post
Share on other sites
  • 0

Hi Omar,

I used to have HP Gen 8 server as yourself. I used it for couple of years without any hassle.  I had "cannot find page" error once and it was caused by certain version of Plex server I installed (so I read somewhere), since I removed that Plex no issue since. Try and look into this, just maybe......

 

I may be wrong 

 

Share this post


Link to post
Share on other sites
  • 0

I have two Gen8 and are working with Xpenology without a problem in the last 3-4 years.

I've upgraded the processors to Intel Xeon E3-1265L V2 and Intel i3 - 3240.

 

No problems at all.

 

I use the internal microSD card for the loader.

Edited by Mentat

Share this post


Link to post
Share on other sites
  • 0
On 2/8/2019 at 10:37 PM, omar said:

 

I always have this happen: Sorry the page you are looking for is not found

http://www.tlso.net/Untitled.png

 

By the looks of it, you have a problem with phpmyadmin and that is not really a Xpenology problem.

Either your database is fu**ed up, your your php config is playing with you.

Do not blame the HW or the OS, this is an "Error 40" situation.

Share this post


Link to post
Share on other sites
  • 0

That's just an example image showing the error I get. Not a screenshot of mine
Obviously that person is trying to install myphp on their server.

 

The error is generic and not specific to a given program.

As you can see no details are given except that the page cannot be found

Hence why no ones been able to assist in this issue.

The only fix is a reinstallation of the diskstation operating system.

Share this post


Link to post
Share on other sites
  • 0

Wow system crashed again!

This time I got an error before it messed up.
As said I shutdown my system each night.
As I shut it down I got an error saying it could not shut down as it was trying to restore a shared folder.
I click OK, the page refreshed and "Sorry, the page you are looking for is not found."

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.