Jump to content
XPEnology Community

s2ram for DSM5 possible?


Recommended Posts



is it possible to build s2ram from the suspend project for DSM5 on gnoboot 10.4?

What would be needed for that?

I have access to Win7 / OSX Mavericks / Ubuntu 10.? systems. So building on Linux is an option.



I run a H340 headless system with 2x2TB and 2x1TB WD-Drives.

Spin-down is not working for me. The system takes ~55 W. It is powered on by WOL when I start one of my regular systems or by actively sending WOL via IOS-App.

I adapted a script I found in the synology forum to poweroff the H340 if it is no longer needed (no other machine online, no WIN/AFP shares active, CPU less than 10%, no connections on known ports for streaming...).

That works quite well, but... it takes too long after the WOL packet to boot up the system. It would be great to suspend the system to RAM. It worked under the original WHSv1 OS so the hardware should be capable to do so.


Any advice is greatly appreciated.


Thanks in advance


Link to comment
Share on other sites




I don't think such function is even available on real Synology machines.

And it seemed having something to do with CPU functionality, what you said is very similar with how Intel describe their "S3" system state.

Link to comment
Share on other sites

Hi jokies,


thank you for your answer.


In fact it is the s3 state. :smile:

Synology doesn't need it on their own machines because they have a very low power profile and are able to use a mode they call hibernate - basically HDD spindown and low power consumption by CPU etc.

A lot of people here seem to have problems with the hibernate state on their franken units and so do I. (No HDD spindown, high power consumption) That is where s2ram comes into play. I guess a lot of the units used for XPEnology are based on intel CPUs that support S3.

I installed bootstrap dev tools on my machine and tried to build 'suspend' but I get the following error: "Required pciutils >= 2.2.4 not found". Looks like there are some header-files missing. And even if I found these header files I don't know if gnoboot's kernel was compiled with options that would allow 's2ram' to work.

Link to comment
Share on other sites

  • Create New...