NFS share permissions denied


Recommended Posts

Hi

 

XBMC Log Error Permission denied 13

 

Since i have updated my XPEnology 4.1 to the latest 4.2 firmware, i have no access to my nfs shares. Before the 4.2 Update everything worked fine, but now i can't connect to the subfolders from my share. I already formatted my system disk and installed the 4.2 new, but no change. I also have modified the /etc/exports file like in the snology wiki described. Is there any other option i have to change or i can check, why my nfs share is not accessible? Please help me i have tryed the access on an Raspbmc and XBMC on Windows. Is there anybody who can confirm this behavior?

 

Thanks

 

Kind regards

Link to post
Share on other sites

Me too, but not with xmbmc but with esxi or any other nfs client, in dmesg o saw a lot of undefined modules in nfsd.ko ( module file ) i suspect some strange trick in compiling options, could be usefull compile another fresh kernel following instructions on wiki with ALL the things that come from synology gpl source, aka, using bromlow config file like .config for kernel options

Link to post
Share on other sites

Hi

 

I just tryed to restart the NFS Service manually by "s83nfs.sh restart" and i get this errors:

 

Starting NFS server...

:: Loading module rpcsec_gss_krb5 ... [FAILED]

:: Loading module exportfs ... [ OK ]

:: Loading module nfsd ... [FAILED]

mount: mounting none on /proc/fs/nfsd failed: No such device

 

Can anybody help me whart this error occours?

 

Thanks

Link to post
Share on other sites

Hi All,

 

Don't know if this would be helpfull, it looks like the same problem when i configured my Raspberry Pi for XBMC for the first time. I also had problems with the NFS share permissions.

 

In the following link there is a explenation how to configure NFS for Synology in combination with XBMC (needs some editing in a config file).

http://www.robvanhamersveld.nl/2012/12/ ... -with-nfs/

 

Hope it helps, it did the trick for me :grin: .

 

Greetz

Link to post
Share on other sites
  • 2 weeks later...
Hi

 

I just tryed to restart the NFS Service manually by "s83nfs.sh restart" and i get this errors:

 

Starting NFS server...

:: Loading module rpcsec_gss_krb5 ... [FAILED]

:: Loading module exportfs ... [ OK ]

:: Loading module nfsd ... [FAILED]

mount: mounting none on /proc/fs/nfsd failed: No such device

 

Can anybody help me whart this error occours?

 

Thanks

 

you may refer my post on http://xpenology.com/forum/viewtopic.php?f=2&t=558&p=2600&hilit=nfs#p2600

Link to post
Share on other sites