DSM 6.x Proxmox Backup Template


Recommended Posts

  • 2 weeks later...
On 5/29/2021 at 1:54 PM, maxleonffm said:

Point 1

Add a "serial Port (serial0) : socket" to your proxmox vm.

Then when your vm is running, you will be able to connect to it from your proxmox server terminal with this following command :
 

$ qm terminal <vmID>


 

HTH

  • Like 1
Link to post
Share on other sites
  • 2 months later...
  • 1 month later...

Hi, I've been following this thread, but can't get an DHCP IP, tried E100e and VirtIO, neither give an allocated IP.

I am on KVM (virsh/virtio), using Virt-Manager. I have been using Xpenology for a couple of years, with the standard Jun's bootlaoder / E100e / Sata, but using this bootloader I can't get it working.

Is there something obvious I am missing to get this working with VirtIO network?

Link to post
Share on other sites
  • 4 weeks later...
On 10/10/2021 at 10:07 AM, speedyrazor said:

Is there something obvious I am missing to get this working with VirtIO network?

I'm not sure what you are missing but it works on Proxmox and docker kvm with bootloader which has virtio drivers.

Maybe you may want to check docker kvm code project which use kvm cmd line to run DSM on VM: 

 

Link to post
Share on other sites
  • 1 month later...
23 часа назад, iruindegi сказал:

I just upgraded my proxmox to version 7, other VMs are ok but xpenology is not working. I see this on the console:

 

No bootable device. Retrying in 1 seconds.

 

And it gets stuck there.

 

Any help?

 

 

  • VMs with SATA as disk bus may show issues when used with io_uring
    • For now this can be worked around by switching the disk's Async IO mode to threads (for cache = write back/through) or native (for cache = off, none or direct sync), respectively, in the Advanced options of the disk edit dialogue.
    • Note that SATA is really not the best choice for a VM's disk bus in general, rather use (VirtIO-) SCSI for best performance and feature set. For Windows VirtIO support is available through the Windows VirtIO Drivers
Link to post
Share on other sites
  • 2 months later...
8 часов назад, Borotes сказал:

Is there a way to update the images with the latest updates?

 

Hi.

 

I have read that there are some loaders which works with QEMU (So with Proxmox too), but not stable. That's why I don't make new images (and not tested personally)

 

All stable loaders are published in this section https://xpenology.com/forum/forum/31-loaders/

  • Thanks 1
Link to post
Share on other sites
  • 4 weeks later...
  • 2 weeks later...

Good day!
Thank you timonych!
Successfully deployed working xpenology from vzdump-qemu-xpenology-3615xs-6.2.3_25426.vma.lzo image.
Everything works, but faced a wild drop in network performance.
The established speed is like a 100 megabit connection, although I use only gigabit connections everywhere.
I tried to use E1000 and vmxnet3 in the virtual machine (the rest did not work). There is no difference, unfortunately.
I sinned on the hard drive, but at a known working and fast speed they did not change...
What can be wrong?

Link to post
Share on other sites
25 минут назад, SLON сказал:

Good day!
Thank you timonych!
Successfully deployed working xpenology from vzdump-qemu-xpenology-3615xs-6.2.3_25426.vma.lzo image.
Everything works, but faced a wild drop in network performance.
The established speed is like a 100 megabit connection, although I use only gigabit connections everywhere.
I tried to use E1000 and vmxnet3 in the virtual machine (the rest did not work). There is no difference, unfortunately.
I sinned on the hard drive, but at a known working and fast speed they did not change...
What can be wrong?

 

Hello, SLON!

 

I think there is some network problem between Your Host with Proxmox and Source/Target Host.

 

For me there is no any problem with network perfomance. In Xpenology UI network speed show 1Gb and transfer between my pc/virtual and Xpenology is about over 55 MB (55 * 8 ~ 400 Mb)

 

image.thumb.png.0203a318a38fbc22098eacf89cf5b816.png

Link to post
Share on other sites

I'm afraid it's not
I tried to transfer files from SDS to VM on the same host and back.
In theory, there is no restriction, except for the virtual bridge.
When copying from SDS to VM, the copy speed was approximately 58 MB / s.
But when copying back (from VTS to VM) - 12 mb / s.
The same speeds are shown when copying from or to hosts on the network.177198086_2022-4-14_9-57-18_597.thumb.jpg.0c3c42fe007467bad33d41e887ae96ce.jpg1331446001_2022-4-14_10-8-16_398.jpg.442c12c09471fd8783a06688b4918765.jpg

Edited by SLON
Link to post
Share on other sites
46 минут назад, SLON сказал:

I'm afraid it's not
I tried to transfer files from SDS to VM on the same host and back.
In theory, there is no restriction, except for the virtual bridge.
When copying from SDS to VM, the copy speed was approximately 58 MB / s.
But when copying back (from VTS to VM) - 12 mb / s.
The same speeds are shown when copying from or to hosts on the network.

 

So, if You have low speed when trasfer files from VTS to Host - You should check speed connection between VTS and Host.

I have 1 Gb from my PC and transfer speed such as copying from VM to VM via virtual bridge.

 

Via WiFi 5Ghz I have speed about ~45-50 MB when trasferring.

Link to post
Share on other sites
9 минут назад, timonych сказал:

 

So, if You have low speed when trasfer files from VTS to Host - You should check speed connection between VTS and Host.

I have 1 Gb from my PC and transfer speed such as copying from VM to VM via virtual bridge.

 

Via WiFi 5Ghz I have speed about ~45-50 MB when trasferring.

Again.
I am copying a file from VM to VM.
Within the same virtualization server.
Both VMs are connected to the same virtual bridge(vmbr0).
Nothing should cut speed.

Link to post
Share on other sites
39 минут назад, SLON сказал:

Again.
I am copying a file from VM to VM.
Within the same virtualization server.
Both VMs are connected to the same virtual bridge(vmbr0).
Nothing should cut speed.

 

Virtual device also depends on speed. If Your Interface in VM shows only 100Mb - it sends packages only with this speed.

 

Try to use in Windows 7 Network device Virtio with virtio drivers.

Link to post
Share on other sites
13 минуты назад, timonych сказал:

 

Virtual device also depends on speed. If Your Interface in VM shows only 100Mb - it sends packages only with this speed.

 

Try to use in Windows 7 Network device Virtio with virtio drivers.

On Win7, I changed the type of network device from e1000 to virtio.
Got those speeds.
They have grown a little, but not much.

From SDS speed is good

1057672981_2022-4-14_12-20-12_831.thumb.jpg.30f3f7291a6f879ecc9491a5452940b6.jpg

Link to post
Share on other sites

Hi. Today I tried to switch from DSM6 to DSM7 on Proxmox. After couple tries I got running 918+ on Proxmox but I will finish it some other day because I will be out of home.

I have question - how can I add quad GbE card and SAS controller that was working on DSM6? Do I need to create my own boot image with redpill-tool-chain (never tried that) or I can just add netiff num, sata args, sataportmap, etc in grub.cfg like it was in DSM6?

Link to post
Share on other sites
  • 4 weeks later...
Posted (edited)

I used the proxmox backup "vzdump-qemu-xpenology-918-6.2.3_25426.vma.lzo" on a Dell R610 with Dual L5640 CPU's and Proxmox 7.2-3 as VM OS.
I get the CLI screen "happy hacking, screen will stop updating shortly, please open http://find.synology.com to continue".
But seems the container does not get any IP from DHCP.
Already restarted over new, let proxmox  generate a MAC address in the hardware tab for network controller.
Network controller is enabled.

Already used the same "vzdump-qemu-xpenology-918-6.2.3_25426.vma.lzo" backup on an Intel NUC 10th gen with Proxmox, which runs without any problem.
Is there a way to open CLI instead of the "happy hacking, screen will stop updating shortly, please open http://find.synology.com to continue" screen?

So I can check if network adapters are available in the unix / it retrieves any ip / ...
All advice is welcome!

Edited by querex
Link to post
Share on other sites
5 часов назад, AHITMAN сказал:

Can i just update to DSM 7 from my 6.2.3 I have installed on proxmox from a backup that was reatored?

No, there is no any way to do it with this backups. According to opinions there is no any reason to use DSM 7.

6 минут назад, querex сказал:

I used the proxmox backup "vzdump-qemu-xpenology-918-6.2.3_25426.vma.lzo" on a Dell R610 with Dual L5640 CPU's and Proxmox 7.2-3 as VM OS.
I get the CLI screen "happy hacking, screen will stop updating shortly, please open http://find.synology.com to continue".
But seems the container does not get any IP from DHCP.
Already restarted over new, let proxmox  generate a MAC address in the hardware tab for network controller.
Network controller is enabled.

Already used the same "vzdump-qemu-xpenology-918-6.2.3_25426.vma.lzo" backup on an Intel NUC 10th gen with Proxmox, which runs without any problem.
Is there a way to open CLI instead of the "happy hacking, screen will stop updating shortly, please open http://find.synology.com to continue" screen?

So I can check if network adapters are available in the unix / it retrieves any ip / ...
All advice is welcome!

 

918 version works only with Haswell or newer CPU. Use 3615xs or 3617xs instead.

  • Like 1
Link to post
Share on other sites
2 hours ago, timonych said:

No, there is no any way to do it with this backups. According to opinions there is no any reason to use DSM 7.

 

918 version works only with Haswell or newer CPU. Use 3615xs or 3617xs instead.

thanks for your reply. Ive downloaded you backup template of xpn dsm 7 and its stuck at "booting to kernel" any ideas?

Link to post
Share on other sites
4 минуты назад, AHITMAN сказал:

thanks for your reply. Ive downloaded you backup template of xpn dsm 7 and its stuck at "booting to kernel" any ideas?

 

This backup are made on Jun's loader. 

You can read the articles about DSM 7 with Jun's loader.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.