Slow SMB write speed


Recommended Posts

With both openmediavault and freenas I get 110MB/s stable while writing on a smb share, with the same file I go from 20 to 80MB/s on XPEnology (tried DS916+ on 6.1.7, DS3615xs on 6.2, DS3617xs on 6.2).

Hardware is J3455-ITX with 8GB of RAM and a single 2TB WD Caviar Green.

I already tried to disable smb encryption and I also switched to SMB3 but the results are the same.

Link to post
Share on other sites

Try turning off SMB3 and turning on SMB1. From what I understand SMB3 is still "in the works" and it not a complete standard.

 

When I did that it stabilized by speeds.

 

Also WD Greens are not the most "premium" drives so they could be the culprit too.

Link to post
Share on other sites
1 minute ago, test4321 said:

Try turning off SMB3 and turning on SMB1. From what I understand SMB3 is still "in the works" and it not a complete standard.

 

When I did that it stabilized by speeds.

 

Also WD Greens are not the most "premium" drives so they could be the culprit too.

I'll try but surely the hdd is not the problem since with freenas and omv I get 110mbps without drops.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.