• 0
milosv

2FA authentication fail - can't get in

Question

Hi guys,

I used 2FA authentication for DSM access for 2 years. last few months my 2FA codes stopped working properly and I had to use emergency email code - that worked fine.

I would then reset 2FA and it worked again until few weeks ago.

2FA codes don't work again and this time when I use emergency code via email - no email is received (waited for 2 weeks, tried many times, checked spam solder) - meaning email settings have stuffed up or Google has changed something in Gmail again.

In any case, I can't get the 2FA code to work. I can still access data via mapped drive but I can't get into DSM settings at all.

 

  • I am on DSM 5.2 - can I just upgrade to 6.17 and password or 2FA can be reset?
  • Or do I reinstall fresh 6.17 and I can just restore data?

 

I have backed up essential data already but ran out of HDD space to back up non-essential data. worst case scenario I have all backups I really need but would like to avoid copying 5TB of data via usb 2.0 if possible.

 

any help or guidance is appreciated.

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

Can you connect via SSH? If the answer is yes try this:

 

sudo find /usr -name google_authenticator

 

The result should be:

 

/usr/syno/etc/preference/YOURUSERNAME/google_authenticator

 

Remove the entry with:

 

rm /usr/syno/etc/preference/YOURUSERNAME/google_authenticator

 

(replace YOURUSERNAME with your real username)

 

Reboot with „sudo reboot“ and try again to log in

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, jensmander said:

Can you connect via SSH? If the answer is yes try this:

 

sudo find /usr -name google_authenticator

 

The result should be:

 

/usr/syno/etc/preference/YOURUSERNAME/google_authenticator

 

Remove the entry with:

 

rm /usr/syno/etc/preference/YOURUSERNAME/google_authenticator

 

(replace YOURUSERNAME with your real username)

 

Reboot with „sudo reboot“ and try again to log in

 

 

 

 

When I use Putty after entering my correct username and password putty just shuts down without any further prompts. I tried multiple times.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, bearcat said:

Does your NAS have the correct date and time ?

I believe so, I have entered the new website and tested it and updated it. I do know what you mean and that's the most likely culprit but since I can't get in I can't do anything about it.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, milosv said:

When I use Putty after entering my correct username and password putty just shuts down without any further prompts. I tried multiple times.

 

I think that you're trying to login with a standard user, not an account which belongs to the admin group. Only users which are members of the admin group can login via SSH. You should try the admin user which was created during your setup/install.

Edited by jensmander

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, jensmander said:

 

I think that you're trying to login with a standard user, not an account which belongs to the admin group. Only users which are members of the admin group can login via SSH. You should try the admin user which was created during your setup/install.

I did use the admin user, I disabled the default admin and created my own. but SSH crashes after login details are entered so not sure SSH was setup correctly.

grrrrr...damn you 2FA :)

Share this post


Link to post
Share on other sites
  • 0
22 hours ago, milosv said:

I believe so, I have entered the new website and tested it and updated it. I do know what you mean and that's the most likely culprit but since I can't get in I can't do anything about it.

You could enter the BIOS, and check/adjust time and date, unless your NAS is configured to sync with a "wrong" NTP server?

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, milosv said:

n. but SSH crashes after login details are entered so not sure SSH was setup correctly.

grrrrr...damn you 2FA :)

 

You‘re sure about the admin user AND that SSH is enabled in DSM? Another approach would be a live Linux boot, mounting the hdds and running the above mentioned commands.

Edited by jensmander

Share this post


Link to post
Share on other sites
  • 0

Hello,

I am in the same situation.

2FA enabled, phone lost and its saying that email service notification not enabled.

Tried via putty but its saying connection refused, tried both 22 , 50 port. I have r3seted the served, same issuse. I dont kown if ssh is enabled, for this server i never used.

Is the any way to rezolve?

Ive seen on juns loader in boot is a option for command promt, is there a command line to reset 2PFA? 

Thank you in advace.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, rimaru said:

...

I dont kown if ssh is enabled, for this server i never used.

...

 

So, if you have never used this server, then no wonder your 2FA is not working 😕

Share this post


Link to post
Share on other sites
  • 0

Hello,

@bearcat , i meant for ssh service. The server si heavy used for plex ,deluge and file transfer .

But i wanted to be very secure, so i activated the 2fa . 

Thank you.

Good day to you.

 

 

Share this post


Link to post
Share on other sites
  • 0

@rimaru Thanks for the clarification, that makes more sense :-)  The default setting is of the SSH service is OFF, If you never activated it ..... :-( it can't help you.

But you could still do as jensmander posted above, using a Live Linux to access the system and edit the needed files.

Share this post


Link to post
Share on other sites
  • 0

I tried and I don't think my SSH is activated on the machine :(

What about the re-installation of DSM? would it still pick up the HDDs and data?

Share this post


Link to post
Share on other sites
  • 0

@milosv : Some users have been able to "reset" their configs, by doing a "migration" install.

If you create a new USB stick, using another "base" than you currently have, ie. using DS3617 if you now are using DS3615, 

you wil be "fooling" you system to think your moving your HDD's to another NAS, and you will get the choice to keep data and setting, or just data.

If you keep just that data, all your old settings and apps will be "lost", and you need to configure a new admin user with a new password.

 

The same might be done using the same base, but a different DSM version, forcing a reinstall of DSM, keeping the data.

 

But be warned  I give you NO guaranty that it will solve your problem, and loss of data may occure! (and your house might burn down and your cat run away ;-) )

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

@bearcat that was a great idea, and it almost worked until I stuffed up and instead of manual install PAT file I downloaded I clicked on install thinking it would ask me later...it didn't. It installed the latest 6.21 so now I am trying to downgrade the unit.

 

but the idea was brilliant, my execution was poor :)

thank you all, I'll try and downgrade to 6.1 and see if it works.

Share this post


Link to post
Share on other sites
  • 0

@milosv Sorry to hear about your mishap... you might be able to use the same approach to downgrade :91_thumbsup:

Share this post


Link to post
Share on other sites
  • 0

hi all, I have managed to install 6.2 on a blank HDD and then re-introduced NAS HDDs and after a repair I have all my data and 6.2 installed. thank you all. I have re-enabled 2FA and hopefully this time there won't be any issues.

Share this post


Link to post
Share on other sites
  • 0
The question(s) in this topic have been answered and/or the topic author has resolved their issue. This topic is now closed. If you have other questions, please open a new topic.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.