Tutorial: installing 918+ 6.2.X DSM on 1.04b loader (transcoding)


Recommended Posts

Hi everybody, maybe I can get some help :(

 

my old Board got damaged so i got a new one: Fujitsu D3543-S3. 

I build a stick with juns 1.04b, changed vid & pid, mac & sn.

 

i can see the diskstation in network, i can ping. but i cant get on webinterface. same with the other nic.

 

i have already tryd some other usb drives - no success.

 

somebody any idea?

 

thanx, holly

 

 

Link to post
Share on other sites
14 hours ago, bearcat said:

 

Did you install DSM on the HDD's ?

12 hours ago, hollywoot said:

Hi, 

no, I cant. Its on first boot. I cant access the webinterface on XXX.XXX.XXX.XXX:5000 and the synology assistant dont find the xpenology too. 

maybe i have to say that i'm trying to boot on an empty disk. my raid-disk are still in the old xpenology.

 

the mainboard doesn't support legacy boot, so i have to took the 1.04b loader with the 918+. my old one was the 3517xs with 1.03b and legacy boot.

 

if i put my usb-stick into another board, it boots. but with the fujitsu board is doesn't...

i think its a wrong setting within the bios/eufi but i dont know what im doing wrong

 

Link to post
Share on other sites

  

On 4/22/2020 at 8:32 AM, hollywoot said:

Hi everybody, maybe I can get some help :(

 

my old Board got damaged so i got a new one: Fujitsu D3543-S3. 

I build a stick with juns 1.04b, changed vid & pid, mac & sn.

 

i can see the diskstation in network, i can ping. but i cant get on webinterface. same with the other nic.

 

i have already tryd some other usb drives - no success.

 

somebody any idea?

 

thanx, holly

 

 

 

my GA-3150 had a intel video problem (fixed whith latest extra.lzma from this topic) - try to turn iGPU off

Link to post
Share on other sites
On 4/22/2020 at 7:32 AM, hollywoot said:

 ...  somebody any idea? ...

 

Here is a fresh idea I got today ;-) Make a new post / thread in the Installation section of the forum.

Make sure you write down all essential info, as what type of CPU and nic your new mainboard is using.

 

This thread is aimed for transcoding, not general installation problems :-)

 

Link to post
Share on other sites
2 minutes ago, bearcat said:

 

Here is a fresh idea I got today ;-) Make a new post / thread in the Installation section of the forum.

Make sure you write down all essential info, as what type of CPU and nic your new mainboard is using.

 

This thread is aimed for transcoding, not general installation problems :-)

 

i think its an good idea :)

Link to post
Share on other sites

Hi guys, I did a baremetal install of DSM 6.2.3-25423 using JUN'S LOADER v1.04b - DS918+ on my ASRock J4105-ITX without anything customized other than the basic config (Original SN and MAC, Sata config, thumbdrive PID/VID) and everything is working just fine but I couldn't find the directory `/dev/dri` but my `/usr/syno/etc/codec/activation.conf` has this:

{"success":true,"activated_codec":["hevc_dec","h264_dec","h264_enc"],"token":"___"}

Am I missing something? Do I need to use a Synology Login or install any specific app other than `DS Video`?

As I run some specific media the codecs will be activated on the fly or it doesn't really supports transcoding for other medias?

 

Ps.: VT-d is enabled because I intend to use Docker.

 

[Edit]

Do I need to keep my thumbdrive to boot to DSM? I tried but nothing happened, I'm not sure if BIOS recognizes the HDD as a bootable device.

[/Edit]

Edited by icaroscherma
Question about thumbdrive to boot
Link to post
Share on other sites
  • 3 weeks later...

Yes My Azrock J4105 with DSM6.2.3 with 1.04b/918+ from clean install (clean usb and clean hdd). 

Hardware transcoding Work with default Videostation

Plex hardware transcoding only with decode not encode with hardware.  see Plex nas Compatibility for transcoding

see Just change on 2nd partition 4 files: 2 from .pat  and 2 extra file from V0.10

don't forget to custom grub file

 

 

Edited by viking74
Link to post
Share on other sites

@viking74

i don´t understand 100% what you want to say.

You could install 6.2.3 without the extra files from IG88 and HW Transcoding did worked?

Only Plex did not worked?

 

I updated my existing version 6.2.2 Update 4 to 6.2.3 and HW Transcoding just worked when i have used IG88 2 Extra Files from 0.11.

 Before the activation worked i had to do the HW Transcoding Patch without valid serial.

No i should work:

success":true,"activated_codec":["hevc_dec","ac3_dec","h264_dec","h264_enc","a                                                                                                             ac_dec","aac_enc","mpeg4part2_dec","vc1_dec","vc1_enc"],"token":"XXXXXXX"}

 

Do i need to do anything else?

I am asking because i am using Plex

Link to post
Share on other sites

Just an FYI on using the combo of 104b,6.23,918+, extra, and extra2 v11, and looking for hw plex transcoding, I only was able to get the following CPUs to work.  i3-8100, i3-8350k, i5-8600k.  I was not able to get 9600k working with hw transcode in plex. 9100 is supposed to work but I have not been able to test.  looks related to the video driver.

 

Link to post
Share on other sites
2 hours ago, mervincm said:

I was not able to get 9600k working with hw transcode in plex.

 

these happens on a few 9th gen cpu's with a UHD630 and device id "3E98" (i5-9400, i5-9600k, i7-9700t, i7-9700)

 

2 hours ago, mervincm said:

9100 is supposed to work but I have not been able to test. 

 

i did, works fine

Link to post
Share on other sites

@chilly

I have used IG-88 2 extra files v0.10  and 2 files from DSM_DS918+_25426 (pat from synology).

Use clean Hdd and Clean USB (no partition) to install it.

After install i haved /dev/dri work, but on plex menu for transcoding don t enable ( disable Use hardware-accelerated video encoding)

It just decode with hardware 4k HEVC but encode on 1080p h264 with software for example. (native on DS918)

I try to install DS920 know, i search serial...

Edited by viking74
Link to post
Share on other sites

I’m still on DSM 6.2.2-24922 Update 4 and would like to Upgrade to latest 6.2.3 but getting a bit confused when reading all the posts.
Some seem to be able to upgrade without any issues others seem to encounter problems. My system is has an Asrock E3C236D2I with 2 intel nicks powered by a sky lake cpu (Intel i7-6700T).
My question is if I can upgrade DSM directly from the DSM interface or do I need any additional files in order to keep Plex transcoding functioning properly?

 

Link to post
Share on other sites
  • 1 month later...

Hello everyone, I have tried multiple times to get hardware transcoding but without success.

I did a bare metal install using DSM6.2.3  25426 with 1.04b/918+ from clean install (clean usb and clean hdd) on a asrock J4105. I have installed video station and tried to play a file and no joy with transcoding. (BTW while installing I have put the SN of an original D918+ in the following format 17A0PDNXXXXXX and the two mac addresses).

 

Then i have tried swapping the original file in the second partition with the four file in the extra.lzma/extra2.lzma for loader 1.04b ds918+ DSM 6.2.3 v0.13.3 but still no joy.

If I run ls /dev/dri the result is Card0 Render D128

If i then run cat/usr/syno/etc/codec/activation.conf it says No such a file or directory.

 

Any Suggestios? What am I doing worong?

Link to post
Share on other sites
On 5/31/2020 at 11:12 AM, mattail said:

I’m still on DSM 6.2.2-24922 Update 4 and would like to Upgrade to latest 6.2.3 but getting a bit confused when reading all the posts.
Some seem to be able to upgrade without any issues others seem to encounter problems. My system is has an Asrock E3C236D2I with 2 intel nicks powered by a sky lake cpu (Intel i7-6700T).
My question is if I can upgrade DSM directly from the DSM interface or do I need any additional files in order to keep Plex transcoding functioning properly?

 

it depends a little of the extra.lzma you used before but in general you will not be able to use hardware based transcoding without a new extra/extra2 package as your i7 never worked with the original i915 driver from synology so you will have jun's i915 in the extra/extra2 you use and that driver will not work with 6.2.3 and also prevent the new i915 driver, that comes from synology with 6.2.3, to work

the clean way would be to be in the dsm web gui, pull the usb from the system, udpate/overwrite the extra/extra2 with the one from here

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

put back the usb to your dsm system, start update process in web gui, let it update and reboot (might be two times as there is a additional update2 that might be installed automatically)

 

 

  • Like 1
Link to post
Share on other sites
  • 2 months later...
On 7/26/2020 at 12:32 PM, IG-88 said:

 

it depends a little of the extra.lzma you used before but in general you will not be able to use hardware based transcoding without a new extra/extra2 package as your i7 never worked with the original i915 driver from synology so you will have jun's i915 in the extra/extra2 you use and that driver will not work with 6.2.3 and also prevent the new i915 driver, that comes from synology with 6.2.3, to work

the clean way would be to be in the dsm web gui, pull the usb from the system, udpate/overwrite the extra/extra2 with the one from here

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

put back the usb to your dsm system, start update process in web gui, let it update and reboot (might be two times as there is a additional update2 that might be installed automatically)

 

 

 

Hi IG-88
Which extra lizma file version should I use for loader 1.04b ds916+? On the page you're referring to there are two v0.12.1 and v0.13.3.

Link to post
Share on other sites
1 hour ago, mattail said:

loader 1.04b ds916+?

 

from that not sure from what you are using, 1.04b is 918+ and 916+ is only older 1.02b for dsm 6.1

if its 918+ 1.04b then its ok, if its really 916+ then you are planing a dsm update with a new loader and you should read more about it before you loose access to your data

 

1 hour ago, mattail said:

On the page you're referring to there are two v0.12.1 and v0.13.3.

you might want to read that before deciding, there a a little string attached when using scsi/sas based controllers (thats what the old version is for)

 

Link to post
Share on other sites
20 minutes ago, IG-88 said:

 

from that not sure from what you are using, 1.04b is 918+ and 916+ is only older 1.02b for dsm 6.1

if its 918+ 1.04b then its ok, if its really 916+ then you are planing a dsm update with a new loader and you should read more about it before you loose access to your data

 

you might want to read that before deciding, there a a little string attached when using scsi/sas based controllers (thats what the old version is for)

 

 

Sorry IG-88, my mistake, of course I meant 1.04b on DS918+. I'm not using any scsi/sas disks , just want the HW transcoding working again so should I just take the extra lzma files from v0.13.3 or 0.12.1 since v0.11 is not listed on that page. 
 

Link to post
Share on other sites
3 hours ago, mattail said:

I'm not using any scsi/sas disks

the lsi sas controller can be used as 8 port sata, sas is backwards compatible to sata (a controller like this has 8 pcie lanes and con be of good use when looking for a higher disk count or using sata ssd's, all pcie sata/ahci controllers only use one or two pcie lane, what can be a serious limit for throughput)

 

Quote

just want the HW transcoding working again so should I just take the extra lzma files from v0.13.3 or 0.12.1 since v0.11 is not listed on that page. 

the newest is fine but with a "normal" hardware not needing any of the added or newer drivers you could use any 6.2.3 aware version as the thing you need is to only get rid of the old i915 driver and the extra.lzma for 6.2.3 makes sure of that

Edited by IG-88
Link to post
Share on other sites
2 hours ago, IG-88 said:

the lsi sas controller can be used as 8 port sata, sas is backwards compatible to sata (a controller like this has 8 pcie lanes and con be of good use when looking for a higher disk count or using sata ssd's, all pcie sata/ahci controllers only use one or two pcie lane, what can be a serious limit for throughput)

 

the newest if fine but with a "normal" hardware not needing any of the added or newer drivers you could use any 6.2.3 aware version as the thing you need is to only get rid of the old i915 driver and the extra.lzma for 6.2.3 makes sure of that

 

Hi IG-88
Cannot thank you enough (again). Plex is now able to HW transcode again.
Thank you so much.

Link to post
Share on other sites
  • 2 months later...

My NAS has been running fine for a few years and having gone through several DSM upgrades, but I started having some issues with Video Station recently, more specific that files (TV Shows) seems to "disappear" from Video station, so i decided to reinstall the NAS to try it out.

 

At first i just attempted to select the "reinstall" option in the USB loader, and was able to find it via find.synology.com - but when it came to upload the image file (Latest DSM) it would fail with an error that the file was most likely corrupt after having formatted etc. 

 

I then attempted to reboot with the normal option in the usb and since the dsm partitions had been formatted, i could again find it via find.synology.com and this time it would accept the same file and install just fine (strange).

 

The system is now up and running on the latest dsm, but i am now missing the /dev/dri/ folder all together (I had this before reinstall), i have the codec activation but no /dri/dev.

 

I have now browsed to forum a bit again, and have read a few different things.

 

What is the best approach to getting the /dev/dri folder back and having the system work entirely as intended?

 

1.) Clean re-install with no changes to usb and using latest dsm?

 

2.) Clean re-install with no changes to usb and using older dsm?

 

3.) Clean install with changes to usb and using latest dsm? If i understand correctly in the driver extension thread, i might need to copy over that new extra/extra 2 to the usb image before reinstalling with the latest dsm? Also did i understand the thread correctly that rd.gz and zImage should also be copied or is this not applicable?

 

4.) Skip reinstall and copy over the new image with newer driver extension, reboot NAS and it should utilize the new drivers and giving /dev/dri back?

 

5.) Something completely different?

 

Hope for a bit of guidance here :)

Also:
I seem to remember that for a reinstall (While still preserving actual non-dsm data on the drives) that one should delete etc.defaults/ and then reboot selecting the reinstall option is this correct? or what would be the correct approach?

 

System:

B360 Motherboard

Pentium Gold 5400 Coffee Lake CPU

8 port LSI SAS Controller (Sata mode)

 

 

 

 

 

Edited by NooL
Link to post
Share on other sites
  • 1 month later...

So, I had HW transcoding working just fine on my box. Got a valid serial/mac, etc.

 

I had to reinstall DSM just recently, was configuring everything, when suddenly I have no activation.conf.

 

My grub.cfg is just fine. Serial registered on synology. I'm on DSM 6.2.3-25426 Update 3.

 

Any ideas? I read this topic but couldn't find any clues... maybe extra.lzma?

Edited by infonator8
Link to post
Share on other sites
On 2/10/2021 at 6:29 PM, infonator8 said:

I'm on DSM 6.2.3-25426 Update 3.

 

Any ideas? I read this topic but couldn't find any clues... maybe extra.lzma?

YES, the 6.2.3 comes with its own newer i915 driver for intel quick sync video on gemini lake and the kernel changes synology made will have the i915 driver jun made not working

my extra/extra2 for 918+ takes care of this (there is some more description about that in the 1st post)

https://xpenology.com/forum/topic/28321-driver-extension-jun-103b104b-for-dsm623-for-918-3615xs-3617xs/

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.