andymiller6891

Poweredge R510

Recommended Posts

Looking for help with a baremetal install on my R510.

 

I know I can do esxi etc but I have an LSI 9211-8i passing all 8 bays through and don't have anywhere to store the required images etc to make xpenology work through esxi.

 

I have tried juns loader 1.02b and added the 3617xs extra.lzma and it works to start with, but once I install and reboot lan connectivity disappears and I no longer have access.

 

Wondered if someone had any advice??

 

Thanks.

Share this post


Link to post
Share on other sites

that's fine I did that, but then the guides I followed said I needed to provide a small hdd volume for the xpenology boot volume, but being as I want to pass through all the disks to xpenology I have no option to do this.

 

Share this post


Link to post
Share on other sites

As long as the USB drive is big enough to host the both the esxi host, and a "datastore" (or using 2 USB devices?)

you can run the actual VM and the virtual bootdrive (50MB) from USB ,and pass through the remaining drives.

 

Do you have any free internal SATA ports in the server? Then you could add a SSD and use for host and datastore.

 

Share this post


Link to post
Share on other sites

hi.

 

Thanks for the reply, the 8 bay R510 has 4 internal sata ports but no way of powering them. but luckily enough I have just this minute resolved the issue, with a combination of updating all the R510 firmware and modifying the grub file to add the sata controller, unsure of which of these solved it but its working and have been able to do all updates. The onboard lan ports arnt working but that's fine and expected.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

I got it all working, andy. 

 

I also am running a R510 with all 14 bays (12x 3.5s and 2x2.5s internal) working with onboard broadcom nic as well as my connectx-2 10Gbe as well.

 

1) make sure you are using 1.02b

2) make sure you are going only up to 6.1.7 update 2.  Do not go into 6.2

3) download the extra.lzma that IG-88 made in the loader extra section of this forum

4) follow instructions to load the extra.lzma into the 2nd partition (30MB) of the synoboot.img

 

You should be able to boot and install just fine with all that done.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Also note that the internal SATAs do not work if you have the 12-bay model of the r510 with h200/h310 cards.

Share this post


Link to post
Share on other sites

I have it working on 1.03b and fully updated without needing the extra LZMA, I don't care the onboard ports don't work as im about to purchase a 10gb nic, it would be interesting to see if the extra lzma will make the onboard ports work on 1.03 just out of curiosity.

 

I also have the 8 bay model with an lsi 9211-81 flashed into IT mode and it all works fine.

 

Share this post


Link to post
Share on other sites

Which particualr 1.03b are you using? because as I know the 1.03b loader doesn't work with the broadcom on the r510.  Did you throw in an extra NIC for test?

Share this post


Link to post
Share on other sites
On 2/16/2019 at 3:31 AM, andymiller6891 said:

I’m running it on a Mellanox 10gb card

good to know.  I have a Connectx-3 or x520-DA1 that i can throw in to make it compatible with 1.03B, but are you running 6.2.1? DS3617xs? or DS3615xs?

Share this post


Link to post
Share on other sites

It was 1.03 but I have since temporarily moved away from Xpenology while I source a new server with more compatable network hardware. Have seen some dual 2011 Supermicro servers with quad i350 intel ports and embedded sas hba that I will be grabbing in the next few days. As I wanted to have a few VM’s running having multiple onboard network ports not working with Xpenology was to much of a drawback plus I have a few 250gb ssds come available from one of my gaming rigs that I would like to repurpose as cache.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.